summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-23 07:43:38 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-23 07:43:38 +0200
commit925ffaf5ba72af6b19499a2bc95da581f61b2ae8 (patch)
tree7056c0182905e99dc45767f90917e8fcf7159b36
parent062e1a4accf557e5b44f78de2dc00e717db0b22b (diff)
php-pecl-swoole: 1.7.18
-rw-r--r--REFLECTION36
-rw-r--r--php-pecl-swoole.spec7
2 files changed, 35 insertions, 8 deletions
diff --git a/REFLECTION b/REFLECTION
index 0687547..173c978 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
+Extension [ <persistent> extension #155 swoole version 1.7.18 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -42,7 +42,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
Constant [ integer SWOOLE_KEEP ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.17 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.18 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -298,7 +298,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
- Properties [0] {
}
- - Methods [30] {
+ - Methods [31] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -348,6 +348,13 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
}
}
+ Method [ <internal:swoole> public method exist ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $conn_fd ]
+ }
+ }
+
Method [ <internal:swoole> public method sendfile ] {
- Parameters [2] {
@@ -618,7 +625,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
- Static properties [0] {
}
- - Static methods [4] {
+ - Static methods [5] {
Method [ <internal:swoole> static public method wait ] {
}
@@ -630,6 +637,9 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
Method [ <internal:swoole> static public method daemon ] {
}
+
+ Method [ <internal:swoole> static public method setaffinity ] {
+ }
}
- Properties [0] {
@@ -874,7 +884,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
Property [ <default> private $global ]
}
- - Methods [31] {
+ - Methods [32] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -932,6 +942,13 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method exist ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $conn_fd ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method sendfile ] {
- Parameters [2] {
@@ -1188,7 +1205,7 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
- Properties [0] {
}
- - Methods [32] {
+ - Methods [33] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1256,6 +1273,13 @@ Extension [ <persistent> extension #155 swoole version 1.7.17 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method exist ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $conn_fd ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method sendfile ] {
- Parameters [2] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index ce1f6b3..996d693 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,8 +23,8 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.17
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.7.18
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -245,6 +245,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jul 23 2015 Remi Collet <remi@fedoraproject.org> - 1.7.18-1
+- Update to 1.7.18
+
* Mon Jun 01 2015 Remi Collet <remi@fedoraproject.org> - 1.7.17-1
- Update to 1.7.17