summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-30 10:46:05 +0100
committerRemi Collet <remi@remirepo.net>2018-01-30 10:46:05 +0100
commit83c5fd981082d30100886f33b49e5b8cb6810818 (patch)
treed9491734109e409cbc1acc7fc9c7a50e5f7a0175
parentf096058a321aa6928f2882c65b905d7f093ab36b (diff)
v1.10.1
-rw-r--r--REFLECTION197
-rw-r--r--php-pecl-swoole.spec9
2 files changed, 157 insertions, 49 deletions
diff --git a/REFLECTION b/REFLECTION
index 9f1e5cc..45499f6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
+Extension [ <persistent> extension #137 swoole version 1.10.1 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -18,7 +18,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
}
}
- - Constants [60] {
+ - Constants [109] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
@@ -63,7 +63,56 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.23 }
+ Constant [ string SWOOLE_VERSION ] { 1.10.1 }
+ Constant [ integer SWOOLE_ERROR_MALLOC_FAIL ] { 501 }
+ Constant [ integer SWOOLE_ERROR_SYSTEM_CALL_FAIL ] { 502 }
+ Constant [ integer SWOOLE_ERROR_PHP_FATAL_ERROR ] { 503 }
+ Constant [ integer SWOOLE_ERROR_NAME_TOO_LONG ] { 504 }
+ Constant [ integer SWOOLE_ERROR_INVALID_PARAMS ] { 505 }
+ Constant [ integer SWOOLE_ERROR_FILE_NOT_EXIST ] { 700 }
+ Constant [ integer SWOOLE_ERROR_FILE_TOO_LARGE ] { 701 }
+ Constant [ integer SWOOLE_ERROR_FILE_EMPTY ] { 702 }
+ Constant [ integer SWOOLE_ERROR_DNSLOOKUP_DUPLICATE_REQUEST ] { 703 }
+ Constant [ integer SWOOLE_ERROR_DNSLOOKUP_RESOLVE_FAILED ] { 704 }
+ Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_SERVER ] { 1001 }
+ Constant [ integer SWOOLE_ERROR_SESSION_CLOSED_BY_CLIENT ] { 1002 }
+ Constant [ integer SWOOLE_ERROR_SESSION_CLOSING ] { 1003 }
+ Constant [ integer SWOOLE_ERROR_SESSION_CLOSED ] { 1004 }
+ Constant [ integer SWOOLE_ERROR_SESSION_NOT_EXIST ] { 1005 }
+ Constant [ integer SWOOLE_ERROR_SESSION_INVALID_ID ] { 1006 }
+ Constant [ integer SWOOLE_ERROR_SESSION_DISCARD_TIMEOUT_DATA ] { 1007 }
+ Constant [ integer SWOOLE_ERROR_OUTPUT_BUFFER_OVERFLOW ] { 1008 }
+ Constant [ integer SWOOLE_ERROR_SSL_NOT_READY ] { 1009 }
+ Constant [ integer SWOOLE_ERROR_SSL_CANNOT_USE_SENFILE ] { 1010 }
+ Constant [ integer SWOOLE_ERROR_SSL_EMPTY_PEER_CERTIFICATE ] { 1011 }
+ Constant [ integer SWOOLE_ERROR_SSL_VEFIRY_FAILED ] { 1012 }
+ Constant [ integer SWOOLE_ERROR_SSL_BAD_CLIENT ] { 1013 }
+ Constant [ integer SWOOLE_ERROR_SSL_BAD_PROTOCOL ] { 1014 }
+ Constant [ integer SWOOLE_ERROR_PACKAGE_LENGTH_TOO_LARGE ] { 1201 }
+ Constant [ integer SWOOLE_ERROR_DATA_LENGTH_TOO_LARGE ] { 1202 }
+ Constant [ integer SWOOLE_ERROR_TASK_PACKAGE_TOO_BIG ] { 2001 }
+ Constant [ integer SWOOLE_ERROR_TASK_DISPATCH_FAIL ] { 2002 }
+ Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_ID_TOO_BIG ] { 3001 }
+ Constant [ integer SWOOLE_ERROR_HTTP2_STREAM_NO_HEADER ] { 3002 }
+ Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_VERSION ] { 7001 }
+ Constant [ integer SWOOLE_ERROR_SOCKS5_UNSUPPORT_METHOD ] { 7002 }
+ Constant [ integer SWOOLE_ERROR_SOCKS5_AUTH_FAILED ] { 7003 }
+ Constant [ integer SWOOLE_ERROR_SOCKS5_SERVER_ERROR ] { 7004 }
+ Constant [ integer SWOOLE_ERROR_HTTP_PROXY_HANDSHAKE_ERROR ] { 8001 }
+ Constant [ integer SWOOLE_ERROR_HTTP_INVALID_PROTOCOL ] { 8002 }
+ Constant [ integer SWOOLE_ERROR_WEBSOCKET_BAD_CLIENT ] { 8501 }
+ Constant [ integer SWOOLE_ERROR_WEBSOCKET_BAD_OPCODE ] { 8502 }
+ Constant [ integer SWOOLE_ERROR_WEBSOCKET_UNCONNECTED ] { 8503 }
+ Constant [ integer SWOOLE_ERROR_WEBSOCKET_HANDSHAKE_FAILED ] { 8504 }
+ Constant [ integer SWOOLE_ERROR_SERVER_MUST_CREATED_BEFORE_CLIENT ] { 9001 }
+ Constant [ integer SWOOLE_ERROR_SERVER_TOO_MANY_SOCKET ] { 9002 }
+ Constant [ integer SWOOLE_ERROR_SERVER_WORKER_TERMINATED ] { 9003 }
+ Constant [ integer SWOOLE_ERROR_SERVER_INVALID_LISTEN_PORT ] { 9004 }
+ Constant [ integer SWOOLE_ERROR_SERVER_TOO_MANY_LISTEN_PORT ] { 9005 }
+ Constant [ integer SWOOLE_ERROR_SERVER_PIPE_BUFFER_FULL ] { 9006 }
+ Constant [ integer SWOOLE_ERROR_SERVER_NO_IDLE_WORKER ] { 9007 }
+ Constant [ integer SWOOLE_ERROR_SERVER_ONLY_START_ONE ] { 9008 }
+ Constant [ integer SWOOLE_ERROR_SERVER_WORKER_EXIT_TIMEOUT ] { 9009 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -144,6 +193,12 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Parameter #0 [ <required> $callback ]
}
}
+ Function [ <internal:swoole> function swoole_event_cycle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
Function [ <internal:swoole> function swoole_timer_after ] {
- Parameters [3] {
@@ -254,8 +309,9 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
}
Function [ <internal:swoole> function swoole_strerror ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $errno ]
+ Parameter #1 [ <optional> $error_type ]
}
}
Function [ <internal:swoole> function swoole_errno ] {
@@ -674,7 +730,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
- Static properties [0] {
}
- - Static methods [7] {
+ - Static methods [8] {
Method [ <internal:swoole> static public method add ] {
- Parameters [4] {
@@ -728,6 +784,13 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Parameter #0 [ <required> $callback ]
}
}
+
+ Method [ <internal:swoole> static public method cycle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callback ]
+ }
+ }
}
- Properties [0] {
@@ -829,7 +892,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
@@ -866,6 +929,12 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
}
}
+ Method [ <internal:swoole, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:swoole, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
@@ -965,7 +1034,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
- Static methods [0] {
}
- - Properties [15] {
+ - Properties [16] {
Property [ <default> public $onConnect ]
Property [ <default> public $onReceive ]
Property [ <default> public $onClose ]
@@ -981,6 +1050,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Property [ <default> public $type ]
Property [ <default> public $sock ]
Property [ <default> public $setting ]
+ Property [ <default> public $connections ]
}
- Methods [7] {
@@ -1027,11 +1097,14 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> class swoole_client ] {
- - Constants [4] {
- Constant [ integer MSG_OOB ] { 1 }
- Constant [ integer MSG_PEEK ] { 2 }
- Constant [ integer MSG_DONTWAIT ] { 64 }
- Constant [ integer MSG_WAITALL ] { 256 }
+ - Constants [7] {
+ Constant [ public integer MSG_OOB ] { 1 }
+ Constant [ public integer MSG_PEEK ] { 2 }
+ Constant [ public integer MSG_DONTWAIT ] { 64 }
+ Constant [ public integer MSG_WAITALL ] { 256 }
+ Constant [ public integer SHUT_RDWR ] { 2 }
+ Constant [ public integer SHUT_RD ] { 0 }
+ Constant [ public integer SHUT_WR ] { 1 }
}
- Static properties [0] {
@@ -1057,7 +1130,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Property [ <default> public $onSSLReady ]
}
- - Methods [22] {
+ - Methods [23] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [2] {
@@ -1154,6 +1227,13 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
}
}
+ Method [ <internal:swoole> public method shutdown ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $how ]
+ }
+ }
+
Method [ <internal:swoole> public method enableSSL ] {
- Parameters [1] {
@@ -1386,8 +1466,12 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> class swoole_process ] {
- - Constants [1] {
- Constant [ integer IPC_NOWAIT ] { 256 }
+ - Constants [5] {
+ Constant [ public integer IPC_NOWAIT ] { 256 }
+ Constant [ public integer PIPE_MASTER ] { 1 }
+ Constant [ public integer PIPE_WORKER ] { 2 }
+ Constant [ public integer PIPE_READ ] { 3 }
+ Constant [ public integer PIPE_WRITE ] { 4 }
}
- Static properties [0] {
@@ -1559,9 +1643,9 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> <iterateable> class swoole_table implements ArrayAccess, Iterator, Traversable, Countable ] {
- Constants [3] {
- Constant [ integer TYPE_INT ] { 1 }
- Constant [ integer TYPE_STRING ] { 7 }
- Constant [ integer TYPE_FLOAT ] { 6 }
+ Constant [ public integer TYPE_INT ] { 1 }
+ Constant [ public integer TYPE_STRING ] { 7 }
+ Constant [ public integer TYPE_FLOAT ] { 6 }
}
- Static properties [0] {
@@ -1787,11 +1871,11 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> class swoole_lock ] {
- Constants [5] {
- Constant [ integer FILELOCK ] { 2 }
- Constant [ integer MUTEX ] { 3 }
- Constant [ integer SEM ] { 4 }
- Constant [ integer RWLOCK ] { 1 }
- Constant [ integer SPINLOCK ] { 5 }
+ Constant [ public integer FILELOCK ] { 2 }
+ Constant [ public integer MUTEX ] { 3 }
+ Constant [ public integer SEM ] { 4 }
+ Constant [ public integer RWLOCK ] { 1 }
+ Constant [ public integer SPINLOCK ] { 5 }
}
- Static properties [0] {
@@ -2673,7 +2757,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Property [ <default> public $setting ]
}
- - Methods [42] {
+ - Methods [43] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -2699,6 +2783,13 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
}
}
+ Method [ <internal:swoole> public method isEstablished ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_http_server, prototype swoole_server> public method start ] {
- Parameters [0] {
@@ -3013,12 +3104,12 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> class swoole_mysql ] {
- Constants [6] {
- Constant [ integer STATE_QUERY ] { 0 }
- Constant [ integer STATE_READ_START ] { 1 }
- Constant [ integer STATE_READ_FIELD ] { 2 }
- Constant [ integer STATE_READ_ROW ] { 3 }
- Constant [ integer STATE_READ_END ] { 4 }
- Constant [ integer STATE_CLOSED ] { 5 }
+ Constant [ public integer STATE_QUERY ] { 0 }
+ Constant [ public integer STATE_READ_START ] { 1 }
+ Constant [ public integer STATE_READ_FIELD ] { 2 }
+ Constant [ public integer STATE_READ_ROW ] { 3 }
+ Constant [ public integer STATE_READ_END ] { 4 }
+ Constant [ public integer STATE_CLOSED ] { 5 }
}
- Static properties [0] {
@@ -3255,11 +3346,14 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> class swoole_http2_client extends swoole_client ] {
- - Constants [4] {
- Constant [ integer MSG_OOB ] { 1 }
- Constant [ integer MSG_PEEK ] { 2 }
- Constant [ integer MSG_DONTWAIT ] { 64 }
- Constant [ integer MSG_WAITALL ] { 256 }
+ - Constants [7] {
+ Constant [ public integer MSG_OOB ] { 1 }
+ Constant [ public integer MSG_PEEK ] { 2 }
+ Constant [ public integer MSG_DONTWAIT ] { 64 }
+ Constant [ public integer MSG_WAITALL ] { 256 }
+ Constant [ public integer SHUT_RDWR ] { 2 }
+ Constant [ public integer SHUT_RD ] { 0 }
+ Constant [ public integer SHUT_WR ] { 1 }
}
- Static properties [0] {
@@ -3287,7 +3381,7 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Property [ <default> public $cookies ]
}
- - Methods [33] {
+ - Methods [34] {
Method [ <internal:swoole, overwrites swoole_client, ctor> public method __construct ] {
}
@@ -3409,6 +3503,13 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_client> public method shutdown ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $how ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_client> public method enableSSL ] {
- Parameters [1] {
@@ -3526,11 +3627,11 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> class swoole_redis ] {
- Constants [5] {
- Constant [ integer STATE_CONNECT ] { 0 }
- Constant [ integer STATE_READY ] { 1 }
- Constant [ integer STATE_WAIT_RESULT ] { 2 }
- Constant [ integer STATE_SUBSCRIBE ] { 3 }
- Constant [ integer STATE_CLOSED ] { 4 }
+ Constant [ public integer STATE_CONNECT ] { 0 }
+ Constant [ public integer STATE_READY ] { 1 }
+ Constant [ public integer STATE_WAIT_RESULT ] { 2 }
+ Constant [ public integer STATE_SUBSCRIBE ] { 3 }
+ Constant [ public integer STATE_CLOSED ] { 4 }
}
- Static properties [0] {
@@ -3607,13 +3708,13 @@ Extension [ <persistent> extension #81 swoole version 1.9.23 ] {
Class [ <internal:swoole> class swoole_redis_server extends swoole_server ] {
- Constants [7] {
- Constant [ integer NIL ] { 1 }
- Constant [ integer ERROR ] { 0 }
- Constant [ integer STATUS ] { 2 }
- Constant [ integer INT ] { 3 }
- Constant [ integer STRING ] { 4 }
- Constant [ integer SET ] { 5 }
- Constant [ integer MAP ] { 6 }
+ Constant [ public integer NIL ] { 1 }
+ Constant [ public integer ERROR ] { 0 }
+ Constant [ public integer STATUS ] { 2 }
+ Constant [ public integer INT ] { 3 }
+ Constant [ public integer STRING ] { 4 }
+ Constant [ public integer SET ] { 5 }
+ Constant [ public integer MAP ] { 6 }
}
- Static properties [0] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 2304052..8cf11b2 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -6,6 +6,10 @@
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-swoole
@@ -32,7 +36,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.10.0
+Version: 1.10.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -312,6 +316,9 @@ cd ../ZTS
%changelog
+* Tue Jan 30 2018 Remi Collet <remi@remirepo.net> - 1.10.1-1
+- Update to 1.10.1
+
* Mon Jan 8 2018 Remi Collet <remi@remirepo.net> - 1.10.0-1
- Update to 1.10.0 (beta)