summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-01 10:30:12 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-01 10:30:12 +0200
commit73ddf5b1451e619ff8ed28dfe5f447b4b7e5a5df (patch)
tree8135da53aeeb8859f97dea0b81bd9b94da662b91
parent7a7496d927a79602a0030114b74af8a6b5fb8f9c (diff)
php-pecl-swoole: 1.8.10
-rw-r--r--REFLECTION105
-rw-r--r--php-pecl-swoole.spec14
-rw-r--r--swoole-upstream.patch50
3 files changed, 77 insertions, 92 deletions
diff --git a/REFLECTION b/REFLECTION
index 19e6445..c9d992a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
+Extension [ <persistent> extension #115 swoole version 1.8.10 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.8.8 }
+ Constant [ string SWOOLE_VERSION ] { 1.8.10 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -254,13 +254,13 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
- Properties [0] {
}
- - Methods [36] {
+ - Methods [38] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <required> $serv_host ]
- Parameter #1 [ <required> $serv_port ]
- Parameter #2 [ <optional> $serv_mode ]
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $sock_type ]
}
}
@@ -307,7 +307,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole> public method send ] {
- Parameters [3] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
Parameter #2 [ <optional> $from_id ]
}
@@ -333,14 +333,14 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole> public method exist ] {
- Parameters [1] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
}
}
Method [ <internal:swoole> public method protect ] {
- Parameters [2] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
Parameter #1 [ <optional> $is_protected ]
}
}
@@ -367,6 +367,20 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
}
}
+ Method [ <internal:swoole> public method pause ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole> public method resume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole> public method task ] {
- Parameters [2] {
@@ -816,7 +830,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Property [ <default> public $sock ]
}
- - Methods [15] {
+ - Methods [16] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
@@ -838,6 +852,9 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole> public method setData ] {
}
+ Method [ <internal:swoole> public method addFile ] {
+ }
+
Method [ <internal:swoole> public method execute ] {
}
@@ -954,7 +971,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
- Properties [0] {
}
- - Methods [18] {
+ - Methods [16] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -1036,18 +1053,6 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
}
}
- Method [ <internal:swoole> public method lock ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:swoole> public method unlock ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:swoole, prototype Iterator> public method rewind ] {
- Parameters [0] {
@@ -1168,7 +1173,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Property [ <default> private $global ]
}
- - Methods [36] {
+ - Methods [38] {
Method [ <internal:swoole, overwrites swoole_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1183,9 +1188,9 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole, inherits swoole_server, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <required> $serv_host ]
- Parameter #1 [ <required> $serv_port ]
- Parameter #2 [ <optional> $serv_mode ]
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $sock_type ]
}
}
@@ -1218,7 +1223,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole, inherits swoole_server> public method send ] {
- Parameters [3] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
Parameter #2 [ <optional> $from_id ]
}
@@ -1244,14 +1249,14 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole, inherits swoole_server> public method exist ] {
- Parameters [1] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
}
}
Method [ <internal:swoole, inherits swoole_server> public method protect ] {
- Parameters [2] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
Parameter #1 [ <optional> $is_protected ]
}
}
@@ -1278,6 +1283,20 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method pause ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method resume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method task ] {
- Parameters [2] {
@@ -1567,7 +1586,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
- Properties [0] {
}
- - Methods [37] {
+ - Methods [39] {
Method [ <internal:swoole, overwrites swoole_http_server, prototype swoole_server> public method on ] {
- Parameters [2] {
@@ -1599,9 +1618,9 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole, inherits swoole_server, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <required> $serv_host ]
- Parameter #1 [ <required> $serv_port ]
- Parameter #2 [ <optional> $serv_mode ]
+ Parameter #0 [ <required> $host ]
+ Parameter #1 [ <required> $port ]
+ Parameter #2 [ <optional> $mode ]
Parameter #3 [ <optional> $sock_type ]
}
}
@@ -1634,7 +1653,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole, inherits swoole_server> public method send ] {
- Parameters [3] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
Parameter #1 [ <required> $send_data ]
Parameter #2 [ <optional> $from_id ]
}
@@ -1660,7 +1679,7 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
Method [ <internal:swoole, inherits swoole_server> public method protect ] {
- Parameters [2] {
- Parameter #0 [ <required> $conn_fd ]
+ Parameter #0 [ <required> $fd ]
Parameter #1 [ <optional> $is_protected ]
}
}
@@ -1687,6 +1706,20 @@ Extension [ <persistent> extension #115 swoole version 1.8.8 ] {
}
}
+ Method [ <internal:swoole, inherits swoole_server> public method pause ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
+ Method [ <internal:swoole, inherits swoole_server> public method resume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fd ]
+ }
+ }
+
Method [ <internal:swoole, inherits swoole_server> public method task ] {
- Parameters [2] {
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index ef69ddd..42d3de0 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -34,15 +34,13 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.8
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.8.10
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-upstream.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 5.3.10
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
@@ -137,8 +135,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
-%patch0 -p1 -b .upstream
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -272,6 +268,12 @@ cd ../ZTS
%changelog
+* Thu Sep 01 2016 Remi Collet <remi@fedoraproject.org> - 1.8.10-1
+- Update to 1.8.10
+
+* Thu Sep 01 2016 Remi Collet <remi@fedoraproject.org> - 1.8.9-1
+- Update to 1.8.9
+
* Thu Jul 28 2016 Remi Collet <remi@fedoraproject.org> - 1.8.8-2
- add upstream patch and add back --enable-http2 build option
diff --git a/swoole-upstream.patch b/swoole-upstream.patch
deleted file mode 100644
index fa98e35..0000000
--- a/swoole-upstream.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 8b86b44ada511935dd1fb1bd7a2ed3d9c2489f0a Mon Sep 17 00:00:00 2001
-From: matyhtf <mikan.tenny@gmail.com>
-Date: Thu, 28 Jul 2016 13:12:58 +0800
-Subject: [PATCH] fixed #787, compile failed with --enable-http2
-
----
- swoole_http_v2_server.c | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/swoole_http_v2_server.c b/swoole_http_v2_server.c
-index bcbea68..b04ffd7 100644
---- a/swoole_http_v2_server.c
-+++ b/swoole_http_v2_server.c
-@@ -30,7 +30,7 @@ static sw_inline void http2_add_header(nghttp2_nv *headers, char *k, int kl, cha
- headers->valuelen = vl;
- }
-
--static void http2_onRequest(http_context *ctx TSRMLS_DC)
-+static sw_inline void http2_onRequest(http_context *ctx, int server_fd TSRMLS_DC)
- {
- zval *retval;
- zval **args[2];
-@@ -41,7 +41,8 @@ static void http2_onRequest(http_context *ctx TSRMLS_DC)
- args[0] = &zrequest_object;
- args[1] = &zresponse_object;
-
-- if (sw_call_user_function_ex(EG(function_table), NULL, php_sw_http_server_callbacks[HTTP_CALLBACK_onRequest], &retval, 2, args, 0, NULL TSRMLS_CC) == FAILURE)
-+ zval *zcallback = php_swoole_server_get_callback(SwooleG.serv, server_fd, SW_SERVER_CB_onRequest);
-+ if (sw_call_user_function_ex(EG(function_table), NULL, zcallback, &retval, 2, args, 0, NULL TSRMLS_CC) == FAILURE)
- {
- php_error_docref(NULL TSRMLS_CC, E_WARNING, "onRequest handler error");
- }
-@@ -509,7 +510,7 @@ int swoole_http2_onFrame(swoole_http_client *client, swEventData *req)
-
- if (flags & SW_HTTP2_FLAG_END_STREAM)
- {
-- http2_onRequest(ctx TSRMLS_CC);
-+ http2_onRequest(ctx, req->info.from_fd TSRMLS_CC);
- }
- else
- {
-@@ -557,7 +558,7 @@ int swoole_http2_onFrame(swoole_http_client *client, swEventData *req)
- swoole_php_fatal_error(E_WARNING, "parse multipart body failed.");
- }
- }
-- http2_onRequest(ctx TSRMLS_CC);
-+ http2_onRequest(ctx, req->info.from_fd TSRMLS_CC);
- }
- }
- else if (type == SW_HTTP2_TYPE_PING)