summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-03-18 16:21:57 +0100
committerRemi Collet <fedora@famillecollet.com>2015-03-18 16:21:57 +0100
commit6dae84da412cc9bce704f3306b661898aef767ac (patch)
tree579dde6211d68ee126d9f1299dfa4ca0c003fa99
parent4922b2887476a01ab16eb9e56ecf843e90a92f64 (diff)
php-pecl-swoole: 1.7.13
-rw-r--r--REFLECTION24
-rw-r--r--php-pecl-swoole.spec14
2 files changed, 21 insertions, 17 deletions
diff --git a/REFLECTION b/REFLECTION
index a83e091..20d6a74 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #148 swoole version 1.7.12 ] {
+Extension [ <persistent> extension #153 swoole version 1.7.13 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -48,7 +48,7 @@ Extension [ <persistent> extension #148 swoole version 1.7.12 ] {
Constant [ integer SWOOLE_SSL ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.7.12 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.13 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_GCC ] { 1 }
Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
@@ -96,15 +96,6 @@ Extension [ <persistent> extension #148 swoole version 1.7.12 ] {
Parameter #3 [ <optional> $from_id ]
}
}
- Function [ <internal:swoole> function swoole_server_sendto ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> swoole_server $zobject ]
- Parameter #1 [ <required> $ip ]
- Parameter #2 [ <required> $port ]
- Parameter #3 [ <optional> $send_data ]
- }
- }
Function [ <internal:swoole> function swoole_server_sendfile ] {
- Parameters [3] {
@@ -643,7 +634,7 @@ Extension [ <persistent> extension #148 swoole version 1.7.12 ] {
Property [ <default> public $sock ]
}
- - Methods [8] {
+ - Methods [11] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
@@ -659,9 +650,18 @@ Extension [ <persistent> extension #148 swoole version 1.7.12 ] {
Method [ <internal:swoole> public method sendfile ] {
}
+ Method [ <internal:swoole> public method sendto ] {
+ }
+
Method [ <internal:swoole> public method isConnected ] {
}
+ Method [ <internal:swoole> public method getsockname ] {
+ }
+
+ Method [ <internal:swoole> public method getpeername ] {
+ }
+
Method [ <internal:swoole> public method close ] {
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 0df8111..b751a12 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,7 +23,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.12
+Version: 1.7.13
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
@@ -97,7 +97,11 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -q -c
mv %{pecl_name}-%{version} NTS
-sed -e '/examples/s/role="src"/role="doc"/' -i package.xml
+# Don't install/register tests, install examples as doc
+sed -e 's/role="test"/role="src"/' \
+ -e '/examples/s/role="src"/role="doc"/' \
+ -i package.xml
+
cd NTS
@@ -179,9 +183,6 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
-
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -240,6 +241,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 18 2015 Remi Collet <remi@fedoraproject.org> - 1.7.13-1
+- Update to 1.7.13
+
* Thu Mar 12 2015 Remi Collet <remi@fedoraproject.org> - 1.7.12-1
- Update to 1.7.12