summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-10 09:41:09 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-10 09:41:09 +0200
commit4cda4570bd72ab3a448fc8299d64f7bada932483 (patch)
tree383fe9450d5a3dfeb0c53b31d3fc6a442d089aab
parentfa10bc34a48d2f4633d9add95a0bedef72e73b5f (diff)
php-pecl-swoole: 1.7.5
-rw-r--r--REFLECTION287
-rw-r--r--php-pecl-swoole.spec32
2 files changed, 258 insertions, 61 deletions
diff --git a/REFLECTION b/REFLECTION
index 90b582e..34c83aa 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
+Extension [ <persistent> extension #146 swoole version 1.7.5 ] {
- INI {
Entry [ swoole.task_worker_num <ALL> ]
@@ -18,7 +18,7 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
}
}
- - Constants [36] {
+ - Constants [33] {
Constant [ integer SWOOLE_BASE ] { 4 }
Constant [ integer SWOOLE_THREAD ] { 2 }
Constant [ integer SWOOLE_PROCESS ] { 3 }
@@ -35,10 +35,10 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
Constant [ integer SWOOLE_UDP6 ] { 4 }
Constant [ integer SWOOLE_UNIX_DGRAM ] { 5 }
Constant [ integer SWOOLE_UNIX_STREAM ] { 6 }
- Constant [ integer SWOOLE_RWLOCK ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
Constant [ integer SWOOLE_MUTEX ] { 3 }
Constant [ integer SWOOLE_SEM ] { 4 }
+ Constant [ integer SWOOLE_RWLOCK ] { 1 }
Constant [ integer SWOOLE_SPINLOCK ] { 5 }
Constant [ integer SWOOLE_SOCK_SYNC ] { 0 }
Constant [ integer SWOOLE_SOCK_ASYNC ] { 1 }
@@ -48,18 +48,17 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
Constant [ integer SWOOLE_SSL ] { 512 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ integer SWOOLE_SIGN ] { 64 }
- Constant [ integer SWOOLE_UNSIGN ] { 32 }
- Constant [ integer SWOOLE_NET ] { 8 }
- Constant [ integer SWOOLE_HOST ] { 16 }
- Constant [ integer SWOOLE_SHORT ] { 2 }
- Constant [ integer SWOOLE_INT ] { 4 }
- Constant [ string SWOOLE_VERSION ] { 1.7.4 }
+ Constant [ string SWOOLE_VERSION ] { 1.7.5 }
+ Constant [ integer SWOOLE_AIO_BASE ] { 0 }
+ Constant [ integer SWOOLE_AIO_GCC ] { 1 }
+ Constant [ integer SWOOLE_AIO_LINUX ] { 2 }
}
- Functions {
Function [ <internal:swoole> function swoole_version ] {
}
+ Function [ <internal:swoole> function swoole_cpu_num ] {
+ }
Function [ <internal:swoole> function swoole_server_create ] {
- Parameters [4] {
@@ -145,6 +144,8 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
Parameter #1 [ <required> $interval ]
}
}
+ Function [ <internal:swoole> function swoole_server_gettimer ] {
+ }
Function [ <internal:swoole> function swoole_server_task ] {
- Parameters [3] {
@@ -242,6 +243,8 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
Parameter #0 [ <required> $interval ]
}
}
+ Function [ <internal:swoole> function swoole_async_set ] {
+ }
Function [ <internal:swoole> function swoole_async_read ] {
}
Function [ <internal:swoole> function swoole_async_write ] {
@@ -266,44 +269,7 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
}
}
- - Classes [4] {
- Class [ <internal:swoole> class swoole_client ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [2] {
- Property [ <default> public $errCode ]
- Property [ <default> public $sock ]
- }
-
- - Methods [6] {
- Method [ <internal:swoole, ctor> public method __construct ] {
- }
-
- Method [ <internal:swoole> public method connect ] {
- }
-
- Method [ <internal:swoole> public method recv ] {
- }
-
- Method [ <internal:swoole> public method send ] {
- }
-
- Method [ <internal:swoole> public method close ] {
- }
-
- Method [ <internal:swoole> public method on ] {
- }
- }
- }
-
+ - Classes [6] {
Class [ <internal:swoole> class swoole_server ] {
- Constants [0] {
@@ -318,7 +284,7 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
- Properties [0] {
}
- - Methods [20] {
+ - Methods [22] {
Method [ <internal:swoole, ctor> public method __construct ] {
- Parameters [4] {
@@ -413,6 +379,9 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
}
}
+ Method [ <internal:swoole> public method gettimer ] {
+ }
+
Method [ <internal:swoole> public method reload ] {
- Parameters [0] {
@@ -470,6 +439,9 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
Parameter #1 [ <required> $find_count ]
}
}
+
+ Method [ <internal:swoole> public method stats ] {
+ }
}
}
@@ -516,21 +488,27 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
- Static properties [0] {
}
- - Static methods [2] {
+ - Static methods [3] {
Method [ <internal:swoole> static public method wait ] {
}
Method [ <internal:swoole> static public method kill ] {
}
+
+ Method [ <internal:swoole> static public method daemon ] {
+ }
}
- Properties [0] {
}
- - Methods [6] {
+ - Methods [9] {
Method [ <internal:swoole, ctor> public method __construct ] {
}
+ Method [ <internal:swoole> public method useQueue ] {
+ }
+
Method [ <internal:swoole> public method start ] {
}
@@ -540,6 +518,12 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
Method [ <internal:swoole> public method read ] {
}
+ Method [ <internal:swoole> public method push ] {
+ }
+
+ Method [ <internal:swoole> public method pop ] {
+ }
+
Method [ <internal:swoole> public method exit ] {
}
@@ -547,6 +531,207 @@ Extension [ <persistent> extension #142 swoole version 1.7.4 ] {
}
}
}
+
+ Class [ <internal:swoole> class swoole_buffer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole> public method substr ] {
+ }
+
+ Method [ <internal:swoole> public method read ] {
+ }
+
+ Method [ <internal:swoole> public method write ] {
+ }
+
+ Method [ <internal:swoole> public method append ] {
+ }
+
+ Method [ <internal:swoole> public method expand ] {
+ }
+
+ Method [ <internal:swoole> public method clear ] {
+ }
+ }
+ }
+
+ Class [ <internal:swoole> class swoole_client ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> public $errCode ]
+ Property [ <default> public $sock ]
+ }
+
+ - Methods [8] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+ }
+
+ Method [ <internal:swoole> public method connect ] {
+ }
+
+ Method [ <internal:swoole> public method recv ] {
+ }
+
+ Method [ <internal:swoole> public method send ] {
+ }
+
+ Method [ <internal:swoole> public method sendfile ] {
+ }
+
+ Method [ <internal:swoole> public method isConnected ] {
+ }
+
+ Method [ <internal:swoole> public method close ] {
+ }
+
+ Method [ <internal:swoole> public method on ] {
+ }
+ }
+ }
+
+ Class [ <internal:swoole> <iterateable> class swoole_table implements Iterator, Traversable, Countable ] {
+
+ - Constants [10] {
+ Constant [ integer TYPE_INT ] { 1 }
+ Constant [ integer TYPE_STRING ] { 7 }
+ Constant [ integer TYPE_FLOAT ] { 6 }
+ Constant [ integer FIND_GT ] { 3 }
+ Constant [ integer FIND_LT ] { 4 }
+ Constant [ integer FIND_EQ ] { 1 }
+ Constant [ integer FIND_NEQ ] { 2 }
+ Constant [ integer FIND_LEFTLIKE ] { 5 }
+ Constant [ integer FIND_RIGHTLIKE ] { 6 }
+ Constant [ integer FIND_LIKE ] { 7 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [14] {
+ Method [ <internal:swoole, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $table_size ]
+ }
+ }
+
+ Method [ <internal:swoole> public method column ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $type ]
+ Parameter #2 [ <optional> $size ]
+ }
+ }
+
+ Method [ <internal:swoole> public method create ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:swoole> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:swoole, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole, prototype Countable> public method count ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $mode ]
+ }
+ }
+
+ Method [ <internal:swoole> public method del ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:swoole> public method lock ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:swoole> public method unlock ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index dba5c54..e518f27 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -23,8 +23,8 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.7.4
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.7.5
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -47,6 +47,7 @@ Requires: %{?scl_prefix}php-common%{?_isa}
%else
Requires: %{?scl_prefix}php-sockets%{?_isa}
%endif
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -77,14 +78,20 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%description
-PHP's asynchronous concurrent distributed networking framework.
-- Event-driven
-- Asynchronous non-blocking
-- Multi-Thread reactor
-- Multi-Process worker
-- Millisecond timer
-- Asynchronous MySQL
-- AsyncTask workers
+Asynchronous and concurrent and distributed networking framework for PHP.
+- event-driven
+- full asynchronous non-blocking
+- multi-thread reactor
+- multi-process worker
+- millisecond timer
+- async MySQL
+- async task
+- async read/write file system
+- async dns lookup
+- support IPv4/IPv6/UnixSocket/TCP/UDP
+- SSL/TLS encrypted transmission
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
%prep
@@ -210,8 +217,10 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
+
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -222,6 +231,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Sep 10 2014 Remi Collet <remi@fedoraproject.org> - 1.7.5-1
+- Update to 1.7.5
+
* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 1.7.4-2
- improve SCL build