summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-06 11:43:15 +0200
committerRemi Collet <remi@remirepo.net>2017-06-06 11:43:15 +0200
commit2bf1ba801644c6549b26c9bf136ae00acfc346ab (patch)
tree8cde4960793a9b92c85e6c1578fa149f6fa91e14
parent372dc3d3255345cbd56d0b17f65ef3cc5e3e2da6 (diff)
v1.9.12
-rw-r--r--0d538227be3d9ff16e4af886cc6ab015380deefd.patch40
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-swoole.spec10
3 files changed, 7 insertions, 47 deletions
diff --git a/0d538227be3d9ff16e4af886cc6ab015380deefd.patch b/0d538227be3d9ff16e4af886cc6ab015380deefd.patch
deleted file mode 100644
index 2484e1d..0000000
--- a/0d538227be3d9ff16e4af886cc6ab015380deefd.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 0d538227be3d9ff16e4af886cc6ab015380deefd Mon Sep 17 00:00:00 2001
-From: guoxinhua <guoxinhua@10.10.12.142>
-Date: Sat, 27 May 2017 14:57:41 +0800
-Subject: [PATCH] add sse test
-
----
- swoole_serialize.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/swoole_serialize.c b/swoole_serialize.c
-index ceeccc88..5fc48617 100644
---- a/swoole_serialize.c
-+++ b/swoole_serialize.c
-@@ -16,7 +16,9 @@
-
- #include "php_swoole.h"
- #include "swoole_serialize.h"
-+#ifdef __SSE2__
- #include <emmintrin.h>
-+#endif
-
- #if PHP_MAJOR_VERSION >= 7
- #define CPINLINE sw_inline
-@@ -101,7 +103,7 @@ static CPINLINE void swoole_check_size(seriaString *str, size_t len)
- str->total = new_size;
- }
- }
--
-+#ifdef __SSE2__
- void CPINLINE swoole_mini_memcpy(void *dst, const void *src, size_t len)
- {
- register unsigned char *dd = (unsigned char*) dst + len;
-@@ -255,6 +257,7 @@ void CPINLINE swoole_memcpy_fast(void *destination, const void *source, size_t s
-
- // return memcpy_tiny(dst, src, size);
- }
-+#endif
-
- static CPINLINE void swoole_string_cpy(seriaString *str, void *mem, size_t len)
- {
diff --git a/REFLECTION b/REFLECTION
index 1033612..1dbbcf2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #80 swoole version 1.9.11 ] {
+Extension [ <persistent> extension #80 swoole version 1.9.12 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #80 swoole version 1.9.11 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.9.11 }
+ Constant [ string SWOOLE_VERSION ] { 1.9.12 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index a334cf0..f428e5e 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -32,15 +32,13 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.9.11
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.9.12
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: 0d538227be3d9ff16e4af886cc6ab015380deefd.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 5.3.10
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
@@ -156,7 +154,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
-%patch0 -p1 -b .upstream
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SWOOLE_VERSION/{s/.* "//;s/".*$//;p}' php_swoole.h)
@@ -310,6 +307,9 @@ cd ../ZTS
%changelog
+* Tue Jun 6 2017 Remi Collet <remi@remirepo.net> - 1.9.12-1
+- Update to 1.9.12
+
* Tue May 30 2017 Remi Collet <remi@remirepo.net> - 1.9.11-2
- rebuild (for 7.2)