summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-01 14:09:33 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-01 14:09:33 +0200
commit024e21759831a37f8f79236cae8bd0306b4b1db1 (patch)
tree3bec3c63a31e46d2fa504e09a4780927c1d39266
parentc141b58e37a1fc5d7edf88113916e046693361e9 (diff)
php-pecl-swoole: 1.8.7
-rw-r--r--REFLECTION39
-rw-r--r--php-pecl-swoole.spec5
2 files changed, 30 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
index 833751b..75144e7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
+Extension [ <persistent> extension #113 swoole version 1.8.7 ] {
- INI {
Entry [ swoole.aio_thread_num <ALL> ]
@@ -63,7 +63,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
Constant [ integer SWOOLE_DTLSv1_CLIENT_METHOD ] { 17 }
Constant [ integer SWOOLE_EVENT_READ ] { 512 }
Constant [ integer SWOOLE_EVENT_WRITE ] { 1024 }
- Constant [ string SWOOLE_VERSION ] { 1.8.6 }
+ Constant [ string SWOOLE_VERSION ] { 1.8.7 }
Constant [ integer SWOOLE_AIO_BASE ] { 0 }
Constant [ integer SWOOLE_AIO_LINUX ] { 1 }
Constant [ integer SWOOLE_FILELOCK ] { 2 }
@@ -141,6 +141,12 @@ Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
Parameter #1 [ <required> $callback ]
}
}
+ Function [ <internal:swoole> function swoole_timer_exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
+ }
Function [ <internal:swoole> function swoole_timer_clear ] {
- Parameters [1] {
@@ -504,7 +510,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
- Static properties [0] {
}
- - Static methods [3] {
+ - Static methods [4] {
Method [ <internal:swoole> static public method tick ] {
- Parameters [3] {
@@ -522,6 +528,13 @@ Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
}
}
+ Method [ <internal:swoole> static public method exists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timer_id ]
+ }
+ }
+
Method [ <internal:swoole> static public method clear ] {
- Parameters [1] {
@@ -1749,7 +1762,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
}
}
- Class [ <internal:swoole> class swoole_mysql_exception extends Exception ] {
+ Class [ <internal:swoole> class swoole_mysql_exception extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -1768,7 +1781,7 @@ Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
Parameter #0 [ <optional> $message ]
@@ -1780,28 +1793,28 @@ Extension [ <persistent> extension #166 swoole version 1.8.6 ] {
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
diff --git a/php-pecl-swoole.spec b/php-pecl-swoole.spec
index 4fde2d9..f7cd859 100644
--- a/php-pecl-swoole.spec
+++ b/php-pecl-swoole.spec
@@ -34,7 +34,7 @@
Summary: PHP's asynchronous concurrent distributed networking framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.8.6
+Version: 1.8.7
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -269,6 +269,9 @@ cd ../ZTS
%changelog
+* Fri Jul 01 2016 Remi Collet <remi@fedoraproject.org> - 1.8.7-1
+- Update to 1.8.7
+
* Thu Jun 16 2016 Remi Collet <remi@fedoraproject.org> - 1.8.6-1
- Update to 1.8.6
- drop --enable-async-mysql and --enable-async-httpclient