summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION219
-rw-r--r--php-pecl-svm.spec5
3 files changed, 229 insertions, 1 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..e4bf58d
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+svm
+
+svm extension => enabled
+svm extension version => 0.2.3
+libsvm version => 321
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..d8cf8d1
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,219 @@
+Extension [ <persistent> extension #147 svm version 0.2.3 ] {
+
+ - Classes [3] {
+ Class [ <internal:svm> class svm ] {
+
+ - Constants [22] {
+ Constant [ public integer C_SVC ] { 0 }
+ Constant [ public integer NU_SVC ] { 1 }
+ Constant [ public integer ONE_CLASS ] { 2 }
+ Constant [ public integer EPSILON_SVR ] { 3 }
+ Constant [ public integer NU_SVR ] { 4 }
+ Constant [ public integer KERNEL_LINEAR ] { 0 }
+ Constant [ public integer KERNEL_POLY ] { 1 }
+ Constant [ public integer KERNEL_RBF ] { 2 }
+ Constant [ public integer KERNEL_SIGMOID ] { 3 }
+ Constant [ public integer KERNEL_PRECOMPUTED ] { 4 }
+ Constant [ public integer OPT_TYPE ] { 101 }
+ Constant [ public integer OPT_KERNEL_TYPE ] { 102 }
+ Constant [ public integer OPT_DEGREE ] { 103 }
+ Constant [ public integer OPT_SHRINKING ] { 301 }
+ Constant [ public integer OPT_PROBABILITY ] { 302 }
+ Constant [ public integer OPT_GAMMA ] { 201 }
+ Constant [ public integer OPT_NU ] { 202 }
+ Constant [ public integer OPT_EPS ] { 203 }
+ Constant [ public integer OPT_P ] { 204 }
+ Constant [ public integer OPT_COEF_ZERO ] { 205 }
+ Constant [ public integer OPT_C ] { 206 }
+ Constant [ public integer OPT_CACHE_SIZE ] { 207 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:svm, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:svm> public method getOptions ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:svm> public method setOptions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $params ]
+ }
+ }
+
+ Method [ <internal:svm> public method train ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $problem ]
+ Parameter #1 [ <optional> $weights ]
+ }
+ }
+
+ Method [ <internal:svm> public method crossvalidate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $problem ]
+ Parameter #1 [ <required> $number_of_folds ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:svm> class svmmodel ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [10] {
+ Method [ <internal:svm, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $filename ]
+ }
+ }
+
+ Method [ <internal:svm> public method save ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $filename ]
+ }
+ }
+
+ Method [ <internal:svm> public method load ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $filename ]
+ }
+ }
+
+ Method [ <internal:svm> public method getSvmType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:svm> public method getLabels ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:svm> public method getNrClass ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:svm> public method getSvrProbability ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:svm> public method checkProbabilityModel ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:svm> public method predict ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:svm> public method predict_probability ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> &$probabilities ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:svm> final class svmexception extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-svm.spec b/php-pecl-svm.spec
index 8fd343e..bf96d9d 100644
--- a/php-pecl-svm.spec
+++ b/php-pecl-svm.spec
@@ -18,7 +18,7 @@
Summary: Support Vector Machine Library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.2.2
+Version: 0.2.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
@@ -214,6 +214,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 0.2.3-1
+- update to 0.2.3
+
* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 0.2.2-1
- initial package, version 0.2.2 (beta)
- open https://github.com/ianbarber/php-svm/issues/17 - PHP min