summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 15:56:52 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 15:56:52 +0200
commit4dd491b759443fcf53e6dbf4ace97b7aa7a66957 (patch)
tree36655e1cc825328ac6f615e8817ebf82220bb24c
parentd51b76a7e3eb2d8f327f59725756e8fff1540d5f (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-sundown.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-sundown.spec b/php-pecl-sundown.spec
index 5f07d81..9ffe2e4 100644
--- a/php-pecl-sundown.spec
+++ b/php-pecl-sundown.spec
@@ -14,11 +14,16 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name sundown
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Sundown is a fast, robust Markdown parsing library for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.3.11
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
# Extension is PHP, sundown library is MIT
License: PHP and MIT
Group: Development/Languages
@@ -97,7 +102,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat << 'EOF' | tee %{pecl_name}.ini
+cat << 'EOF' | tee %{ini_name}
; %{summary}
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
@@ -127,7 +132,7 @@ make -C NTS \
install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -136,7 +141,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
make -C ZTS \
install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -218,16 +223,19 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 0.3.11-2
+- add numerical prefix to extension configuration file (php 5.6)
+
* Thu Jan 02 2014 Remi Collet <remi@fedoraproject.org> - 0.3.11-1
- Update to 0.3.11 (beta)