summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-01 08:43:51 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-01 08:43:51 +0100
commit143a39f60d09f9360fcc69cbcf9a74b31bd298d7 (patch)
treec6dc540c549d1a44aced20693beeef9d2adf2b18
parentf90c6b891266dc23ab4633ba113e992eee47cdcc (diff)
php-pecl-strict: 0.4.0
-rw-r--r--REFLECTION79
-rw-r--r--php-pecl-strict.spec7
2 files changed, 83 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index bf1fdd2..19429cc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,3 +1,80 @@
-Extension [ <persistent> extension #146 strict version 0.3.0 ] {
+Extension [ <persistent> extension #185 strict version 0.4.0 ] {
+
+ - Constants [8] {
+ Constant [ integer strict\integer ] { 1 }
+ Constant [ integer strict\int ] { 1 }
+ Constant [ integer strict\double ] { 2 }
+ Constant [ integer strict\float ] { 2 }
+ Constant [ integer strict\boolean ] { 3 }
+ Constant [ integer strict\bool ] { 3 }
+ Constant [ integer strict\string ] { 6 }
+ Constant [ integer strict\resource ] { 7 }
+ }
+
+ - Functions {
+ Function [ <internal:strict> function strict_cast ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $type ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+ }
+
+ - Classes [1] {
+ Class [ <internal:strict> class strict\CastException extends Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [9] {
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+ }
}
diff --git a/php-pecl-strict.spec b/php-pecl-strict.spec
index 551225d..4885b04 100644
--- a/php-pecl-strict.spec
+++ b/php-pecl-strict.spec
@@ -24,8 +24,8 @@
Summary: Strict scalar parameter type hint
Name: %{?scl_prefix}php-pecl-strict
-Version: 0.3.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 0.4.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -226,6 +226,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Dec 01 2014 Remi Collet <remi@fedoraproject.org> - 0.4.0-1
+- Update to 0.4.0
+
* Mon Nov 24 2014 Remi Collet <remi@fedoraproject.org> - 0.3.0-3
- drop conflicts with ionCube Loader