summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-04 08:57:52 +0200
committerRemi Collet <remi@remirepo.net>2017-05-04 08:57:52 +0200
commit03c7c061ef7bdd8b490f3a71970050e5595a60ca (patch)
treefd2f09ec5cde35e5601d8532ca58accf8f9ffedc
parentd432a2d46b2df52eab0258f67b1f31ecec7854ad (diff)
v2.0.1
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-stomp.spec14
-rw-r--r--stomp-upstream.patch56
3 files changed, 10 insertions, 62 deletions
diff --git a/REFLECTION b/REFLECTION
index e062a8a..4595d64 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #78 Stomp version 2.0.0 ] {
+Extension [ <persistent> extension #132 Stomp version 2.0.1 ] {
- INI {
Entry [ stomp.default_broker <ALL> ]
diff --git a/php-pecl-stomp.spec b/php-pecl-stomp.spec
index b06de50..80f4bcb 100644
--- a/php-pecl-stomp.spec
+++ b/php-pecl-stomp.spec
@@ -15,15 +15,13 @@
Summary: Stomp client extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.0
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.0.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-upstream.patch
-
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: openssl-devel
@@ -57,6 +55,10 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -86,7 +88,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .upstream
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_STOMP_VERSION/{s/.* "//;s/".*$//;p}' php_stomp.h)
@@ -212,6 +213,9 @@ fi
%changelog
+* Thu May 4 2017 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- Update to 2.0.1
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-4
- rebuild with PHP 7.1.0 GA
diff --git a/stomp-upstream.patch b/stomp-upstream.patch
deleted file mode 100644
index d53e166..0000000
--- a/stomp-upstream.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 2a6ef9570e309b6d2d58f03ed80e305d7b2ea4cb Mon Sep 17 00:00:00 2001
-From: Pierrick Charron <pierrick@webstart.fr>
-Date: Thu, 9 Jun 2016 13:27:54 -0400
-Subject: [PATCH] Remove useless zend_fcall_info.function_table
-
----
- php_stomp.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/php_stomp.c b/php_stomp.c
-index 96a08db..869e7ed 100644
---- a/php_stomp.c
-+++ b/php_stomp.c
-@@ -963,8 +963,10 @@ PHP_FUNCTION(stomp_read_frame)
- }
-
- fci.size = sizeof(fci);
-+#if (PHP_MAJOR_VERSION == 7 && PHP_MINOR_VERSION == 0)
- fci.function_table = &ce->function_table;
- fci.symbol_table = NULL;
-+#endif
-
- /* PARAMS */
- fci.param_count = 3;
---
-2.1.4
-
-From bd384b27c1ed0b188dd7fd21961d1f31628939cd Mon Sep 17 00:00:00 2001
-From: Pierrick Charron <pierrick@webstart.fr>
-Date: Thu, 9 Jun 2016 13:32:55 -0400
-Subject: [PATCH] get rid of EG(scope). zend_get_executed_scope() should be
- used instead
-
----
- php_stomp.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/php_stomp.c b/php_stomp.c
-index 869e7ed..dcde51f 100644
---- a/php_stomp.c
-+++ b/php_stomp.c
-@@ -982,7 +982,11 @@ PHP_FUNCTION(stomp_read_frame)
-
- fcc.initialized = 1;
- fcc.function_handler = ce->constructor;
-+#if (PHP_MAJOR_VERSION == 7 && PHP_MINOR_VERSION == 0)
- fcc.calling_scope = EG(scope);
-+#else
-+ fcc.calling_scope = zend_get_executed_scope();
-+#endif
- fcc.object = Z_OBJ_P(return_value);
-
- if (zend_call_function(&fci, &fcc ) == FAILURE) {
---
-2.1.4
-