summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-02 17:43:34 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-02 17:43:34 +0200
commitf3fc9c27e6a9ade020e54d208bb0e4e00449d95e (patch)
treedba02d458721c6a257811638810f798d38787299
parent3430d4f196857dd32f877740cb77b4d7ec6e750b (diff)
php-pecl-stats: 1.0.5 and 2.0.3
-rw-r--r--REFLECTION2
-rw-r--r--REFLECTION-PHP72
-rw-r--r--php-pecl-stats-php7.spec7
-rw-r--r--php-pecl-stats.spec8
-rw-r--r--stats-upstream.patch29
5 files changed, 11 insertions, 37 deletions
diff --git a/REFLECTION b/REFLECTION
index bc106fc..608588e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #162 stats version 1.0.4 ] {
+Extension [ <persistent> extension #162 stats version 1.0.5 ] {
- Functions {
Function [ <internal:stats> function stats_cdf_t ] {
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 3075e29..d7fbc3c 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #77 stats version 2.0.2 ] {
+Extension [ <persistent> extension #77 stats version 2.0.3 ] {
- Functions {
Function [ <internal:stats> function stats_cdf_t ] {
diff --git a/php-pecl-stats-php7.spec b/php-pecl-stats-php7.spec
index 9ee72e2..ac6b16c 100644
--- a/php-pecl-stats-php7.spec
+++ b/php-pecl-stats-php7.spec
@@ -14,7 +14,7 @@
Summary: Routines for statistical computation
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.0.2
+Version: 2.0.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -202,8 +202,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Jun 2 2016 Remi Collet <remi@fedoraproject.org> - 2.0.3-1
+- update to 2.0.3 (php 7, stable)
+
* Sat May 28 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
-- update to 2.0.1 (php 7, stable)
+- update to 2.0.2 (php 7, stable)
* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
- adapt for F24
diff --git a/php-pecl-stats.spec b/php-pecl-stats.spec
index 9ae9e49..b6a533d 100644
--- a/php-pecl-stats.spec
+++ b/php-pecl-stats.spec
@@ -18,15 +18,13 @@
Summary: Routines for statistical computation
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.4
+Version: 1.0.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -83,7 +81,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .fix
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_STATS_VERSION/{s/.* "//;s/".*$//;p}' php_stats.h)
@@ -221,6 +218,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 2 2016 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
+- update to 1.0.5 (php 5, stable)
+
* Sat May 28 2016 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
- update to 1.0.4 (php 5, stable)
diff --git a/stats-upstream.patch b/stats-upstream.patch
deleted file mode 100644
index 327d250..0000000
--- a/stats-upstream.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 9eadb06e96aabfaed7598bc3a7e730d74a9a9631 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Sat, 28 May 2016 09:48:44 +0200
-Subject: [PATCH] fix zend_parse_parameters call and segfault in
- stats_stat_binomial_coef
-
----
- php_stats.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/php_stats.c b/php_stats.c
-index 8b7c3ef..d7da5fd 100644
---- a/php_stats.c
-+++ b/php_stats.c
-@@ -3381,9 +3381,9 @@ PHP_FUNCTION(stats_stat_correlation)
- Not documented */
- PHP_FUNCTION(stats_stat_binomial_coef)
- {
-- int i;
-+ long i;
- long n;
-- int x;
-+ long x;
- double bc = 1.0;
-
- if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "ll", &x, &n) == FAILURE) {
---
-2.1.4
-