summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-02 08:42:16 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-02 08:42:16 +0100
commit470a1e7306c2a9d57ee0c1d980f375cdfb230ff0 (patch)
treeeed06b29b1dff1533f18b18b28a40c7175821ee7
parentae90b3944426af5b0b75131106a20f9ef5ef2720 (diff)
php-pecl-stats: 2.0.1 (php 7, stable)
-rw-r--r--REFLECTION-PHP7144
-rw-r--r--php-pecl-stats-php7.spec71
2 files changed, 176 insertions, 39 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..1c76cc7
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,144 @@
+Extension [ <persistent> extension #61 stats version 2.0.1 ] {
+
+ - Functions {
+ Function [ <internal:stats> function stats_cdf_t ] {
+ }
+ Function [ <internal:stats> function stats_cdf_normal ] {
+ }
+ Function [ <internal:stats> function stats_cdf_gamma ] {
+ }
+ Function [ <internal:stats> function stats_cdf_chisquare ] {
+ }
+ Function [ <internal:stats> function stats_cdf_beta ] {
+ }
+ Function [ <internal:stats> function stats_cdf_binomial ] {
+ }
+ Function [ <internal:stats> function stats_cdf_noncentral_chisquare ] {
+ }
+ Function [ <internal:stats> function stats_cdf_f ] {
+ }
+ Function [ <internal:stats> function stats_cdf_noncentral_f ] {
+ }
+ Function [ <internal:stats> function stats_cdf_noncentral_t ] {
+ }
+ Function [ <internal:stats> function stats_cdf_negative_binomial ] {
+ }
+ Function [ <internal:stats> function stats_cdf_poisson ] {
+ }
+ Function [ <internal:stats> function stats_cdf_laplace ] {
+ }
+ Function [ <internal:stats> function stats_cdf_cauchy ] {
+ }
+ Function [ <internal:stats> function stats_cdf_logistic ] {
+ }
+ Function [ <internal:stats> function stats_cdf_weibull ] {
+ }
+ Function [ <internal:stats> function stats_cdf_uniform ] {
+ }
+ Function [ <internal:stats> function stats_cdf_exponential ] {
+ }
+ Function [ <internal:stats> function stats_rand_setall ] {
+ }
+ Function [ <internal:stats> function stats_rand_getsd ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_iuniform ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_funiform ] {
+ }
+ Function [ <internal:stats> function stats_rand_ignlgi ] {
+ }
+ Function [ <internal:stats> function stats_rand_ranf ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_beta ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_chisquare ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_exponential ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_f ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_gamma ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_noncentral_chisquare ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_noncenral_f ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_normal ] {
+ }
+ Function [ <internal:stats> function stats_rand_phrase_to_seeds ] {
+ }
+ Function [ <internal:stats> function stats_rand_ibinomial ] {
+ }
+ Function [ <internal:stats> function stats_rand_ibinomial_negative ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_ipoisson ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_noncentral_t ] {
+ }
+ Function [ <internal:stats> function stats_rand_gen_t ] {
+ }
+ Function [ <internal:stats> function stats_dens_normal ] {
+ }
+ Function [ <internal:stats> function stats_dens_cauchy ] {
+ }
+ Function [ <internal:stats> function stats_dens_laplace ] {
+ }
+ Function [ <internal:stats> function stats_dens_logistic ] {
+ }
+ Function [ <internal:stats> function stats_dens_beta ] {
+ }
+ Function [ <internal:stats> function stats_dens_weibull ] {
+ }
+ Function [ <internal:stats> function stats_dens_uniform ] {
+ }
+ Function [ <internal:stats> function stats_dens_chisquare ] {
+ }
+ Function [ <internal:stats> function stats_dens_t ] {
+ }
+ Function [ <internal:stats> function stats_dens_gamma ] {
+ }
+ Function [ <internal:stats> function stats_dens_exponential ] {
+ }
+ Function [ <internal:stats> function stats_dens_f ] {
+ }
+ Function [ <internal:stats> function stats_dens_pmf_binomial ] {
+ }
+ Function [ <internal:stats> function stats_dens_pmf_poisson ] {
+ }
+ Function [ <internal:stats> function stats_dens_pmf_negative_binomial ] {
+ }
+ Function [ <internal:stats> function stats_dens_pmf_hypergeometric ] {
+ }
+ Function [ <internal:stats> function stats_stat_powersum ] {
+ }
+ Function [ <internal:stats> function stats_stat_innerproduct ] {
+ }
+ Function [ <internal:stats> function stats_stat_independent_t ] {
+ }
+ Function [ <internal:stats> function stats_stat_paired_t ] {
+ }
+ Function [ <internal:stats> function stats_stat_percentile ] {
+ }
+ Function [ <internal:stats> function stats_stat_correlation ] {
+ }
+ Function [ <internal:stats> function stats_stat_binomial_coef ] {
+ }
+ Function [ <internal:stats> function stats_stat_factorial ] {
+ }
+ Function [ <internal:stats> function stats_standard_deviation ] {
+ }
+ Function [ <internal:stats> function stats_absolute_deviation ] {
+ }
+ Function [ <internal:stats> function stats_variance ] {
+ }
+ Function [ <internal:stats> function stats_harmonic_mean ] {
+ }
+ Function [ <internal:stats> function stats_skew ] {
+ }
+ Function [ <internal:stats> function stats_kurtosis ] {
+ }
+ Function [ <internal:stats> function stats_covariance ] {
+ }
+ }
+}
+
diff --git a/php-pecl-stats-php7.spec b/php-pecl-stats-php7.spec
index f4d2c6a..f9bb165 100644
--- a/php-pecl-stats-php7.spec
+++ b/php-pecl-stats-php7.spec
@@ -1,6 +1,6 @@
# spec file for php-pecl-stats
#
-# Copyright (c) 2013-2015 Remi Collet
+# Copyright (c) 2013-2016 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,33 +11,23 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name stats
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: Routines for statistical computation
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.3
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Version: 2.0.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://bugs.php.net/65884 Please Provides LICENSE file
-# Link from the headers
-Source1: http://www.php.net/license/3_0.txt
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -53,14 +43,12 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -73,6 +61,8 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%description
Extension that provides few dozens routines for statistical computation.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
%prep
%setup -q -c
@@ -80,14 +70,6 @@ mv %{pecl_name}-%{version} NTS
cd NTS
-# empty this file which try to dl("stats.so")
-> tests/common.php
-
-cp %{SOURCE1} LICENSE
-
-# Fix version
-sed -e '/PHP_STATS_VERSION/s/1.0.3-dev/%{version}/' -i php_stats.h
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_STATS_VERSION/{s/.* "//;s/".*$//;p}' php_stats.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -145,22 +127,27 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
+# Documentation
cd NTS
-for i in $(grep 'role="test"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 $i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
-for i in LICENSE $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
@@ -169,12 +156,12 @@ fi
: Minimal load test for NTS extension
cd NTS
%{_bindir}/php --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{_bindir}/php -n run-tests.php
@@ -184,12 +171,12 @@ REPORT_EXIT_STATUS=1 \
: Minimal load test for ZTS extension
cd ../ZTS
%{__ztsphp} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php
@@ -202,8 +189,8 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
-%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -215,6 +202,12 @@ rm -rf %{buildroot}
%changelog
+* Sat Jan 2 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1 (php 7, stable)
+- don't install/register tests
+- drop runtime dependency on pear, new scriptlets
+- LICENSE is provided by upstream (PHP 3.01)
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.0.3-4.1
- Fedora 21 SCL mass rebuild