summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-stackdriver-debugger.spec31
2 files changed, 33 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index 92300ae..741eb16 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #140 stackdriver_debugger version 0.1.1 ] {
+Extension [ <persistent> extension #141 stackdriver_debugger version 0.2.0 ] {
- INI {
Entry [ stackdriver_debugger.function_whitelist <ALL> ]
@@ -7,6 +7,12 @@ Extension [ <persistent> extension #140 stackdriver_debugger version 0.1.1 ] {
Entry [ stackdriver_debugger.max_time <ALL> ]
Current = '10'
}
+ Entry [ stackdriver_debugger.max_time_percentage <ALL> ]
+ Current = '1'
+ }
+ Entry [ stackdriver_debugger.max_memory <ALL> ]
+ Current = '10'
+ }
}
- Functions {
diff --git a/php-pecl-stackdriver-debugger.spec b/php-pecl-stackdriver-debugger.spec
index e7bfc75..bd09741 100644
--- a/php-pecl-stackdriver-debugger.spec
+++ b/php-pecl-stackdriver-debugger.spec
@@ -1,11 +1,15 @@
# remirepo spec file for php-pecl-stackdriver-debugger
#
-# Copyright (c) 2018 Remi Collet
+# Copyright (c) 2017-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-pecl-stackdriver-debugger
@@ -17,13 +21,13 @@
Summary: Investigate your code behavior in production
Name: %{?sub_prefix}php-pecl-stackdriver-debugger
-Version: 0.1.1
+Version: 0.2.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: ASL 2.0
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -102,10 +106,14 @@ extension = %{pecl_name}.so
; Configuration
;stackdriver_debugger.function_whitelist = ''
;stackdriver_debugger.max_time = 10
+;stackdriver_debugger.max_time_percentage = 1
+;stackdriver_debugger.max_memory = 10
EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -124,6 +132,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -145,6 +155,11 @@ done
%check
+# see https://github.com/GoogleCloudPlatform/stackdriver-debugger-php-extension/issues/45
+%if %{__isa_bits} < 64
+rm ?TS/tests/logpoints/memory_limit.phpt
+%endif
+
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -174,7 +189,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -209,8 +224,14 @@ fi
%changelog
+* Thu Mar 8 2018 Remi Collet <remi@remirepo.net> - 0.2.0-1
+- update to 0.2.0 (alpha)
+- ignore test failing on 32-bit, reported as
+ https://github.com/GoogleCloudPlatform/stackdriver-debugger-php-extension/issues/45
+- add new option in provided configuration file
+
* Wed Jan 10 2018 Remi Collet <remi@remirepo.net> - 0.1.1-1
-- Update to 0.1.1
+- Update to 0.1.1 (alpha)
* Wed Jan 3 2018 Remi Collet <remi@remirepo.net> - 0.1.0-1
- Update to 0.1.0 (alpha)