summaryrefslogtreecommitdiffstats
path: root/php-pecl-ssh2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-ssh2.spec')
-rw-r--r--php-pecl-ssh2.spec19
1 files changed, 13 insertions, 6 deletions
diff --git a/php-pecl-ssh2.spec b/php-pecl-ssh2.spec
index a519b6e..016da50 100644
--- a/php-pecl-ssh2.spec
+++ b/php-pecl-ssh2.spec
@@ -25,7 +25,7 @@
%global ini_name 40-%{pecl_name}.ini
Name: %{?sub_prefix}php-pecl-ssh2
-Version: 1.0
+Version: 1.1
%if 0%{?gh_date}
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
@@ -37,8 +37,6 @@ Summary: Bindings for the libssh2 library
%global buildver %(pkg-config --silence-errors --modversion libssh2 2>/dev/null || echo 65536)
-Patch0: %{pecl_name}-php7013.patch
-
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/ssh2
@@ -77,6 +75,10 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -117,9 +119,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .php7013
-
-extver=$(sed -n '/#define PHP_SSH2_VERSION/{s/.* "//;s/".*$//;p}' php_ssh2.h)
+extver=$(sed -n '/#define PHP_SSH2_VERSION/{s/.*\t"//;s/".*$//;p}' php_ssh2.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
: Error: Upstream version is now ${extver}, expecting %{version}%{?gh_date:-dev}.
: Update the pdover macro and rebuild.
@@ -139,6 +139,8 @@ cp -pr NTS ZTS
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure --with-php-config=%{_bindir}/php-config
@@ -153,6 +155,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
make -C NTS install INSTALL_ROOT=%{buildroot}
# Install XML package description
@@ -227,6 +231,9 @@ fi
%changelog
+* Wed Jun 14 2017 Remi Collet <remi@remirepo.net> - 1.1-1
+- Update to 1.1 (alpha)
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.0-5
- rebuild with PHP 7.1.0 GA