summaryrefslogtreecommitdiffstats
path: root/php-pecl-ssdeep.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 15:56:52 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 15:56:52 +0200
commitda921298242785cc64d12f54112b8b0e047b3953 (patch)
treee82e4cbb212bee582d731934df3b82033e813786 /php-pecl-ssdeep.spec
parenta633745743c9d11dd3f09250e11e5d6da81096b7 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
Diffstat (limited to 'php-pecl-ssdeep.spec')
-rw-r--r--php-pecl-ssdeep.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-ssdeep.spec b/php-pecl-ssdeep.spec
index d26adc7..5c20c02 100644
--- a/php-pecl-ssdeep.spec
+++ b/php-pecl-ssdeep.spec
@@ -14,11 +14,16 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name ssdeep
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Wrapper for libfuzzy library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.4
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -86,7 +91,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat << 'EOF' | tee %{pecl_name}.ini
+cat << 'EOF' | tee %{ini_name}
; Enable %{summary} extension module
extension=%{pecl_name}.so
EOF
@@ -118,7 +123,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -126,7 +131,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -187,16 +192,19 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 1.0.4-2
+- add numerical prefix to extension configuration file (php 5.6)
+
* Wed Jan 22 2014 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
- Update to 1.0.4 (stable)
- drop upstream patch