summaryrefslogtreecommitdiffstats
path: root/php-pecl-ssdeep.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-04 14:52:37 +0200
committerRemi Collet <remi@remirepo.net>2020-09-04 14:52:37 +0200
commit01dbb935c95153d3f84764b71ebc355a8bd7fa57 (patch)
tree3da06e28b12e5ee1ccba5312df99f4c1a02ba975 /php-pecl-ssdeep.spec
parent1f04d39697b60a4084cf3a0d9bdf46c210358efe (diff)
add patch for PHP 8 from
https://github.com/php/pecl-text-ssdeep/pull/2
Diffstat (limited to 'php-pecl-ssdeep.spec')
-rw-r--r--php-pecl-ssdeep.spec40
1 files changed, 18 insertions, 22 deletions
diff --git a/php-pecl-ssdeep.spec b/php-pecl-ssdeep.spec
index cbb73f6..36d3c78 100644
--- a/php-pecl-ssdeep.spec
+++ b/php-pecl-ssdeep.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-ssdeep
#
-# Copyright (c) 2014-2018 Remi Collet
+# Copyright (c) 2014-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -31,10 +31,12 @@
Summary: Wrapper for libfuzzy library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.1.0
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+Patch0: https://patch-diff.githubusercontent.com/raw/php/pecl-text-ssdeep/pull/2.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -52,31 +54,19 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -117,6 +107,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
+%patch0 -p1 -b .pr2
+
# Sanity check, really often broken
extver=$(sed -n '/# *define PHP_SSDEEP_VERSION/{s/.* "//;s/".*$//;p}' php_ssdeep.h)
if test "x${extver}" != "x%{version}%{?versuf}"; then
@@ -247,6 +239,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Sep 4 2020 Remi Collet <remi@remirepo.net> - 1.1.0-6
+- add patch for PHP 8 from
+ https://github.com/php/pecl-text-ssdeep/pull/2
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.1.0-5
- rebuild for 7.4.0RC1