summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-06 07:40:45 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-06 07:40:45 +0100
commit49bae555737c571038449041fc5e6c1b51c9c920 (patch)
tree066c4caa663b0b5d4db5c9b4ffb069b4656f6b09
parentc9606f52110c6b23740d794a6863b23204c3ef4e (diff)
php-pecl-ssdeep: F24
-rw-r--r--php-pecl-ssdeep.spec24
1 files changed, 15 insertions, 9 deletions
diff --git a/php-pecl-ssdeep.spec b/php-pecl-ssdeep.spec
index d03c77a..aedca75 100644
--- a/php-pecl-ssdeep.spec
+++ b/php-pecl-ssdeep.spec
@@ -19,9 +19,6 @@
%{?scl: %scl_package php-pecl-ssdeep}
%{!?scl: %global _root_prefix %{_prefix}}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name ssdeep
@@ -34,7 +31,7 @@
Summary: Wrapper for libfuzzy library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.4
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -51,10 +48,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -107,7 +106,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
pushd NTS
%patch0 -p1 -b .php7
@@ -176,6 +177,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -192,6 +194,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -243,6 +246,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 1.0.4-10
+- adapt for F24
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 1.0.4-9
- rebuild for PHP 7.0.0RC5 new API version
@@ -277,4 +283,4 @@ rm -rf %{buildroot}
- drop upstream patch
* Wed Jan 22 2014 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
-- initial package, version 1.0.3 (stable) \ No newline at end of file
+- initial package, version 1.0.3 (stable)