summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-16 17:22:40 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-16 17:22:40 +0200
commite649af79a5ae7c453930f180d4905de9476ad022 (patch)
tree7300b31594be6af7139ac602e27b4a40f14c0b49
parenta639ad464771861b9d1f6db430af6e2a54c1a360 (diff)
php-pecl: add numerical prefix to extension configuration file (more)
-rw-r--r--php-pecl-spl-types.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-spl-types.spec b/php-pecl-spl-types.spec
index e3d9439..f44f56d 100644
--- a/php-pecl-spl-types.spec
+++ b/php-pecl-spl-types.spec
@@ -14,11 +14,16 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name SPL_Types
%global ext_name spl_types
+%if "%{php_version}" < "5.6"
+%global ini_name %{ext_name}.ini
+%else
+%global ini_name 40-%{ext_name}.ini
+%endif
Summary: Standard PHP Library, Types Addon
Name: %{?scl_prefix}php-pecl-spl-types
Version: 0.4.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -97,7 +102,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{ext_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{ext_name}.so
EOF
@@ -129,7 +134,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{ext_name}.ini %{buildroot}%{php_inidir}/%{ext_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -137,7 +142,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ext_name}.ini %{buildroot}%{php_ztsinidir}/%{ext_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -199,16 +204,19 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{ext_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{ext_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ext_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{ext_name}.so
%endif
%changelog
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 0.4.0-5
+- add numerical prefix to extension configuration file (php 5.6)
+
* Wed Jan 8 2014 Remi Collet <remi@fedoraproject.org> - 0.4.0-4
- adapt for SCL and Copr