summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-05-06 18:41:53 +0200
committerRemi Collet <fedora@famillecollet.com>2014-05-06 18:41:53 +0200
commit8411ef009a7acbbdcec38709510fe8029b45614f (patch)
treefbbbd7987087b9110c5e16a59e61dab914fd7ef6
parent0ac6e8f3b3cc28ed209c653733182c3b4f122229 (diff)
php-pecl-sphinx: 1.3.2 (stable)
-rw-r--r--3_01.txt68
-rw-r--r--REFLECTION344
-rw-r--r--php-pecl-sphinx.spec18
3 files changed, 349 insertions, 81 deletions
diff --git a/3_01.txt b/3_01.txt
deleted file mode 100644
index 6059c80..0000000
--- a/3_01.txt
+++ /dev/null
@@ -1,68 +0,0 @@
---------------------------------------------------------------------
- The PHP License, version 3.01
-Copyright (c) 1999 - 2014 The PHP Group. All rights reserved.
---------------------------------------------------------------------
-
-Redistribution and use in source and binary forms, with or without
-modification, is permitted provided that the following conditions
-are met:
-
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in
- the documentation and/or other materials provided with the
- distribution.
-
- 3. The name "PHP" must not be used to endorse or promote products
- derived from this software without prior written permission. For
- written permission, please contact group@php.net.
-
- 4. Products derived from this software may not be called "PHP", nor
- may "PHP" appear in their name, without prior written permission
- from group@php.net. You may indicate that your software works in
- conjunction with PHP by saying "Foo for PHP" instead of calling
- it "PHP Foo" or "phpfoo"
-
- 5. The PHP Group may publish revised and/or new versions of the
- license from time to time. Each version will be given a
- distinguishing version number.
- Once covered code has been published under a particular version
- of the license, you may always continue to use it under the terms
- of that version. You may also choose to use such covered code
- under the terms of any subsequent version of the license
- published by the PHP Group. No one other than the PHP Group has
- the right to modify the terms applicable to covered code created
- under this License.
-
- 6. Redistributions of any form whatsoever must retain the following
- acknowledgment:
- "This product includes PHP software, freely available from
- <http://www.php.net/software/>".
-
-THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
-ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
-THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
-DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
-INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
-OF THE POSSIBILITY OF SUCH DAMAGE.
-
---------------------------------------------------------------------
-
-This software consists of voluntary contributions made by many
-individuals on behalf of the PHP Group.
-
-The PHP Group can be contacted via Email at group@php.net.
-
-For more information on the PHP Group and the PHP project,
-please see <http://www.php.net>.
-
-PHP includes the Zend Engine, freely available at
-<http://www.zend.com>.
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..18a65c3
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,344 @@
+Extension [ <persistent> extension #128 sphinx version 1.3.2 ] {
+
+ - Constants [42] {
+ Constant [ integer SEARCHD_OK ] { 0 }
+ Constant [ integer SEARCHD_ERROR ] { 1 }
+ Constant [ integer SEARCHD_RETRY ] { 2 }
+ Constant [ integer SEARCHD_WARNING ] { 3 }
+ Constant [ integer SPH_MATCH_ALL ] { 0 }
+ Constant [ integer SPH_MATCH_ANY ] { 1 }
+ Constant [ integer SPH_MATCH_PHRASE ] { 2 }
+ Constant [ integer SPH_MATCH_BOOLEAN ] { 3 }
+ Constant [ integer SPH_MATCH_EXTENDED ] { 4 }
+ Constant [ integer SPH_MATCH_FULLSCAN ] { 5 }
+ Constant [ integer SPH_MATCH_EXTENDED2 ] { 6 }
+ Constant [ integer SPH_RANK_PROXIMITY_BM25 ] { 0 }
+ Constant [ integer SPH_RANK_BM25 ] { 1 }
+ Constant [ integer SPH_RANK_NONE ] { 2 }
+ Constant [ integer SPH_RANK_WORDCOUNT ] { 3 }
+ Constant [ integer SPH_RANK_PROXIMITY ] { 4 }
+ Constant [ integer SPH_RANK_MATCHANY ] { 5 }
+ Constant [ integer SPH_RANK_FIELDMASK ] { 6 }
+ Constant [ integer SPH_RANK_SPH04 ] { 7 }
+ Constant [ integer SPH_RANK_EXPR ] { 8 }
+ Constant [ integer SPH_RANK_TOTAL ] { 9 }
+ Constant [ integer SPH_SORT_RELEVANCE ] { 0 }
+ Constant [ integer SPH_SORT_ATTR_DESC ] { 1 }
+ Constant [ integer SPH_SORT_ATTR_ASC ] { 2 }
+ Constant [ integer SPH_SORT_TIME_SEGMENTS ] { 3 }
+ Constant [ integer SPH_SORT_EXTENDED ] { 4 }
+ Constant [ integer SPH_SORT_EXPR ] { 5 }
+ Constant [ integer SPH_FILTER_VALUES ] { 0 }
+ Constant [ integer SPH_FILTER_RANGE ] { 1 }
+ Constant [ integer SPH_FILTER_FLOATRANGE ] { 2 }
+ Constant [ integer SPH_ATTR_INTEGER ] { 1 }
+ Constant [ integer SPH_ATTR_TIMESTAMP ] { 2 }
+ Constant [ integer SPH_ATTR_ORDINAL ] { 3 }
+ Constant [ integer SPH_ATTR_BOOL ] { 4 }
+ Constant [ integer SPH_ATTR_FLOAT ] { 5 }
+ Constant [ integer SPH_ATTR_MULTI ] { 1073741825 }
+ Constant [ integer SPH_GROUPBY_DAY ] { 0 }
+ Constant [ integer SPH_GROUPBY_WEEK ] { 1 }
+ Constant [ integer SPH_GROUPBY_MONTH ] { 2 }
+ Constant [ integer SPH_GROUPBY_YEAR ] { 3 }
+ Constant [ integer SPH_GROUPBY_ATTR ] { 4 }
+ Constant [ integer SPH_GROUPBY_ATTRPAIR ] { 5 }
+ }
+
+ - Classes [1] {
+ Class [ <internal:sphinx> class SphinxClient ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [37] {
+ Method [ <internal:sphinx, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method addQuery ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $query ]
+ Parameter #1 [ <optional> $index ]
+ Parameter #2 [ <optional> $comment ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method buildExcerpts ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $docs ]
+ Parameter #1 [ <required> $index ]
+ Parameter #2 [ <required> $words ]
+ Parameter #3 [ <optional> $opts ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method buildKeywords ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $query ]
+ Parameter #1 [ <required> $index ]
+ Parameter #2 [ <required> $hits ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method getLastError ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method getLastWarning ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method escapeString ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method open ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method query ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $query ]
+ Parameter #1 [ <optional> $index ]
+ Parameter #2 [ <optional> $comment ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method resetFilters ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method resetGroupBy ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method runQueries ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method setArrayResult ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $array_result ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setConnectTimeout ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timeout ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setFieldWeights ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $weights ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setFilter ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $attribute ]
+ Parameter #1 [ <required> $values ]
+ Parameter #2 [ <optional> $exclude ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setFilterFloatRange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $attribute ]
+ Parameter #1 [ <required> $min ]
+ Parameter #2 [ <required> $max ]
+ Parameter #3 [ <optional> $exclude ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setFilterRange ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $attribute ]
+ Parameter #1 [ <required> $min ]
+ Parameter #2 [ <required> $max ]
+ Parameter #3 [ <optional> $exclude ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setGeoAnchor ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $attrlat ]
+ Parameter #1 [ <required> $attrlong ]
+ Parameter #2 [ <required> $latitude ]
+ Parameter #3 [ <required> $longitude ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setGroupBy ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $attribute ]
+ Parameter #1 [ <required> $func ]
+ Parameter #2 [ <optional> $groupsort ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setGroupDistinct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $attribute ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setIndexWeights ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $weights ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setIDRange ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $min ]
+ Parameter #1 [ <required> $max ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setSelect ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $clause ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setLimits ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $limit ]
+ Parameter #2 [ <optional> $max_matches ]
+ Parameter #3 [ <optional> $cutoff ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setMatchMode ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $mode ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setMaxQueryTime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $qtime ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setOverride ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $attribute ]
+ Parameter #1 [ <required> $type ]
+ Parameter #2 [ <required> $values ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setRankingMode ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ranker ]
+ Parameter #1 [ <optional> $rank_expression ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setRetries ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $count ]
+ Parameter #1 [ <optional> $delay ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setServer ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $server ]
+ Parameter #1 [ <required> $port ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method setSortMode ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $mode ]
+ Parameter #1 [ <optional> $sortby ]
+ }
+ }
+
+ Method [ <internal:sphinx> public method status ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:sphinx> public method updateAttributes ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $attributes ]
+ Parameter #2 [ <required> $values ]
+ Parameter #3 [ <optional> $mva ]
+ }
+ }
+
+ Method [ <internal:sphinx> final public method __sleep ] {
+ }
+
+ Method [ <internal:sphinx> final public method __wakeup ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-sphinx.spec b/php-pecl-sphinx.spec
index 779d157..c57f175 100644
--- a/php-pecl-sphinx.spec
+++ b/php-pecl-sphinx.spec
@@ -22,7 +22,7 @@
%endif
Name: %{?scl_prefix}php-pecl-sphinx
-Version: 1.3.1
+Version: 1.3.2
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Summary: PECL extension for Sphinx SQL full-text search engine
Group: Development/Languages
@@ -30,14 +30,6 @@ License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# http://git.php.net/?p=pecl/search_engine/sphinx.git;a=commitdiff;h=c9df387423cc10e5e2db98ee55d98361ab7e404a
-# http://git.php.net/?p=pecl/search_engine/sphinx.git;a=commitdiff;h=8e491962b19a253d813f8056c07d15b643e668c3
-Patch0: %{pecl_name}-el5.patch
-
-# https://bugs.php.net/65864 ask license file
-# URL from sphinx.c headers
-Source1: http://www.php.net/license/3_01.txt
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libsphinxclient-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -86,9 +78,6 @@ client library for Sphinx the SQL full-text search engine.
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p1
-cp %{SOURCE1} LICENSE
-
# Check reported version (phpinfo), as this is often broken
extver=$(sed -n '/#define PHP_SPHINX_VERSION/{s/.* "//;s/".*$//;p}' php_sphinx.h)
if test "x${extver}" != "x%{version}"; then
@@ -155,7 +144,7 @@ install -Dpm644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Test & Documentation
cd NTS
-for i in LICENSE $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -189,6 +178,9 @@ fi
%changelog
+* Tue May 06 2014 Remi Collet <remi@fedoraproject.org> - 1.3.2-1
+- Update to 1.3.2 (stable)
+
* Tue May 06 2014 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
- Update to 1.3.1 (stable)