summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 16:26:12 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 16:26:12 +0100
commit1fe9490b868a12c15e2c2b412453e28cc92242c8 (patch)
tree630984376f6db15ae34fb1b16582bd34ad3a2620
parent43ff0a2cae0e50b6d7278b25a7303899c592386d (diff)
php-pecl-sphinx: F24
-rw-r--r--php-pecl-sphinx.spec22
1 files changed, 14 insertions, 8 deletions
diff --git a/php-pecl-sphinx.spec b/php-pecl-sphinx.spec
index 7a0ce8b..bc4b346 100644
--- a/php-pecl-sphinx.spec
+++ b/php-pecl-sphinx.spec
@@ -18,9 +18,6 @@
%endif
%{?scl: %scl_package php-pecl-selinux}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%define pecl_name sphinx
%global with_zts 0%{?__ztsphp:1}
@@ -32,7 +29,7 @@
Name: %{?sub_prefix}php-pecl-sphinx
Version: 1.3.3
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PECL extension for Sphinx SQL full-text search engine
Group: Development/Languages
License: PHP
@@ -48,10 +45,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -84,12 +83,14 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
This extension provides PHP bindings for libsphinxclient,
client library for Sphinx the SQL full-text search engine.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -q -c
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
mv %{pecl_name}-%{version} NTS
cd NTS
@@ -168,6 +169,7 @@ done
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -184,6 +186,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%files
@@ -202,6 +205,9 @@ fi
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.3.3-3
+- adapt for F24
+
* Tue Jun 23 2015 Remi Collet <remi@fedoraproject.org> - 1.3.3-2
- allow build against rh-php56 (as more-php56)