summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-21 17:53:36 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-21 17:53:36 +0200
commit02d35946ecb9de63852d14b7d611f7df06ad79ca (patch)
tree44c15be3eb77577bc1897465e90124804380f4f8
parent948fb852818cb8532a6805d176b5d7d871810fbd (diff)
php-pecl-sphinx: 1.3.3 (stable)
-rw-r--r--REFLECTION13
-rw-r--r--php-pecl-sphinx.spec32
2 files changed, 33 insertions, 12 deletions
diff --git a/REFLECTION b/REFLECTION
index 18a65c3..f4410f1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #128 sphinx version 1.3.2 ] {
+Extension [ <persistent> extension #146 sphinx version 1.3.3 ] {
- Constants [42] {
Constant [ integer SEARCHD_OK ] { 0 }
@@ -60,7 +60,7 @@ Extension [ <persistent> extension #128 sphinx version 1.3.2 ] {
- Properties [0] {
}
- - Methods [37] {
+ - Methods [38] {
Method [ <internal:sphinx, ctor> public method __construct ] {
- Parameters [0] {
@@ -183,6 +183,15 @@ Extension [ <persistent> extension #128 sphinx version 1.3.2 ] {
}
}
+ Method [ <internal:sphinx> public method setFilterString ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $attribute ]
+ Parameter #1 [ <required> $value ]
+ Parameter #2 [ <optional> $exclude ]
+ }
+ }
+
Method [ <internal:sphinx> public method setFilterFloatRange ] {
- Parameters [4] {
diff --git a/php-pecl-sphinx.spec b/php-pecl-sphinx.spec
index cb557fc..829ebf1 100644
--- a/php-pecl-sphinx.spec
+++ b/php-pecl-sphinx.spec
@@ -1,7 +1,8 @@
-# spec file for php-pecl-sphinx
+# remirepo spec file for php-pecl-sphinx
#
# Copyright (c) 2011-2015 Remi Collet
-# Copyright (c) 2009-2011 Andrew Colin Kissa
+#
+# Fedora spec file for php-pecl-sphinx
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -22,8 +23,8 @@
%endif
Name: %{?scl_prefix}php-pecl-sphinx
-Version: 1.3.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Version: 1.3.3
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Summary: PECL extension for Sphinx SQL full-text search engine
Group: Development/Languages
License: PHP
@@ -37,8 +38,6 @@ BuildRequires: %{?scl_prefix}php-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
@@ -155,18 +154,27 @@ done
rm -rf %{buildroot}
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -180,6 +188,10 @@ fi
%changelog
+* Thu May 21 2015 Remi Collet <remi@fedoraproject.org> - 1.3.3-1
+- Update to 1.3.3
+- drop runtime dependency on pear, new scriptlets
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.3.2-2.1
- Fedora 21 SCL mass rebuild