summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-solr2.spec10
1 files changed, 7 insertions, 3 deletions
diff --git a/php-pecl-solr2.spec b/php-pecl-solr2.spec
index 5b984c5..426d350 100644
--- a/php-pecl-solr2.spec
+++ b/php-pecl-solr2.spec
@@ -33,7 +33,8 @@
# After 20-curl, 40-json
%global ini_name 50-%{pecl_name}.ini
%endif
-# For full test, with online server (solr5 must resolve)
+# For full test (with online server) use --with tests
+# solr5 must be resolved, or use --define "server <ip>"
%global with_tests 0%{?_with_tests:1}
Summary: Object oriented API to Apache Solr
@@ -209,9 +210,12 @@ fi
%check
%if %{with_tests}
-sed -e '/SOLR_SERVER_CONFIGURED/s/false/true/' -i ?TS/tests/test.config.inc
+sed -e '/SOLR_SERVER_CONFIGURED/s/false/true/' \
+ %{?server: -e '/SOLR_SERVER_HOSTNAME/s/solr5/%{server}/'} \
+ -i ?TS/tests/test.config.inc
%else
-sed -e '/SOLR_SERVER_CONFIGURED/s/true/false/' -i ?TS/tests/test.config.inc
+sed -e '/SOLR_SERVER_CONFIGURED/s/true/false/' \
+ -i ?TS/tests/test.config.inc
%endif
: Minimal load test for NTS installed extension