summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-09 14:37:12 +0100
committerRemi Collet <remi@php.net>2022-11-09 14:37:12 +0100
commit9099cba8e88047d3431ce3fc3c2f844fb90a5a99 (patch)
tree0747850da533d1ea0f9633743afb109b84cc64f1
parenta1069e7e0bf1e80be5eb772cd6416a12024bf338 (diff)
update to 2.6.0
drop patch merged upstream
-rw-r--r--php-pecl-solr2.spec13
-rw-r--r--solr-php82.patch79
2 files changed, 6 insertions, 86 deletions
diff --git a/php-pecl-solr2.spec b/php-pecl-solr2.spec
index b05fc3f..986524d 100644
--- a/php-pecl-solr2.spec
+++ b/php-pecl-solr2.spec
@@ -36,9 +36,6 @@ URL: https://pecl.php.net/package/solr
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# for PHP 8.2 from https://github.com/php/pecl-search_engine-solr/pull/39
-Patch1: %{pecl_name}-php82.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -100,8 +97,6 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
-%patch1 -p1 -b .pr
-
: Check version
DIR=src/php7
extver=$(sed -n '/#define PHP_SOLR_VERSION /{s/.* "//;s/".*$//;p}' $DIR/php_solr_version.h)
@@ -209,9 +204,9 @@ OPT="$OPT -d error_reporting=24575"
: Upstream test suite for NTS extension
cd NTS
+TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-TEST_PHP_EXECUTABLE=%{__php} \
%{__php} -n run-tests.php -q --show-diff
%if %{with_zts}
@@ -222,9 +217,9 @@ TEST_PHP_EXECUTABLE=%{__php} \
: Upstream test suite for ZTS extension
cd ../ZTS
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -244,6 +239,10 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
%changelog
+* Wed Nov 9 2022 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- drop patch merged upstream
+
* Wed Nov 9 2022 Remi Collet <remi@remirepo.net> - 2.6.0-0
- test build for upcoming 2.6.0
- refresh fix from PHP 8.2 from
diff --git a/solr-php82.patch b/solr-php82.patch
deleted file mode 100644
index 67c89da..0000000
--- a/solr-php82.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From e90b33b4c5d3b94da4f12923242f943aa5558d4c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 9 Sep 2022 15:37:33 +0200
-Subject: [PATCH 1/2] fix __toString method for 8.2
-
----
- src/php7/php_solr.c | 11 +++++++++--
- 1 file changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/src/php7/php_solr.c b/src/php7/php_solr.c
-index de69bc8..d06a9cc 100644
---- a/src/php7/php_solr.c
-+++ b/src/php7/php_solr.c
-@@ -554,6 +554,13 @@ ZEND_ARG_INFO(SOLR_ARG_PASS_BY_REF_FALSE, mime_type)
- ZEND_ARG_OBJ_INFO(SOLR_ARG_PASS_BY_REF_TRUE, params, SolrModifiableParams, SOLR_ARG_ALLOW_NULL_FALSE)
- ZEND_END_ARG_INFO()
-
-+#if PHP_VERSION_ID >= 80200
-+ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(Solr_toString_args, 0, 0, IS_STRING, 0)
-+#else
-+ZEND_BEGIN_ARG_INFO_EX(Solr_toString_args, 0, 0, 0)
-+#endif
-+ZEND_END_ARG_INFO();
-+
-
- /* }}} */
-
-@@ -619,7 +626,7 @@ static zend_function_entry solr_collapse_function_methods[] = {
-
- PHP_ME(SolrCollapseFunction, setNullPolicy, SolrCollapseFunction_set_null_policy_args, ZEND_ACC_PUBLIC)
- PHP_ME(SolrCollapseFunction, getNullPolicy, Solr_no_args, ZEND_ACC_PUBLIC)
-- PHP_ME(SolrCollapseFunction, __toString, Solr_no_args, ZEND_ACC_PUBLIC)
-+ PHP_ME(SolrCollapseFunction, __toString, Solr_toString_args, ZEND_ACC_PUBLIC)
- PHP_ME(SolrCollapseFunction, __sleep, Solr_no_args, ZEND_ACC_PUBLIC)
- PHP_ME(SolrCollapseFunction, __wakeup, Solr_no_args, ZEND_ACC_PUBLIC)
-
-@@ -788,7 +795,7 @@ static zend_function_entry solr_illegal_argument_exception_methods[] = {
- static zend_function_entry solr_params_methods[] = {
- PHP_ME(SolrParams, setParam, SolrParams_setParam_args, ZEND_ACC_PUBLIC)
- PHP_ME(SolrParams, addParam, SolrParams_addParam_args, ZEND_ACC_PUBLIC)
-- PHP_ME(SolrParams, __toString, Solr_no_args, ZEND_ACC_PUBLIC)
-+ PHP_ME(SolrParams, __toString, Solr_toString_args, ZEND_ACC_PUBLIC)
- PHP_ME(SolrParams, toString, SolrParams_toString_args, ZEND_ACC_PUBLIC)
- PHP_ME(SolrParams, getParams, Solr_no_args, ZEND_ACC_PUBLIC)
- PHP_ME(SolrParams, getParam, SolrParams_getParam_args, ZEND_ACC_PUBLIC)
-
-From 0c0e3d155f58a674e654e2aa447d9f8570ac4fc8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 9 Nov 2022 13:32:41 +0100
-Subject: [PATCH 2/2] allow dynamic properties
-
----
- src/php7/php_solr.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/src/php7/php_solr.c b/src/php7/php_solr.c
-index d06a9cc..8062090 100644
---- a/src/php7/php_solr.c
-+++ b/src/php7/php_solr.c
-@@ -1207,6 +1207,9 @@ PHP_MINIT_FUNCTION(solr)
- INIT_CLASS_ENTRY(ce, PHP_SOLR_OBJECT_CLASSNAME, solr_object_methods);
- solr_ce_SolrObject = zend_register_internal_class(&ce);
- solr_ce_SolrObject->ce_flags |= ZEND_ACC_FINAL;
-+#if PHP_VERSION_ID >= 80200
-+ solr_ce_SolrObject->ce_flags |= ZEND_ACC_ALLOW_DYNAMIC_PROPERTIES;
-+#endif
-
- /* SolrObject implements ArrayAccess */
- zend_class_implements(solr_ce_SolrObject, 1, solr_ce_ArrayAccess);
-@@ -1239,6 +1242,9 @@ PHP_MINIT_FUNCTION(solr)
- INIT_CLASS_ENTRY(ce, PHP_SOLR_INPUT_DOCUMENT_CLASSNAME, solr_input_document_methods);
- solr_ce_SolrInputDocument = zend_register_internal_class(&ce);
- solr_ce_SolrInputDocument->ce_flags |= ZEND_ACC_FINAL;
-+#if PHP_VERSION_ID >= 80200
-+ solr_ce_SolrInputDocument->ce_flags |= ZEND_ACC_ALLOW_DYNAMIC_PROPERTIES;
-+#endif
-
- /* This internal property will be used to map to this SolrDocument instance */
- zend_declare_property_long(solr_ce_SolrInputDocument, SOLR_INDEX_PROPERTY_NAME, sizeof(SOLR_INDEX_PROPERTY_NAME) -1, 0L, ZEND_ACC_PRIVATE);