summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-06-24 15:41:27 +0200
committerRemi Collet <fedora@famillecollet.com>2014-06-24 15:41:27 +0200
commit76657ddbd0bb28128a83ea3657c4b1600a966e0e (patch)
tree192da11b5bf1a1ac1f910a611e1fb5e012027ed4
parente097a144821bfea29084791556d66f6c669bc19c (diff)
php-pecl-solr2: 2.0.0
-rw-r--r--REFLECTION80
-rw-r--r--php-pecl-solr2.spec33
2 files changed, 88 insertions, 25 deletions
diff --git a/REFLECTION b/REFLECTION
index a920866..4c94fa0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,15 +1,15 @@
-Extension [ <persistent> extension #161 solr version 2.0.0b ] {
+Extension [ <persistent> extension #169 solr version 2.0.0 ] {
- Dependencies {
- Dependency [ curl (Required) ]
Dependency [ libxml (Required) ]
+ Dependency [ json (Required) ]
}
- Constants [4] {
Constant [ integer SOLR_MAJOR_VERSION ] { 2 }
Constant [ integer SOLR_MINOR_VERSION ] { 0 }
Constant [ integer SOLR_PATCH_VERSION ] { 0 }
- Constant [ string SOLR_EXTENSION_VERSION ] { 2.0.0b }
+ Constant [ string SOLR_EXTENSION_VERSION ] { 2.0.0 }
}
- Functions {
@@ -20,7 +20,7 @@ Extension [ <persistent> extension #161 solr version 2.0.0b ] {
}
}
- - Classes [18] {
+ - Classes [19] {
Class [ <internal:solr> final class SolrObject implements ArrayAccess ] {
- Constants [0] {
@@ -2592,7 +2592,7 @@ Extension [ <persistent> extension #161 solr version 2.0.0b ] {
- Static properties [0] {
}
- - Static methods [4] {
+ - Static methods [5] {
Method [ <internal:solr> static public method escapeQueryChars ] {
- Parameters [1] {
@@ -2615,6 +2615,13 @@ Extension [ <persistent> extension #161 solr version 2.0.0b ] {
}
}
+ Method [ <internal:solr> static public method digestJsonResponse ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $jsonResponse ]
+ }
+ }
+
Method [ <internal:solr> static public method getSolrVersion ] {
- Parameters [0] {
@@ -2880,6 +2887,69 @@ Extension [ <persistent> extension #161 solr version 2.0.0b ] {
}
}
}
+
+ Class [ <internal:solr> class SolrServerException extends SolrException ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [7] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $sourceline ]
+ Property [ <default> protected $sourcefile ]
+ Property [ <default> protected $zif_name ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:solr, overwrites SolrException, prototype SolrException> public method getInternalInfo ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
}
}
diff --git a/php-pecl-solr2.spec b/php-pecl-solr2.spec
index 30e6c05..72f9042 100644
--- a/php-pecl-solr2.spec
+++ b/php-pecl-solr2.spec
@@ -27,7 +27,7 @@ Summary: Object oriented API to Apache Solr
Summary(fr): API orientée objet pour Apache Solr
Name: %{?scl_prefix}php-pecl-solr2
Version: 2.0.0
-Release: 0.4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/solr
@@ -112,6 +112,7 @@ PECL Solr 1 is available in php-pecl-solr package.
%setup -c -q
mv %{pecl_name}-%{version}%{?prever} NTS
+
cd NTS
# Check version
@@ -121,8 +122,6 @@ if test "x${extver}" != "x%{version}%{?prever}"; then
exit 1
fi
-# Fix rights (fixed upstream)
-find . -type f -exec chmod -x {} \;
cd ..
# Create configuration file
@@ -171,7 +170,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
done
-for i in LICENSE $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -189,22 +188,15 @@ fi
%check
cd NTS
-: Minimal load test for NTS extension
+: Minimal load test for NTS installed extension
%{__php} \
-n \
-d extension=curl.so \
-d extension=json.so \
- -d extension=$PWD/modules/%{pecl_name}.so \
+ -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
-m | grep %{pecl_name}
: Upstream test suite for NTS extension
-# http://git.php.net/?p=pecl/search_engine/solr.git;a=commitdiff;h=a7ac6ee8f09b28e848436f7d972cc74b8eb1ae1c
-sed -e '/SOLR_SERVER_CONFIGURED/s/true/false/' \
- -i tests/test.config.inc
-
-# http://git.php.net/?p=pecl/search_engine/solr.git;a=commitdiff;h=224c40fd3118ae675b5bbc2194370198918b18d0
-sed -e '/^curl$/d' -i tests/*phpt
-
TEST_PHP_ARGS="-n -d extension=curl.so -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
NO_INTERACTION=1 \
@@ -214,19 +206,15 @@ TEST_PHP_EXECUTABLE=%{__php} \
%if %{with_zts}
cd ../ZTS
-: Minimal load test for ZTS extension
+: Minimal load test for ZTS installed extension
%{__ztsphp} \
-n \
-d extension=curl.so \
-d extension=json.so \
- -d extension=$PWD/modules/%{pecl_name}.so \
+ -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
-m | grep %{pecl_name}
: Upstream test suite for ZTS extension
-sed -e '/SOLR_SERVER_CONFIGURED/s/true/false/' \
- -i tests/test.config.inc
-sed -e '/^curl$/d' -i tests/*phpt
-
TEST_PHP_ARGS="-n -d extension=curl.so -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
NO_INTERACTION=1 \
@@ -243,9 +231,11 @@ rm -rf %{buildroot}
%defattr(-, root, root, -)
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
-%{pecl_xmldir}/%{name}.xml
+
%if %{with_zts}
%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
@@ -253,6 +243,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 24 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0
+
* Mon Jun 23 2014 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.4
- test build before 2.0.0 finale