summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-01 14:13:15 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-01 14:13:15 +0100
commit4b9b4cfffb8e725fca32e06c97445f78817dd7ea (patch)
tree4578cd66c803903b0d5faa5af5df4cbcd21c9672
parentd1e15f976adba037e3023e54524cb65e4552bcd5 (diff)
php-pecl-solr2: upcoming 2.3.0 test build
-rw-r--r--REFLECTION70
-rw-r--r--php-pecl-solr2.spec15
2 files changed, 68 insertions, 17 deletions
diff --git a/REFLECTION b/REFLECTION
index feaed4a..8aaca0e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #198 solr version 2.2.1 ] {
+Extension [ <persistent> extension #197 solr version 2.3.0 ] {
- Dependencies {
Dependency [ libxml (Required) ]
@@ -7,9 +7,9 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
- Constants [4] {
Constant [ integer SOLR_MAJOR_VERSION ] { 2 }
- Constant [ integer SOLR_MINOR_VERSION ] { 2 }
- Constant [ integer SOLR_PATCH_VERSION ] { 1 }
- Constant [ string SOLR_EXTENSION_VERSION ] { 2.2.1 }
+ Constant [ integer SOLR_MINOR_VERSION ] { 3 }
+ Constant [ integer SOLR_PATCH_VERSION ] { 0 }
+ Constant [ string SOLR_EXTENSION_VERSION ] { 2.3.0 }
}
- Functions {
@@ -106,7 +106,7 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
Property [ <default> private $_hashtable_index ]
}
- - Methods [30] {
+ - Methods [33] {
Method [ <internal:solr, ctor> public method __construct ] {
- Parameters [0] {
@@ -300,6 +300,24 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:solr> public method getChildDocumentsCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:solr> public method hasChildDocuments ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:solr> public method getChildDocuments ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -356,7 +374,7 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
Property [ <default> private $_hashtable_index ]
}
- - Methods [20] {
+ - Methods [25] {
Method [ <internal:solr, ctor> public method __construct ] {
- Parameters [0] {
@@ -484,6 +502,38 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
Parameter #1 [ <optional> $overwrite ]
}
}
+
+ Method [ <internal:solr> public method addChildDocument ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> SolrInputDocument &$child ]
+ }
+ }
+
+ Method [ <internal:solr> public method getChildDocuments ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:solr> public method hasChildDocuments ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:solr> public method getChildDocumentsCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:solr> public method &addChildDocuments ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array &$docs ]
+ }
+ }
}
}
@@ -3981,7 +4031,7 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
Method [ <internal:solr> public method setMax ] {
- Parameters [1] {
- Parameter #0 [ <required> $value ]
+ Parameter #0 [ <required> $max ]
}
}
@@ -3994,7 +4044,7 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
Method [ <internal:solr> public method setMin ] {
- Parameters [1] {
- Parameter #0 [ <required> $value ]
+ Parameter #0 [ <required> $min ]
}
}
@@ -4007,7 +4057,7 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
Method [ <internal:solr> public method setSize ] {
- Parameters [1] {
- Parameter #0 [ <required> $value ]
+ Parameter #0 [ <required> $size ]
}
}
@@ -4020,7 +4070,7 @@ Extension [ <persistent> extension #198 solr version 2.2.1 ] {
Method [ <internal:solr> public method setHint ] {
- Parameters [1] {
- Parameter #0 [ <required> $value ]
+ Parameter #0 [ <required> $hint ]
}
}
diff --git a/php-pecl-solr2.spec b/php-pecl-solr2.spec
index 7cc7a27..ab82f98 100644
--- a/php-pecl-solr2.spec
+++ b/php-pecl-solr2.spec
@@ -34,23 +34,22 @@
%global ini_name 50-%{pecl_name}.ini
%endif
# For full test (using localhost server) use --with tests
-# create: docker run -d -p 8983:8983 --name solr5 -t omars/solr53
-# cleanup: docker stop solr5 && docker rm solr5
+# retrieve: docker pull omars/solr53
+# create: docker run -d -p 8983:8983 --name solr5 -t omars/solr53
+# cleanup: docker stop solr5 && docker rm solr5
%global with_tests 0%{?_with_tests:1}
Summary: Object oriented API to Apache Solr
Summary(fr): API orientée objet pour Apache Solr
Name: %{?sub_prefix}php-pecl-solr2
-Version: 2.2.1
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.3.0
+Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/solr
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-Patch0: %{pecl_name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -136,7 +135,6 @@ sed -e 's/role="test"/role="src"/' -i package.xml
mv %{pecl_name}-%{version}%{?prever} NTS
cd NTS
-%patch0 -p1 -b .upstream
# Check version
extver=$(sed -n '/#define PHP_SOLR_VERSION /{s/.* "//;s/".*$//;p}' php_solr_version.h)
@@ -289,6 +287,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Nov 01 2015 Remi Collet <remi@fedoraproject.org> - 2.3.0-0
+- test build for upcoming 2.3.0
+
* Mon Sep 28 2015 Remi Collet <remi@fedoraproject.org> - 2.2.1-3
- add upstream patch for zpp calls (fix broken ppc64)