summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-11 08:16:34 +0100
committerRemi Collet <remi@php.net>2024-01-11 08:16:34 +0100
commit0d3e919349d92f7905e6d6596089372ad6646837 (patch)
tree817ccef784332a5182d5519092d9797f4173fff0
parentd9604576b4b313853f608d323991337cac28bc60 (diff)
test build for upcoming 2.7.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION48
-rw-r--r--php-pecl-solr2.spec23
3 files changed, 54 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index b9af9d9..314e77b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
solr
Solr Support => enabled
-Version => 2.6.0
-Last Build Date => Nov 9 2022
+Version => 2.7.0
+Last Build Date => Jan 11 2024
Last Build Time => 00:00:00
diff --git a/REFLECTION b/REFLECTION
index 5593de7..fe186a1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #124 solr version 2.6.0 ] {
+Extension [ <persistent> extension #82 solr version 2.7.0 ] {
- Dependencies {
Dependency [ libxml (Required) ]
@@ -7,9 +7,9 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
- Constants [4] {
Constant [ int SOLR_MAJOR_VERSION ] { 2 }
- Constant [ int SOLR_MINOR_VERSION ] { 6 }
+ Constant [ int SOLR_MINOR_VERSION ] { 7 }
Constant [ int SOLR_PATCH_VERSION ] { 0 }
- Constant [ string SOLR_EXTENSION_VERSION ] { 2.6.0 }
+ Constant [ string SOLR_EXTENSION_VERSION ] { 2.7.0 }
}
- Functions {
@@ -1093,7 +1093,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected $_hashtable_index = 0 ]
}
- - Methods [208] {
+ - Methods [210] {
Method [ <internal:solr, overwrites SolrModifiableParams, ctor> public method __construct ] {
- Parameters [1] {
@@ -1794,6 +1794,19 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
}
}
+ Method [ <internal:solr> public method setHighlightQuery ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $q ]
+ }
+ }
+
+ Method [ <internal:solr> public method getHighlightQuery ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:solr> public method addHighlightField ] {
- Parameters [1] {
@@ -2528,7 +2541,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected $_hashtable_index = 0 ]
}
- - Methods [235] {
+ - Methods [237] {
Method [ <internal:solr, overwrites SolrQuery, ctor> public method __construct ] {
- Parameters [1] {
@@ -3425,6 +3438,19 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
}
}
+ Method [ <internal:solr, inherits SolrQuery> public method setHighlightQuery ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $q ]
+ }
+ }
+
+ Method [ <internal:solr, inherits SolrQuery> public method getHighlightQuery ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:solr, inherits SolrQuery> public method addHighlightField ] {
- Parameters [1] {
@@ -4997,7 +5023,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected string $file = '' ]
Property [ protected int $line = 0 ]
Property [ protected $sourceline = 118 ]
- Property [ protected $sourcefile = '/builddir/build/BUILD/php-pecl-solr2-2.6.0/NTS/src/php7/solr_functions_helpers.c' ]
+ Property [ protected $sourcefile = '/dev/shm/BUILD/php-pecl-solr2-2.7.0/solr-2.7.0/src/php7/solr_functions_helpers.c' ]
Property [ protected $zif_name = 'solr_exception_register_class_properties' ]
}
@@ -5098,7 +5124,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected string $file = '' ]
Property [ protected int $line = 0 ]
Property [ protected $sourceline = 118 ]
- Property [ protected $sourcefile = '/builddir/build/BUILD/php-pecl-solr2-2.6.0/NTS/src/php7/solr_functions_helpers.c' ]
+ Property [ protected $sourcefile = '/dev/shm/BUILD/php-pecl-solr2-2.7.0/solr-2.7.0/src/php7/solr_functions_helpers.c' ]
Property [ protected $zif_name = 'solr_exception_register_class_properties' ]
}
@@ -5199,7 +5225,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected string $file = '' ]
Property [ protected int $line = 0 ]
Property [ protected $sourceline = 118 ]
- Property [ protected $sourcefile = '/builddir/build/BUILD/php-pecl-solr2-2.6.0/NTS/src/php7/solr_functions_helpers.c' ]
+ Property [ protected $sourcefile = '/dev/shm/BUILD/php-pecl-solr2-2.7.0/solr-2.7.0/src/php7/solr_functions_helpers.c' ]
Property [ protected $zif_name = 'solr_exception_register_class_properties' ]
}
@@ -5300,7 +5326,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected string $file = '' ]
Property [ protected int $line = 0 ]
Property [ protected $sourceline = 118 ]
- Property [ protected $sourcefile = '/builddir/build/BUILD/php-pecl-solr2-2.6.0/NTS/src/php7/solr_functions_helpers.c' ]
+ Property [ protected $sourcefile = '/dev/shm/BUILD/php-pecl-solr2-2.7.0/solr-2.7.0/src/php7/solr_functions_helpers.c' ]
Property [ protected $zif_name = 'solr_exception_register_class_properties' ]
}
@@ -5401,7 +5427,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected string $file = '' ]
Property [ protected int $line = 0 ]
Property [ protected $sourceline = 118 ]
- Property [ protected $sourcefile = '/builddir/build/BUILD/php-pecl-solr2-2.6.0/NTS/src/php7/solr_functions_helpers.c' ]
+ Property [ protected $sourcefile = '/dev/shm/BUILD/php-pecl-solr2-2.7.0/solr-2.7.0/src/php7/solr_functions_helpers.c' ]
Property [ protected $zif_name = 'solr_exception_register_class_properties' ]
}
@@ -5502,7 +5528,7 @@ Extension [ <persistent> extension #124 solr version 2.6.0 ] {
Property [ protected string $file = '' ]
Property [ protected int $line = 0 ]
Property [ protected $sourceline = 118 ]
- Property [ protected $sourcefile = '/builddir/build/BUILD/php-pecl-solr2-2.6.0/NTS/src/php7/solr_functions_helpers.c' ]
+ Property [ protected $sourcefile = '/dev/shm/BUILD/php-pecl-solr2-2.7.0/solr-2.7.0/src/php7/solr_functions_helpers.c' ]
Property [ protected $zif_name = 'solr_exception_register_class_properties' ]
}
diff --git a/php-pecl-solr2.spec b/php-pecl-solr2.spec
index b58926e..91b1b2e 100644
--- a/php-pecl-solr2.spec
+++ b/php-pecl-solr2.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-solr2
#
-# Copyright (c) 2011-2023 Remi Collet
+# Copyright (c) 2011-2024 Remi Collet
# Copyright (c) 2010 Johan Cwiklinski
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
@@ -21,17 +21,17 @@
%global _configure ../%{sources}/configure
# For full test (using localhost server) use --with fulltests
-# retrieve: docker pull omars/solr53
-# create: docker run -d -p 8983:8983 --name solr5 -t omars/solr53
-# cleanup: docker stop solr5 && docker rm solr5
+# retrieve: podman pull docker.io/omars/solr53
+# create: podman run -d -p 8983:8983 --name solr5 -t omars/solr53
+# cleanup: podman kill solr5 && podman stop solr5 && podman rm solr5
%bcond_without tests
%bcond_with fulltests
Summary: Object oriented API to Apache Solr
Summary(fr): API orientée objet pour Apache Solr
Name: %{?scl_prefix}php-pecl-solr2
-Version: 2.6.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.7.0
+Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/solr
@@ -125,12 +125,16 @@ cd %{sources}
%{__phpize}
cd ../NTS
-%configure --with-php-config=%{__phpconfig}
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%configure --with-php-config=%{__ztsphpconfig}
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -243,6 +247,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Jan 11 2024 Remi Collet <remi@remirepo.net> - 2.7.0-0
+- test build for upcoming 2.7.0
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 2.6.0-3
- rebuild for PHP 8.3.0RC1