summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 15:45:31 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 15:45:31 +0100
commit4fd0d665728ebaf7f413d9363abaa2bf431aefcc (patch)
tree4e2c876969764d868b6be51267b6698487d043bf
parent4c8c08c40679b77c5b76864bfc364fe407bada8e (diff)
php-pecl-solr: F24
-rw-r--r--php-pecl-solr.spec28
1 files changed, 14 insertions, 14 deletions
diff --git a/php-pecl-solr.spec b/php-pecl-solr.spec
index 75ff9b6..d0bb2f6 100644
--- a/php-pecl-solr.spec
+++ b/php-pecl-solr.spec
@@ -19,9 +19,6 @@
%endif
%{?scl: %scl_package php-pecl-solr}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global pecl_name solr
%global with_zts 0%{?__ztsphp:1}
@@ -37,7 +34,7 @@ Summary: Object oriented API to Apache Solr
Summary(fr): API orientée objet pour Apache Solr
Name: %{?sub_prefix}php-pecl-solr
Version: 1.1.1
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/solr
@@ -54,20 +51,16 @@ BuildRequires: libxml2-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%if "%{php_version}" < "5.4"
-# php 5.3.3 in EL-6 don't use arched virtual provides
-# so only requires real packages instead
-Requires: %{?scl_prefix}php-common%{?_isa}
-%else
Requires: %{?scl_prefix}php-curl%{?_isa}
Requires: %{?scl_prefix}php-json%{?_isa}
-%endif
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -155,7 +148,9 @@ Paquet construit pour PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VE
mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
@@ -215,6 +210,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -231,6 +227,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -286,6 +283,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-4
+- adapt for F24
+
* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 1.1.1-3
- allow build against rh-php56 (as more-php56)
- drop runtime dependency on pear, new scriptlets