summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-10 11:51:13 +0200
committerRemi Collet <remi@php.net>2022-10-10 11:51:13 +0200
commit7e465a57f4cfdd5eac8daf429453ff239a5e714e (patch)
tree1bf79be6bae5457b973cf3782d919d9dc58d671b
initial package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION27
-rwxr-xr-xmakedeps.sh20
-rw-r--r--php-pecl-skywalking-agent.spec241
6 files changed, 315 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..c1ae5c6
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,14 @@
+
+skywalking_agent
+
+version => 0.1.0
+authors => Apache Software Foundation:jmjoy <jmjoy@apache.org>:Yanlong He <heyanlong@apache.org>
+
+Directive => Local Value => Master Value
+skywalking_agent.server_addr => http://127.0.0.1:11800 => http://127.0.0.1:11800
+skywalking_agent.skywalking_version => 8 => 8
+skywalking_agent.worker_threads => 0 => 0
+skywalking_agent.log_file => /tmp/skywalking-agent.log => /tmp/skywalking-agent.log
+skywalking_agent.log_level => OFF => OFF
+skywalking_agent.service_name => hello-skywalking => hello-skywalking
+skywalking_agent.enable => false => false
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..3570ce4
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,27 @@
+Extension [ <persistent> extension #99 skywalking_agent version <no_version> ] {
+
+ - INI {
+ Entry [ skywalking_agent.skywalking_version <SYSTEM> ]
+ Current = '8'
+ }
+ Entry [ skywalking_agent.worker_threads <SYSTEM> ]
+ Current = '0'
+ }
+ Entry [ skywalking_agent.service_name <SYSTEM> ]
+ Current = 'hello-skywalking'
+ }
+ Entry [ skywalking_agent.server_addr <SYSTEM> ]
+ Current = 'http://127.0.0.1:11800'
+ }
+ Entry [ skywalking_agent.enable <SYSTEM> ]
+ Current = 'false'
+ }
+ Entry [ skywalking_agent.log_file <SYSTEM> ]
+ Current = '/tmp/skywalking-agent.log'
+ }
+ Entry [ skywalking_agent.log_level <SYSTEM> ]
+ Current = 'OFF'
+ }
+ }
+}
+
diff --git a/makedeps.sh b/makedeps.sh
new file mode 100755
index 0000000..b102749
--- /dev/null
+++ b/makedeps.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if [ $# -lt 1 ]; then
+ echo usage $0 version
+ exit 0
+fi
+if [ -f skywalking_agent-$1.tgz ]; then
+ echo "+ Unpack"
+ tar xf skywalking_agent-$1.tgz
+
+ pushd skywalking_agent-$1
+ echo "+ Fetch"
+ cargo vendor mycargo
+
+ echo "+ Pack"
+ tar czf ../skywalking_agent-deps-$1.tgz mycargo
+ popd
+else
+ echo skywalking_agent-$version.tgz missing
+fi
diff --git a/php-pecl-skywalking-agent.spec b/php-pecl-skywalking-agent.spec
new file mode 100644
index 0000000..48c79f5
--- /dev/null
+++ b/php-pecl-skywalking-agent.spec
@@ -0,0 +1,241 @@
+# remirepo spec file for php-pecl-skywalking-agent
+#
+# Copyright (c) 2022 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%scl_package php-pecl-skywalking-agent
+%else
+%global _root_bindir %{_bindir}
+%endif
+
+%global pecl_name skywalking_agent
+# not supported by upstream
+%global with_zts 0
+%global ini_name 40-%{pecl_name}.ini
+
+
+## TODO: issues
+# bad role for documentation (role="src" instead of role="doc")
+#=> fixed in prep
+# no PHP 8.2 support
+# broken build with new GCC 12 (Fedora 36+)
+# broken build with rust 1.58 (RHEL-8 and RHEL-9)
+# => 1.62 on 6.7 and 9.1
+# no support for offline build
+# => workaround with "cargo vendor"
+
+
+Summary: Apache SkyWalking PHP Agent
+Name: %{?scl_prefix}php-pecl-skywalking-agent
+Version: 0.1.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: ASL 2.0
+URL: https://pecl.php.net/package/%{pecl_name}
+
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# awfull hack, use a bundled rust registry
+Source1: makedeps.sh
+Source2: https://pecl.php.net/get/%{pecl_name}-deps-%{version}.tgz
+
+%if 0%{?rhel} == 7 && 0%{?dtsversion} == 0
+BuildRequires: devtoolset-6-toolchain
+%global dtsversion 6
+%global dtsenable source /opt/rh/devtoolset-6/enable
+%global dtsprefix devtoolset-6-
+%endif
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc-c++
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: cargo
+BuildRequires: rustfmt
+BuildRequires: protobuf-compiler
+BuildRequires: clang-devel
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 9
+BuildRequires: rust-packaging
+%endif
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+
+%description
+The PHP Agent for Apache SkyWalking, which provides the native tracing
+abilities for PHP project.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c -a2
+mv %{pecl_name}-%{version} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ -e '/"NOTICE"/s/role="src"/role="doc"/' \
+ -e '/"README.md"/s/role="src"/role="doc"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+pushd NTS
+# Create cargo configuration to use vendor directory
+mkdir .cargo
+cat << EOF | tee .cargo/config.toml
+[build]
+rustc = "%{_root_bindir}/rustc"
+
+[env]
+CFLAGS = "%{build_cflags}"
+CXXFLAGS = "%{build_cxxflags}"
+LDFLAGS = "%{build_ldflags}"
+
+[term]
+verbose = true
+
+[source.crates-io]
+replace-with = "vendored-sources"
+
+[source.vendored-sources]
+directory = "$(dirname $PWD)/mycargo"
+EOF
+
+: Check version
+grep '^version' Cargo.toml
+grep '^version = "%{version}"' Cargo.toml
+popd
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+
+; Configuration
+;skywalking_agent.worker_threads = 0
+;skywalking_agent.service_name = "hello-skywalking"
+;skywalking_agent.server_addr = "http://127.0.0.1:11800"
+;skywalking_agent.skywalking_version = 8
+;skywalking_agent.enable = false
+;skywalking_agent.log_file = "/tmp/skywalking-agent.log"
+;skywalking_agent.log_level = OFF
+
+EOF
+
+
+%build
+%{?dtsenable}
+
+export CARGO_HOME=$PWD/mycargo
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --enable-skywalking_agent \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --enable-skywalking_agent \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+%{!?_licensedir:install -Dpm 644 LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE}
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+OPT="-n -d extension=curl.so -d extension=json.so"
+
+# Minimal load test for NTS extension
+%{__php} $OPT \
+ --define extension=$PWD/NTS/modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_zts}
+# Minimal load test for ZTS extension
+%{__ztsphp} $OPT \
+ --define extension=$PWD/ZTS/modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Mon Oct 10 2022 Remi Collet <remi@remirepo.net> - 0.1.0-1
+- initial package