summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION566
-rw-r--r--php-pecl-simple-kafka-client.spec13
3 files changed, 418 insertions, 169 deletions
diff --git a/PHPINFO b/PHPINFO
index dafb823..3e80534 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
simple_kafka_client
kafka support => enabled
-version => 0.1.2
-build date => Apr 13 2021 00:00:00
-librdkafka version (runtime) => 1.6.1
-librdkafka version (build) => 1.6.1.255
+version => 0.1.3
+build date => Jul 1 2021 00:00:00
+librdkafka version (runtime) => 1.7.0
+librdkafka version (build) => 1.7.0.255
diff --git a/REFLECTION b/REFLECTION
index e78f8fb..2998faa 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,184 @@
-Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
+Extension [ <persistent> extension #121 simple_kafka_client version 0.1.3 ] {
+
+ - Constants [177] {
+ Constant [ int RD_KAFKA_OFFSET_BEGINNING ] { -2 }
+ Constant [ int RD_KAFKA_OFFSET_END ] { -1 }
+ Constant [ int RD_KAFKA_OFFSET_STORED ] { -1000 }
+ Constant [ int RD_KAFKA_PARTITION_UA ] { -1 }
+ Constant [ int RD_KAFKA_MSG_F_BLOCK ] { 4 }
+ Constant [ int RD_KAFKA_PURGE_F_QUEUE ] { 1 }
+ Constant [ int RD_KAFKA_PURGE_F_INFLIGHT ] { 2 }
+ Constant [ int RD_KAFKA_PURGE_F_NON_BLOCKING ] { 4 }
+ Constant [ int RD_KAFKA_VERSION ] { 17236223 }
+ Constant [ int RD_KAFKA_BUILD_VERSION ] { 17236223 }
+ Constant [ int RD_KAFKA_RESP_ERR__BEGIN ] { -200 }
+ Constant [ int RD_KAFKA_RESP_ERR__BAD_MSG ] { -199 }
+ Constant [ int RD_KAFKA_RESP_ERR__BAD_COMPRESSION ] { -198 }
+ Constant [ int RD_KAFKA_RESP_ERR__DESTROY ] { -197 }
+ Constant [ int RD_KAFKA_RESP_ERR__FAIL ] { -196 }
+ Constant [ int RD_KAFKA_RESP_ERR__TRANSPORT ] { -195 }
+ Constant [ int RD_KAFKA_RESP_ERR__CRIT_SYS_RESOURCE ] { -194 }
+ Constant [ int RD_KAFKA_RESP_ERR__RESOLVE ] { -193 }
+ Constant [ int RD_KAFKA_RESP_ERR__MSG_TIMED_OUT ] { -192 }
+ Constant [ int RD_KAFKA_RESP_ERR__PARTITION_EOF ] { -191 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_PARTITION ] { -190 }
+ Constant [ int RD_KAFKA_RESP_ERR__FS ] { -189 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_TOPIC ] { -188 }
+ Constant [ int RD_KAFKA_RESP_ERR__ALL_BROKERS_DOWN ] { -187 }
+ Constant [ int RD_KAFKA_RESP_ERR__INVALID_ARG ] { -186 }
+ Constant [ int RD_KAFKA_RESP_ERR__TIMED_OUT ] { -185 }
+ Constant [ int RD_KAFKA_RESP_ERR__QUEUE_FULL ] { -184 }
+ Constant [ int RD_KAFKA_RESP_ERR__ISR_INSUFF ] { -183 }
+ Constant [ int RD_KAFKA_RESP_ERR__NODE_UPDATE ] { -182 }
+ Constant [ int RD_KAFKA_RESP_ERR__SSL ] { -181 }
+ Constant [ int RD_KAFKA_RESP_ERR__WAIT_COORD ] { -180 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_GROUP ] { -179 }
+ Constant [ int RD_KAFKA_RESP_ERR__IN_PROGRESS ] { -178 }
+ Constant [ int RD_KAFKA_RESP_ERR__PREV_IN_PROGRESS ] { -177 }
+ Constant [ int RD_KAFKA_RESP_ERR__EXISTING_SUBSCRIPTION ] { -176 }
+ Constant [ int RD_KAFKA_RESP_ERR__ASSIGN_PARTITIONS ] { -175 }
+ Constant [ int RD_KAFKA_RESP_ERR__REVOKE_PARTITIONS ] { -174 }
+ Constant [ int RD_KAFKA_RESP_ERR__CONFLICT ] { -173 }
+ Constant [ int RD_KAFKA_RESP_ERR__STATE ] { -172 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_PROTOCOL ] { -171 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOT_IMPLEMENTED ] { -170 }
+ Constant [ int RD_KAFKA_RESP_ERR__AUTHENTICATION ] { -169 }
+ Constant [ int RD_KAFKA_RESP_ERR__NO_OFFSET ] { -168 }
+ Constant [ int RD_KAFKA_RESP_ERR__OUTDATED ] { -167 }
+ Constant [ int RD_KAFKA_RESP_ERR__TIMED_OUT_QUEUE ] { -166 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNSUPPORTED_FEATURE ] { -165 }
+ Constant [ int RD_KAFKA_RESP_ERR__WAIT_CACHE ] { -164 }
+ Constant [ int RD_KAFKA_RESP_ERR__INTR ] { -163 }
+ Constant [ int RD_KAFKA_RESP_ERR__KEY_SERIALIZATION ] { -162 }
+ Constant [ int RD_KAFKA_RESP_ERR__VALUE_SERIALIZATION ] { -161 }
+ Constant [ int RD_KAFKA_RESP_ERR__KEY_DESERIALIZATION ] { -160 }
+ Constant [ int RD_KAFKA_RESP_ERR__VALUE_DESERIALIZATION ] { -159 }
+ Constant [ int RD_KAFKA_RESP_ERR__PARTIAL ] { -158 }
+ Constant [ int RD_KAFKA_RESP_ERR__READ_ONLY ] { -157 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOENT ] { -156 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNDERFLOW ] { -155 }
+ Constant [ int RD_KAFKA_RESP_ERR__INVALID_TYPE ] { -154 }
+ Constant [ int RD_KAFKA_RESP_ERR__RETRY ] { -153 }
+ Constant [ int RD_KAFKA_RESP_ERR__PURGE_QUEUE ] { -152 }
+ Constant [ int RD_KAFKA_RESP_ERR__PURGE_INFLIGHT ] { -151 }
+ Constant [ int RD_KAFKA_RESP_ERR__FATAL ] { -150 }
+ Constant [ int RD_KAFKA_RESP_ERR__INCONSISTENT ] { -149 }
+ Constant [ int RD_KAFKA_RESP_ERR__GAPLESS_GUARANTEE ] { -148 }
+ Constant [ int RD_KAFKA_RESP_ERR__MAX_POLL_EXCEEDED ] { -147 }
+ Constant [ int RD_KAFKA_RESP_ERR__UNKNOWN_BROKER ] { -146 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOT_CONFIGURED ] { -145 }
+ Constant [ int RD_KAFKA_RESP_ERR__FENCED ] { -144 }
+ Constant [ int RD_KAFKA_RESP_ERR__APPLICATION ] { -143 }
+ Constant [ int RD_KAFKA_RESP_ERR__ASSIGNMENT_LOST ] { -142 }
+ Constant [ int RD_KAFKA_RESP_ERR__NOOP ] { -141 }
+ Constant [ int RD_KAFKA_RESP_ERR__AUTO_OFFSET_RESET ] { -140 }
+ Constant [ int RD_KAFKA_RESP_ERR__END ] { -100 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN ] { -1 }
+ Constant [ int RD_KAFKA_RESP_ERR_NO_ERROR ] { 0 }
+ Constant [ int RD_KAFKA_RESP_ERR_OFFSET_OUT_OF_RANGE ] { 1 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_MSG ] { 2 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_TOPIC_OR_PART ] { 3 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_MSG_SIZE ] { 4 }
+ Constant [ int RD_KAFKA_RESP_ERR_LEADER_NOT_AVAILABLE ] { 5 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_LEADER_FOR_PARTITION ] { 6 }
+ Constant [ int RD_KAFKA_RESP_ERR_REQUEST_TIMED_OUT ] { 7 }
+ Constant [ int RD_KAFKA_RESP_ERR_BROKER_NOT_AVAILABLE ] { 8 }
+ Constant [ int RD_KAFKA_RESP_ERR_REPLICA_NOT_AVAILABLE ] { 9 }
+ Constant [ int RD_KAFKA_RESP_ERR_MSG_SIZE_TOO_LARGE ] { 10 }
+ Constant [ int RD_KAFKA_RESP_ERR_STALE_CTRL_EPOCH ] { 11 }
+ Constant [ int RD_KAFKA_RESP_ERR_OFFSET_METADATA_TOO_LARGE ] { 12 }
+ Constant [ int RD_KAFKA_RESP_ERR_NETWORK_EXCEPTION ] { 13 }
+ Constant [ int RD_KAFKA_RESP_ERR_COORDINATOR_LOAD_IN_PROGRESS ] { 14 }
+ Constant [ int RD_KAFKA_RESP_ERR_COORDINATOR_NOT_AVAILABLE ] { 15 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_COORDINATOR ] { 16 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_EXCEPTION ] { 17 }
+ Constant [ int RD_KAFKA_RESP_ERR_RECORD_LIST_TOO_LARGE ] { 18 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_ENOUGH_REPLICAS ] { 19 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_ENOUGH_REPLICAS_AFTER_APPEND ] { 20 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REQUIRED_ACKS ] { 21 }
+ Constant [ int RD_KAFKA_RESP_ERR_ILLEGAL_GENERATION ] { 22 }
+ Constant [ int RD_KAFKA_RESP_ERR_INCONSISTENT_GROUP_PROTOCOL ] { 23 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_GROUP_ID ] { 24 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_MEMBER_ID ] { 25 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_SESSION_TIMEOUT ] { 26 }
+ Constant [ int RD_KAFKA_RESP_ERR_REBALANCE_IN_PROGRESS ] { 27 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_COMMIT_OFFSET_SIZE ] { 28 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_AUTHORIZATION_FAILED ] { 29 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_AUTHORIZATION_FAILED ] { 30 }
+ Constant [ int RD_KAFKA_RESP_ERR_CLUSTER_AUTHORIZATION_FAILED ] { 31 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_TIMESTAMP ] { 32 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_SASL_MECHANISM ] { 33 }
+ Constant [ int RD_KAFKA_RESP_ERR_ILLEGAL_SASL_STATE ] { 34 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_VERSION ] { 35 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_ALREADY_EXISTS ] { 36 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PARTITIONS ] { 37 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REPLICATION_FACTOR ] { 38 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REPLICA_ASSIGNMENT ] { 39 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_CONFIG ] { 40 }
+ Constant [ int RD_KAFKA_RESP_ERR_NOT_CONTROLLER ] { 41 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_REQUEST ] { 42 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_FOR_MESSAGE_FORMAT ] { 43 }
+ Constant [ int RD_KAFKA_RESP_ERR_POLICY_VIOLATION ] { 44 }
+ Constant [ int RD_KAFKA_RESP_ERR_OUT_OF_ORDER_SEQUENCE_NUMBER ] { 45 }
+ Constant [ int RD_KAFKA_RESP_ERR_DUPLICATE_SEQUENCE_NUMBER ] { 46 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PRODUCER_EPOCH ] { 47 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_TXN_STATE ] { 48 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PRODUCER_ID_MAPPING ] { 49 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_TRANSACTION_TIMEOUT ] { 50 }
+ Constant [ int RD_KAFKA_RESP_ERR_CONCURRENT_TRANSACTIONS ] { 51 }
+ Constant [ int RD_KAFKA_RESP_ERR_TRANSACTION_COORDINATOR_FENCED ] { 52 }
+ Constant [ int RD_KAFKA_RESP_ERR_TRANSACTIONAL_ID_AUTHORIZATION_FAILED ] { 53 }
+ Constant [ int RD_KAFKA_RESP_ERR_SECURITY_DISABLED ] { 54 }
+ Constant [ int RD_KAFKA_RESP_ERR_OPERATION_NOT_ATTEMPTED ] { 55 }
+ Constant [ int RD_KAFKA_RESP_ERR_KAFKA_STORAGE_ERROR ] { 56 }
+ Constant [ int RD_KAFKA_RESP_ERR_LOG_DIR_NOT_FOUND ] { 57 }
+ Constant [ int RD_KAFKA_RESP_ERR_SASL_AUTHENTICATION_FAILED ] { 58 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_PRODUCER_ID ] { 59 }
+ Constant [ int RD_KAFKA_RESP_ERR_REASSIGNMENT_IN_PROGRESS ] { 60 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTH_DISABLED ] { 61 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_NOT_FOUND ] { 62 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_OWNER_MISMATCH ] { 63 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_REQUEST_NOT_ALLOWED ] { 64 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_AUTHORIZATION_FAILED ] { 65 }
+ Constant [ int RD_KAFKA_RESP_ERR_DELEGATION_TOKEN_EXPIRED ] { 66 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_PRINCIPAL_TYPE ] { 67 }
+ Constant [ int RD_KAFKA_RESP_ERR_NON_EMPTY_GROUP ] { 68 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_ID_NOT_FOUND ] { 69 }
+ Constant [ int RD_KAFKA_RESP_ERR_FETCH_SESSION_ID_NOT_FOUND ] { 70 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_FETCH_SESSION_EPOCH ] { 71 }
+ Constant [ int RD_KAFKA_RESP_ERR_LISTENER_NOT_FOUND ] { 72 }
+ Constant [ int RD_KAFKA_RESP_ERR_TOPIC_DELETION_DISABLED ] { 73 }
+ Constant [ int RD_KAFKA_RESP_ERR_FENCED_LEADER_EPOCH ] { 74 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNKNOWN_LEADER_EPOCH ] { 75 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSUPPORTED_COMPRESSION_TYPE ] { 76 }
+ Constant [ int RD_KAFKA_RESP_ERR_STALE_BROKER_EPOCH ] { 77 }
+ Constant [ int RD_KAFKA_RESP_ERR_OFFSET_NOT_AVAILABLE ] { 78 }
+ Constant [ int RD_KAFKA_RESP_ERR_MEMBER_ID_REQUIRED ] { 79 }
+ Constant [ int RD_KAFKA_RESP_ERR_PREFERRED_LEADER_NOT_AVAILABLE ] { 80 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_MAX_SIZE_REACHED ] { 81 }
+ Constant [ int RD_KAFKA_RESP_ERR_FENCED_INSTANCE_ID ] { 82 }
+ Constant [ int RD_KAFKA_RESP_ERR_ELIGIBLE_LEADERS_NOT_AVAILABLE ] { 83 }
+ Constant [ int RD_KAFKA_RESP_ERR_ELECTION_NOT_NEEDED ] { 84 }
+ Constant [ int RD_KAFKA_RESP_ERR_NO_REASSIGNMENT_IN_PROGRESS ] { 85 }
+ Constant [ int RD_KAFKA_RESP_ERR_GROUP_SUBSCRIBED_TO_TOPIC ] { 86 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_RECORD ] { 87 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNSTABLE_OFFSET_COMMIT ] { 88 }
+ Constant [ int RD_KAFKA_RESP_ERR_THROTTLING_QUOTA_EXCEEDED ] { 89 }
+ Constant [ int RD_KAFKA_RESP_ERR_PRODUCER_FENCED ] { 90 }
+ Constant [ int RD_KAFKA_RESP_ERR_RESOURCE_NOT_FOUND ] { 91 }
+ Constant [ int RD_KAFKA_RESP_ERR_DUPLICATE_RESOURCE ] { 92 }
+ Constant [ int RD_KAFKA_RESP_ERR_UNACCEPTABLE_CREDENTIAL ] { 93 }
+ Constant [ int RD_KAFKA_RESP_ERR_INCONSISTENT_VOTER_SET ] { 94 }
+ Constant [ int RD_KAFKA_RESP_ERR_INVALID_UPDATE_VERSION ] { 95 }
+ Constant [ int RD_KAFKA_RESP_ERR_FEATURE_UPDATE_FAILED ] { 96 }
+ Constant [ int RD_KAFKA_RESP_ERR_PRINCIPAL_DESERIALIZATION_FAILURE ] { 97 }
+ Constant [ int RD_KAFKA_CONF_UNKNOWN ] { -2 }
+ Constant [ int RD_KAFKA_CONF_INVALID ] { -1 }
+ Constant [ int RD_KAFKA_CONF_OK ] { 0 }
+ Constant [ int RD_KAFKA_LOG_PRINT ] { 100 }
+ Constant [ int RD_KAFKA_LOG_SYSLOG ] { 101 }
+ Constant [ int RD_KAFKA_LOG_SYSLOG_PRINT ] { 102 }
+ }
- Functions {
Function [ <internal:simple_kafka_client> function kafka_get_err_descs ] {
@@ -51,7 +231,7 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
- Properties [0] {
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:simple_kafka_client> public method getMetadata ] {
- Parameters [3] {
@@ -69,14 +249,6 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
- Return [ int ]
}
- Method [ <internal:simple_kafka_client> public method poll ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> int $timeoutMs ]
- }
- - Return [ int ]
- }
-
Method [ <internal:simple_kafka_client> public method queryWatermarkOffsets ] {
- Parameters [5] {
@@ -97,6 +269,25 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
}
- Return [ array ]
}
+
+ Method [ <internal:simple_kafka_client> public method setOAuthBearerTokenFailure ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $errorString ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method setOAuthBearerToken ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $token ]
+ Parameter #1 [ <required> int $lifetimeMs ]
+ Parameter #2 [ <required> string $principalName ]
+ Parameter #3 [ <optional> $extensions ]
+ }
+ - Return [ void ]
+ }
}
}
@@ -114,7 +305,7 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
- Properties [0] {
}
- - Methods [13] {
+ - Methods [15] {
Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
- Parameters [1] {
@@ -161,6 +352,14 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
- Return [ int ]
}
+ Method [ <internal:simple_kafka_client> public method poll ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $timeoutMs ]
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:simple_kafka_client> public method purge ] {
- Parameters [1] {
@@ -194,11 +393,177 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
- Return [ int ]
}
- Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method poll ] {
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method queryWatermarkOffsets ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> string $topic ]
+ Parameter #1 [ <required> int $partition ]
+ Parameter #2 [ <required> int &$low ]
+ Parameter #3 [ <required> int &$high ]
+ Parameter #4 [ <required> int $timeoutMs ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method offsetsForTimes ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $topicPartitions ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method setOAuthBearerTokenFailure ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $errorString ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method setOAuthBearerToken ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $token ]
+ Parameter #1 [ <required> int $lifetimeMs ]
+ Parameter #2 [ <required> string $principalName ]
+ Parameter #3 [ <optional> $extensions ]
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
+ Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Consumer extends SimpleKafkaClient ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [19] {
+ Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> SimpleKafkaClient\Configuration $configuration ]
+ }
+ }
+
+ Method [ <internal:simple_kafka_client> public method assign ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $topics ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getAssignment ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method subscribe ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $topics ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getSubscription ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method unsubscribe ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method consume ] {
- Parameters [1] {
Parameter #0 [ <required> int $timeoutMs ]
}
+ - Return [ SimpleKafkaClient\Message ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method commit ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $messageOrOffsets ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method commitAsync ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $messageOrOffsets ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method close ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getTopicHandle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $topic ]
+ }
+ - Return [ SimpleKafkaClient\ConsumerTopic ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getCommittedOffsets ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $topics ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client> public method getOffsetPositions ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $topics ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method getMetadata ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> bool $allTopics ]
+ Parameter #1 [ <required> int $timeoutMs ]
+ Parameter #2 [ <required> SimpleKafkaClient\Topic $topic ]
+ }
+ - Return [ SimpleKafkaClient\Metadata ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method getOutQLen ] {
+
+ - Parameters [0] {
+ }
- Return [ int ]
}
@@ -222,6 +587,25 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
}
- Return [ array ]
}
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method setOAuthBearerTokenFailure ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $errorString ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:simple_kafka_client, inherits SimpleKafkaClient> public method setOAuthBearerToken ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $token ]
+ Parameter #1 [ <required> int $lifetimeMs ]
+ Parameter #2 [ <required> string $principalName ]
+ Parameter #3 [ <optional> $extensions ]
+ }
+ - Return [ void ]
+ }
}
}
@@ -239,7 +623,7 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
- Parameters [0] {
@@ -309,6 +693,14 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
}
- Return [ void ]
}
+
+ Method [ <internal:simple_kafka_client> public method setOAuthBearerTokenRefreshCb ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> callable $callback ]
+ }
+ - Return [ void ]
+ }
}
}
@@ -461,154 +853,6 @@ Extension [ <persistent> extension #101 simple_kafka_client version 0.1.2 ] {
}
}
- Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Consumer ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [16] {
- Method [ <internal:simple_kafka_client, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> SimpleKafkaClient\Configuration $configuration ]
- }
- }
-
- Method [ <internal:simple_kafka_client> public method assign ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array or NULL $topics ]
- }
- - Return [ void ]
- }
-
- Method [ <internal:simple_kafka_client> public method getAssignment ] {
-
- - Parameters [0] {
- }
- - Return [ array ]
- }
-
- Method [ <internal:simple_kafka_client> public method subscribe ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $topics ]
- }
- - Return [ void ]
- }
-
- Method [ <internal:simple_kafka_client> public method getSubscription ] {
-
- - Parameters [0] {
- }
- - Return [ array ]
- }
-
- Method [ <internal:simple_kafka_client> public method unsubscribe ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
-
- Method [ <internal:simple_kafka_client> public method consume ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> int $timeoutMs ]
- }
- - Return [ SimpleKafkaClient\Message ]
- }
-
- Method [ <internal:simple_kafka_client> public method commit ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $messageOrOffsets ]
- }
- - Return [ void ]
- }
-
- Method [ <internal:simple_kafka_client> public method commitAsync ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $messageOrOffsets ]
- }
- - Return [ void ]
- }
-
- Method [ <internal:simple_kafka_client> public method close ] {
-
- - Parameters [0] {
- }
- - Return [ void ]
- }
-
- Method [ <internal:simple_kafka_client> public method getMetadata ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> bool $allTopics ]
- Parameter #1 [ <required> int $timeoutMs ]
- Parameter #2 [ <required> SimpleKafkaClient\ConsumerTopic $topic ]
- }
- - Return [ SimpleKafkaClient\Metadata ]
- }
-
- Method [ <internal:simple_kafka_client> public method getTopicHandle ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $topic ]
- }
- - Return [ SimpleKafkaClient\ConsumerTopic ]
- }
-
- Method [ <internal:simple_kafka_client> public method getCommittedOffsets ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> array $topics ]
- Parameter #1 [ <required> int $timeoutMs ]
- }
- - Return [ array ]
- }
-
- Method [ <internal:simple_kafka_client> public method getOffsetPositions ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $topics ]
- }
- - Return [ array ]
- }
-
- Method [ <internal:simple_kafka_client> public method offsetsForTimes ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> array $topicPartitions ]
- Parameter #1 [ <required> int $timeoutMs ]
- }
- - Return [ array ]
- }
-
- Method [ <internal:simple_kafka_client> public method queryWatermarkOffsets ] {
-
- - Parameters [5] {
- Parameter #0 [ <required> string $topic ]
- Parameter #1 [ <required> int $partition ]
- Parameter #2 [ <required> int &$low ]
- Parameter #3 [ <required> int &$high ]
- Parameter #4 [ <required> int $timeoutMs ]
- }
- - Return [ void ]
- }
- }
- }
-
Class [ <internal:simple_kafka_client> class SimpleKafkaClient\Message ] {
- Constants [0] {
diff --git a/php-pecl-simple-kafka-client.spec b/php-pecl-simple-kafka-client.spec
index ea55831..ba833fa 100644
--- a/php-pecl-simple-kafka-client.spec
+++ b/php-pecl-simple-kafka-client.spec
@@ -20,7 +20,7 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-simple-kafka-client
-Version: 0.1.2
+Version: 0.1.3
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
@@ -28,7 +28,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: librdkafka1php-devel >= 1.6
+BuildRequires: librdkafka1php-devel >= 1.7
BuildRequires: %{?scl_prefix}php-devel >= 7.3
BuildRequires: %{?scl_prefix}php-pear
@@ -55,6 +55,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -167,9 +170,8 @@ cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%if %{with_zts}
cd ../ZTS
@@ -195,6 +197,9 @@ cd ../ZTS
%changelog
+* Thu Jul 1 2021 Remi Collet <remi@remirepo.net> - 0.1.3-1
+- update to 0.1.3
+
* Tue Apr 13 2021 Remi Collet <remi@remirepo.net> - 0.1.2-1
- update to 0.1.2
- drop patches merged upstream