summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-04 14:12:05 +0200
committerRemi Collet <remi@remirepo.net>2021-08-04 14:12:05 +0200
commit7b989def7355fcb8deaf16b7ba0dfff0851d4da1 (patch)
treeb3e0fc32de604f8e3124c535f79750b99fbf94d9
parentd21b6ebf9818d37bcbe436cfcfd3274795192f89 (diff)
update to 0.1.4
drop patch merge upstream
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-simple-kafka-client.spec10
-rw-r--r--simple_kafka_client-php81.patch59
4 files changed, 8 insertions, 67 deletions
diff --git a/PHPINFO b/PHPINFO
index 3e80534..3ab7a64 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
simple_kafka_client
kafka support => enabled
-version => 0.1.3
-build date => Jul 1 2021 00:00:00
+version => 0.1.4
+build date => Aug 4 2021 00:00:00
librdkafka version (runtime) => 1.7.0
librdkafka version (build) => 1.7.0.255
diff --git a/REFLECTION b/REFLECTION
index 2998faa..d0d7f2c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 simple_kafka_client version 0.1.3 ] {
+Extension [ <persistent> extension #122 simple_kafka_client version 0.1.4 ] {
- Constants [177] {
Constant [ int RD_KAFKA_OFFSET_BEGINNING ] { -2 }
diff --git a/php-pecl-simple-kafka-client.spec b/php-pecl-simple-kafka-client.spec
index fa44e3f..e964dac 100644
--- a/php-pecl-simple-kafka-client.spec
+++ b/php-pecl-simple-kafka-client.spec
@@ -20,14 +20,12 @@
Summary: Kafka client based on librdkafka
Name: %{?sub_prefix}php-pecl-simple-kafka-client
-Version: 0.1.3
+Version: 0.1.4
Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-php81.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: librdkafka1php-devel >= 1.7
@@ -79,8 +77,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr54
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SIMPLE_KAFKA_CLIENT_VERSION/{s/.* "//;s/".*$//;p}' php_simple_kafka_client_int.h)
if test "x${extver}" != "x%{version}"; then
@@ -201,6 +197,10 @@ cd ../ZTS
%changelog
+* Wed Aug 4 2021 Remi Collet <remi@remirepo.net> - 0.1.4-1
+- update to 0.1.4
+- drop patch merge upstream
+
* Wed Aug 4 2021 Remi Collet <remi@remirepo.net> - 0.1.3-2
- add patch for PHP 8.1.0beta2 from
https://github.com/php-kafka/php-simple-kafka-client/pull/54
diff --git a/simple_kafka_client-php81.patch b/simple_kafka_client-php81.patch
deleted file mode 100644
index 05197d4..0000000
--- a/simple_kafka_client-php81.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From c5c97dc6750057807db318a6e587a62e3c751c97 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 4 Aug 2021 11:41:50 +0200
-Subject: [PATCH] fix proto for 8.1.0beta2
-
----
- metadata_collection.c | 8 +++++++-
- metadata_collection.stub.php | 8 ++++----
- metadata_collection_arginfo.h | 7 ++++---
- 3 files changed, 15 insertions(+), 8 deletions(-)
-
-diff --git a/metadata_collection.c b/metadata_collection.c
-index 3af8357..c3b086a 100644
---- a/metadata_collection.c
-+++ b/metadata_collection.c
-@@ -39,9 +39,15 @@
- #include "php_simple_kafka_client_int.h"
- #include "ext/spl/spl_iterators.h"
- #include "Zend/zend_interfaces.h"
--#include "metadata_collection_arginfo.h"
- #include "Zend/zend_exceptions.h"
-
-+#if PHP_VERSION_ID < 80100
-+#define ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(name, return_reference, required_num_args, type, allow_null) \
-+ ZEND_BEGIN_ARG_INFO_EX(name, return_reference, required_num_args, allow_null)
-+#endif
-+
-+#include "metadata_collection_arginfo.h"
-+
- typedef struct _object_intern {
- zval zmetadata;
- const void *items;
-diff --git a/metadata_collection_arginfo.h b/metadata_collection_arginfo.h
-index ce1df7e..7da4de4 100644
---- a/metadata_collection_arginfo.h
-+++ b/metadata_collection_arginfo.h
-@@ -1,5 +1,5 @@
- /* This is a generated file, edit the .stub.php file instead.
-- * Stub hash: 925cbd1dcf14595ae437c111d3f99f767a665006 */
-+ * Stub hash: c130cfc464b41b677ecde96328b3417797b5176d */
-
- ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_class_SimpleKafkaClient_Metadata_Collection_count, 0, 0, IS_LONG, 0)
- ZEND_END_ARG_INFO()
-@@ -7,12 +7,13 @@ ZEND_END_ARG_INFO()
- ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_class_SimpleKafkaClient_Metadata_Collection_rewind, 0, 0, IS_VOID, 0)
- ZEND_END_ARG_INFO()
-
--ZEND_BEGIN_ARG_INFO_EX(arginfo_class_SimpleKafkaClient_Metadata_Collection_current, 0, 0, 0)
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_class_SimpleKafkaClient_Metadata_Collection_current, 0, 0, IS_MIXED, 0)
- ZEND_END_ARG_INFO()
-
- #define arginfo_class_SimpleKafkaClient_Metadata_Collection_key arginfo_class_SimpleKafkaClient_Metadata_Collection_count
-
--#define arginfo_class_SimpleKafkaClient_Metadata_Collection_next arginfo_class_SimpleKafkaClient_Metadata_Collection_current
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_class_SimpleKafkaClient_Metadata_Collection_next, 0, 0, IS_VOID, 0)
-+ZEND_END_ARG_INFO()
-
- ZEND_BEGIN_ARG_WITH_RETURN_TYPE_INFO_EX(arginfo_class_SimpleKafkaClient_Metadata_Collection_valid, 0, 0, _IS_BOOL, 0)
- ZEND_END_ARG_INFO()