summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-31 08:04:29 +0200
committerRemi Collet <remi@php.net>2022-08-31 08:04:29 +0200
commit4ea6011584db4372c42b76e0f7223d2d07e32285 (patch)
tree7091f53dabea61f0e6844375131edd68eaea91b2
initial package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO7
-rw-r--r--REFLECTION52
-rw-r--r--php-pecl-simdjson.spec214
5 files changed, 286 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..51ba89b
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,7 @@
+
+simdjson
+
+simdjson support => enabled
+Version => 2.0.3
+Support => https://github.com/crazyxman/simdjson_php
+Implementation => Intel/AMD AVX2
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..0adf8ed
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,52 @@
+Extension [ <persistent> extension #116 simdjson version 2.0.3 ] {
+
+ - Dependencies {
+ }
+
+ - Functions {
+ Function [ <internal:simdjson> function simdjson_is_valid ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $json ]
+ Parameter #1 [ <optional> int $depth = <default> ]
+ }
+ - Return [ ?bool ]
+ }
+ Function [ <internal:simdjson> function simdjson_decode ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $json ]
+ Parameter #1 [ <optional> bool $assoc = <default> ]
+ Parameter #2 [ <optional> int $depth = <default> ]
+ }
+ }
+ Function [ <internal:simdjson> function simdjson_key_value ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $json ]
+ Parameter #1 [ <required> string $key ]
+ Parameter #2 [ <optional> bool $assoc = <default> ]
+ Parameter #3 [ <optional> int $depth = <default> ]
+ }
+ }
+ Function [ <internal:simdjson> function simdjson_key_exists ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $json ]
+ Parameter #1 [ <required> string $key ]
+ Parameter #2 [ <optional> int $depth = <default> ]
+ }
+ - Return [ ?bool ]
+ }
+ Function [ <internal:simdjson> function simdjson_key_count ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $json ]
+ Parameter #1 [ <required> string $key ]
+ Parameter #2 [ <optional> int $depth = <default> ]
+ }
+ - Return [ ?int ]
+ }
+ }
+}
+
diff --git a/php-pecl-simdjson.spec b/php-pecl-simdjson.spec
new file mode 100644
index 0000000..c5165e2
--- /dev/null
+++ b/php-pecl-simdjson.spec
@@ -0,0 +1,214 @@
+# remirepo spec file for php-pecl-simdjson
+#
+# Copyright (c) 2022 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%scl_package php-pecl-simdjson
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name simdjson
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%if "%{php_version}" < "5.6"
+# after json
+%global ini_name %{pecl_name}.ini
+%else
+# after 40-json.ini
+%global ini_name 50-%{pecl_name}.ini
+%endif
+#global prever RC2
+
+Summary: Provides faster json decoding through simdjson bindings for PHP
+Name: %{?scl_prefix}php-pecl-jsonpath
+Version: 2.0.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+
+%if 0%{?rhel} == 7 && 0%{?dtsversion} < 7
+BuildRequires: devtoolset-7-toolchain
+%global dtsversion 7
+%global dtsenable source /opt/rh/devtoolset-7/enable
+%global dtsprefix devtoolset-7-
+%endif
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-json%{?_isa}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+
+%description
+Provides faster json decoding through simdjson bindings for PHP
+(Single Instruction, Multiple Data).
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%package devel
+Summary: %{name} developer files (header)
+Group: Development/Libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: %{?scl_prefix}php-devel%{?_isa}
+
+%description devel
+These are the files needed to compile programs using %{name}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version}%{?prever} NTS
+
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
+cd NTS
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_SIMDJSON_VERSION/{s/.* "//;s/".*$//;p}' php_simdjson.h)
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --enable-jsonpath \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --enable-jsonpath \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+# Tests
+for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} -n \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php -P -q --show-diff
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} -n \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%endif
+
+
+%files
+%doc %{pecl_docdir}/%{pecl_name}
+%{?_licensedir:%license NTS/LICENSE}
+
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+%files devel
+%doc %{pecl_testdir}/%{pecl_name}
+%{php_incldir}/ext/%{pecl_name}
+
+%if %{with_zts}
+%{php_ztsincldir}/ext/%{pecl_name}
+%endif
+
+
+%changelog
+* Wed Aug 31 2022 Remi Collet <remi@remirepo.net> - 2.0.3-1
+- initial package
+