summaryrefslogtreecommitdiffstats
path: root/php-pecl-selinux.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-24 17:07:36 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-24 17:07:36 +0100
commit535b20016742ec858994d98962f09dc17f9e2e0f (patch)
treec531feab1d4c1196350455abd015ab359dd5b3eb /php-pecl-selinux.spec
parenta16aa7981fa8d075fe173e65404be4414d16be2f (diff)
php-pecl-selinux: allow SCL build
Diffstat (limited to 'php-pecl-selinux.spec')
-rw-r--r--php-pecl-selinux.spec54
1 files changed, 34 insertions, 20 deletions
diff --git a/php-pecl-selinux.spec b/php-pecl-selinux.spec
index 6de7c0e..51e81c0 100644
--- a/php-pecl-selinux.spec
+++ b/php-pecl-selinux.spec
@@ -1,34 +1,45 @@
+# spec file for php-pecl-selinux
+#
+# Copyright (c) 2011-2014 Remi Collet
+# Copyright (c) 2009-2010 KaiGai Kohei
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-selinux}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%define pecl_name selinux
+%define pecl_name selinux
%global with_zts 0%{?__ztsphp:1}
-Summary: SELinux binding for PHP scripting language
-Name: php-pecl-selinux
-Version: 0.3.1
-Release: 13%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Summary: SELinux binding for PHP scripting language
+Name: %{?scl_prefix}php-pecl-selinux
+Version: 0.3.1
+Release: 14%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
-BuildRequires: php-devel >= 5.2.0
-BuildRequires: php-pear
-BuildRequires: libselinux-devel >= 2.0.80
+BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+BuildRequires: %{?scl_prefix}php-devel >= 5.2.0
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: libselinux-devel >= 2.0.80
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
-Requires: libselinux >= 2.0.80
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: libselinux >= 2.0.80
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
@@ -158,6 +169,9 @@ fi
%changelog
+* Mon Mar 24 2014 Remi Collet <remi@fedoraproject.org> - 0.3.1-14
+- allow SCL build
+
* Fri Mar 14 2014 Remi Collet <remi@fedoraproject.org> - 0.3.1-13
- fix syntax in provided configuration