summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-06 07:35:49 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-06 07:35:49 +0100
commitbfe1c55ce00b1dd991aec6cf57a1c81453781cb6 (patch)
treebf0b0ad65b02074a6edd01d0656e37e79feb57bc
parentf2e776b2a701b7fde2cb4d61b851cc7174d4500f (diff)
php-pecl-selinux: F24
-rw-r--r--php-pecl-selinux.spec19
1 files changed, 12 insertions, 7 deletions
diff --git a/php-pecl-selinux.spec b/php-pecl-selinux.spec
index b7a531f..0f27078 100644
--- a/php-pecl-selinux.spec
+++ b/php-pecl-selinux.spec
@@ -21,9 +21,6 @@
%endif
%{?scl: %scl_package php-pecl-selinux}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%define pecl_name selinux
%global with_zts 0%{?__ztsphp:1}
@@ -37,7 +34,7 @@
Summary: SELinux binding for PHP scripting language
Name: %{?sub_prefix}php-pecl-selinux
Version: 0.4.1
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -53,10 +50,12 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: libselinux >= 2.0.80
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -102,6 +101,7 @@ mv %{pecl_name}-%{version} NTS
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
pushd NTS
@@ -196,6 +196,7 @@ cd ../ZTS
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -212,6 +213,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%files
@@ -230,6 +232,9 @@ fi
%changelog
+* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 0.4.1-7
+- adapt for F24
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 0.4.1-6
- rebuild for PHP 7.0.0RC5 new API version