summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION86
-rw-r--r--php-pecl-seaslog.spec10
2 files changed, 92 insertions, 4 deletions
diff --git a/REFLECTION b/REFLECTION
index e0ee584..96bd92f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #155 SeasLog version 1.6.8 ] {
+Extension [ <persistent> extension #171 SeasLog version 1.6.9 ] {
- Dependencies {
}
@@ -46,7 +46,7 @@ Extension [ <persistent> extension #155 SeasLog version 1.6.8 ] {
}
- Constants [16] {
- Constant [ string SEASLOG_VERSION ] { 1.6.8 }
+ Constant [ string SEASLOG_VERSION ] { 1.6.9 }
Constant [ string SEASLOG_AUTHOR ] { Chitao.Gao [ neeke@php.net ] }
Constant [ string SEASLOG_ALL ] { all }
Constant [ string SEASLOG_DEBUG ] { debug }
@@ -82,27 +82,54 @@ Extension [ <persistent> extension #155 SeasLog version 1.6.8 ] {
- Static methods [19] {
Method [ <internal:SeasLog> static public method setBasePath ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $base_path ]
+ }
}
Method [ <internal:SeasLog> static public method getBasePath ] {
}
Method [ <internal:SeasLog> static public method setLogger ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method getLastLogger ] {
}
Method [ <internal:SeasLog> static public method setDatetimeFormat ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $format ]
+ }
}
Method [ <internal:SeasLog> static public method getDatetimeFormat ] {
}
Method [ <internal:SeasLog> static public method analyzerCount ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $level ]
+ Parameter #1 [ <optional> $log_path ]
+ Parameter #2 [ <optional> $key_word ]
+ }
}
Method [ <internal:SeasLog> static public method analyzerDetail ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $level ]
+ Parameter #1 [ <optional> $log_path ]
+ Parameter #2 [ <optional> $key_word ]
+ Parameter #3 [ <optional> $start ]
+ Parameter #4 [ <optional> $limit ]
+ Parameter #5 [ <optional> $order ]
+ }
}
Method [ <internal:SeasLog> static public method getBuffer ] {
@@ -112,30 +139,85 @@ Extension [ <persistent> extension #155 SeasLog version 1.6.8 ] {
}
Method [ <internal:SeasLog> static public method log ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $level ]
+ Parameter #1 [ <optional> $message ]
+ Parameter #2 [ <optional> $content ]
+ Parameter #3 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method debug ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method info ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method notice ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method warning ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method error ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method critical ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method alert ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
Method [ <internal:SeasLog> static public method emergency ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <optional> $content ]
+ Parameter #2 [ <optional> $logger ]
+ }
}
}
diff --git a/php-pecl-seaslog.spec b/php-pecl-seaslog.spec
index 83e8c90..43018a3 100644
--- a/php-pecl-seaslog.spec
+++ b/php-pecl-seaslog.spec
@@ -25,8 +25,8 @@
Summary: A effective,fast,stable log extension for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.6.8
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.6.9
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
Group: Development/Languages
URL: http://pecl.php.net/package/%{proj_name}
@@ -139,6 +139,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -158,6 +160,7 @@ make %{?_smp_mflags}
%install
rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -237,6 +240,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jan 23 2017 Remi Collet <remi@fedoraproject.org> - 1.6.9-1
+- Update to 1.6.9
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.6.8-2
- rebuild with PHP 7.1.0 GA