summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION41
-rw-r--r--php-pecl-seaslog.spec30
3 files changed, 52 insertions, 21 deletions
diff --git a/PHPINFO b/PHPINFO
index 0f106bf..81542ae 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
SeasLog
SeasLog support => Enabled
-SeasLog Version => 2.1.0
+SeasLog Version => 2.2.0
SeasLog Author => Chitao.Gao [ neeke@php.net ]
SeasLog Supports => https://github.com/SeasX/SeasLog
diff --git a/REFLECTION b/REFLECTION
index f7e2ac1..6e2012a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
+Extension [ <persistent> extension #119 SeasLog version 2.2.0 ] {
- Dependencies {
}
@@ -100,7 +100,7 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
}
- Constants [22] {
- Constant [ string SEASLOG_VERSION ] { 2.1.0 }
+ Constant [ string SEASLOG_VERSION ] { 2.2.0 }
Constant [ string SEASLOG_AUTHOR ] { Chitao.Gao [ neeke@php.net ] }
Constant [ string SEASLOG_ALL ] { ALL }
Constant [ string SEASLOG_DEBUG ] { DEBUG }
@@ -126,8 +126,14 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
- Functions {
Function [ <internal:SeasLog> function seaslog_get_version ] {
+
+ - Parameters [0] {
+ }
}
Function [ <internal:SeasLog> function seaslog_get_author ] {
+
+ - Parameters [0] {
+ }
}
}
@@ -149,6 +155,9 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
}
Method [ <internal:SeasLog> static public method getBasePath ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog> static public method setLogger ] {
@@ -161,12 +170,15 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
Method [ <internal:SeasLog> static public method closeLoggerStream ] {
- Parameters [2] {
- Parameter #0 [ <required> $model ]
+ Parameter #0 [ <optional> $model ]
Parameter #1 [ <optional> $logger ]
}
}
Method [ <internal:SeasLog> static public method getLastLogger ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog> static public method setRequestID ] {
@@ -177,6 +189,9 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
}
Method [ <internal:SeasLog> static public method getRequestID ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog> static public method setDatetimeFormat ] {
@@ -187,6 +202,9 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
}
Method [ <internal:SeasLog> static public method getDatetimeFormat ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog> static public method setRequestVariable ] {
@@ -207,7 +225,7 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
Method [ <internal:SeasLog> static public method analyzerCount ] {
- Parameters [3] {
- Parameter #0 [ <required> $level ]
+ Parameter #0 [ <optional> $level ]
Parameter #1 [ <optional> $log_path ]
Parameter #2 [ <optional> $key_word ]
}
@@ -226,12 +244,21 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
}
Method [ <internal:SeasLog> static public method getBuffer ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog> static public method getBufferCount ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog> static public method getBufferEnabled ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog> static public method flushBuffer ] {
@@ -329,9 +356,15 @@ Extension [ <persistent> extension #108 SeasLog version 2.1.0 ] {
- Methods [2] {
Method [ <internal:SeasLog, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:SeasLog, dtor> public method __destruct ] {
+
+ - Parameters [0] {
+ }
}
}
}
diff --git a/php-pecl-seaslog.spec b/php-pecl-seaslog.spec
index 3435d78..78a1b41 100644
--- a/php-pecl-seaslog.spec
+++ b/php-pecl-seaslog.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-seaslog
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -25,12 +25,13 @@
Summary: An effective, fast, stable log extension for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.1.0
+Version: 2.2.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/%{proj_name}
Source0: https://pecl.php.net/get/%{proj_name}-%{version}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -50,26 +51,17 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -100,7 +92,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-sed -e 's/ifndef ulong/if 0/' -i include/php7_wrapper.h
+#sed -e 's/ifndef ulong/if 0/' -i include/php7_wrapper.h
: Sanity check, really often broken
extver=$(sed -n '/#define SEASLOG_VERSION /{s/.* "//;s/".*$//;p}' include/SeasLog.h)
@@ -124,7 +116,7 @@ extension=%{pecl_name}.so
;seaslog.default_basepath = '/var/log/www'
;seaslog.default_logger = 'default'
;seaslog.default_datetime_format = 'Y-m-d H:i:s'
-;seaslog.default_template = '%T | %L | %P | %Q | %t | %M'
+;seaslog.default_template = '%%T | %%L | %%P | %%Q | %%t | %%M'
;seaslog.disting_folder = 1
;seaslog.disting_type = 0
;seaslog.disting_by_hour = 0
@@ -253,6 +245,12 @@ fi
%changelog
+* Tue Jan 19 2021 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+
+* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 2.1.0-2
+- F33 build
+
* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0
- open https://github.com/SeasX/SeasLog/issues/286