summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-19 08:16:50 +0200
committerRemi Collet <remi@remirepo.net>2017-09-19 08:16:50 +0200
commit8070c3b6d9828e48cd3419cd3bc4e7ab8bc3e26f (patch)
treea486ff85bd516305c8fb29da41b7836f541589eb
parent46982e05dbc660f36ce9b154727e73bbba21d1be (diff)
1.7.5 (skipped as broken)
-rw-r--r--REFLECTION50
-rw-r--r--php-pecl-seaslog.spec31
2 files changed, 55 insertions, 26 deletions
diff --git a/REFLECTION b/REFLECTION
index 96bd92f..9d0e3b1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #171 SeasLog version 1.6.9 ] {
+Extension [ <persistent> extension #15 SeasLog version 1.7.5 ] {
- Dependencies {
}
@@ -11,7 +11,10 @@ Extension [ <persistent> extension #171 SeasLog version 1.6.9 ] {
Current = 'default'
}
Entry [ seaslog.default_datetime_format <ALL> ]
- Current = 'Y:m:d H:i:s'
+ Current = 'Y-m-d H:i:s'
+ }
+ Entry [ seaslog.default_template <ALL> ]
+ Current = '%T | %L | %P | %Q | %t | %M'
}
Entry [ seaslog.disting_type <ALL> ]
Current = '0'
@@ -32,7 +35,7 @@ Extension [ <persistent> extension #171 SeasLog version 1.6.9 ] {
Current = '0'
}
Entry [ seaslog.level <ALL> ]
- Current = '0'
+ Current = '8'
}
Entry [ seaslog.appender <ALL> ]
Current = '1'
@@ -43,20 +46,29 @@ Extension [ <persistent> extension #171 SeasLog version 1.6.9 ] {
Entry [ seaslog.remote_port <ALL> ]
Current = '514'
}
+ Entry [ seaslog.trim_wrap <ALL> ]
+ Current = '0'
+ }
+ Entry [ seaslog.throw_exception <ALL> ]
+ Current = '1'
+ }
+ Entry [ seaslog.ignore_warning <ALL> ]
+ Current = '1'
+ }
}
- Constants [16] {
- Constant [ string SEASLOG_VERSION ] { 1.6.9 }
+ Constant [ string SEASLOG_VERSION ] { 1.7.5 }
Constant [ string SEASLOG_AUTHOR ] { Chitao.Gao [ neeke@php.net ] }
- Constant [ string SEASLOG_ALL ] { all }
- Constant [ string SEASLOG_DEBUG ] { debug }
- Constant [ string SEASLOG_INFO ] { info }
- Constant [ string SEASLOG_NOTICE ] { notice }
- Constant [ string SEASLOG_WARNING ] { warning }
- Constant [ string SEASLOG_ERROR ] { error }
- Constant [ string SEASLOG_CRITICAL ] { critical }
- Constant [ string SEASLOG_ALERT ] { alert }
- Constant [ string SEASLOG_EMERGENCY ] { emergency }
+ Constant [ string SEASLOG_ALL ] { ALL }
+ Constant [ string SEASLOG_DEBUG ] { DEBUG }
+ Constant [ string SEASLOG_INFO ] { INFO }
+ Constant [ string SEASLOG_NOTICE ] { NOTICE }
+ Constant [ string SEASLOG_WARNING ] { WARNING }
+ Constant [ string SEASLOG_ERROR ] { ERROR }
+ Constant [ string SEASLOG_CRITICAL ] { CRITICAL }
+ Constant [ string SEASLOG_ALERT ] { ALERT }
+ Constant [ string SEASLOG_EMERGENCY ] { EMERGENCY }
Constant [ integer SEASLOG_DETAIL_ORDER_ASC ] { 1 }
Constant [ integer SEASLOG_DETAIL_ORDER_DESC ] { 2 }
Constant [ integer SEASLOG_APPENDER_FILE ] { 1 }
@@ -80,7 +92,7 @@ Extension [ <persistent> extension #171 SeasLog version 1.6.9 ] {
- Static properties [0] {
}
- - Static methods [19] {
+ - Static methods [21] {
Method [ <internal:SeasLog> static public method setBasePath ] {
- Parameters [1] {
@@ -101,6 +113,16 @@ Extension [ <persistent> extension #171 SeasLog version 1.6.9 ] {
Method [ <internal:SeasLog> static public method getLastLogger ] {
}
+ Method [ <internal:SeasLog> static public method setRequestID ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $request_id ]
+ }
+ }
+
+ Method [ <internal:SeasLog> static public method getRequestID ] {
+ }
+
Method [ <internal:SeasLog> static public method setDatetimeFormat ] {
- Parameters [1] {
diff --git a/php-pecl-seaslog.spec b/php-pecl-seaslog.spec
index 6534b2e..1b990fb 100644
--- a/php-pecl-seaslog.spec
+++ b/php-pecl-seaslog.spec
@@ -25,14 +25,13 @@
Summary: A effective,fast,stable log extension for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.6.9
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: ASL 2.0
+Version: 1.7.5
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{proj_name}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -92,6 +91,11 @@ A effective,fast,stable log extension for PHP.
- Analysis of early warning framework preliminary
- Buffer debug efficient log buffer, convenient
- With PSR-3 Logger interface
+- Error and exception automatic logging
+- Support appender with File,TCP,UDP
+- Send to Rsyslog(TCP/UDP) with RFC5424
+- Support RequestId differentiated requests
+- Support for log template customizations
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -108,7 +112,7 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
: Sanity check, really often broken
-extver=$(sed -n '/#define SEASLOG_VERSION/{s/.* "//;s/".*$//;p}' php_seaslog.h)
+extver=$(sed -n '/#define SEASLOG_VERSION /{s/.* "//;s/".*$//;p}' include/SeasLog.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}.
exit 1
@@ -127,7 +131,8 @@ extension=%{pecl_name}.so
; Configuration
;seaslog.default_basepath = '/var/log/www'
-;seaslog.default_datetime_format = 'Y:m:d H:i:s '
+;seaslog.default_datetime_format = 'Y-m-d H:i:s'
+;seaslog.default_template = '%T | %L | %P | %Q | %t | %M'
;seaslog.logger = 'default'
;seaslog.disting_type = 0
;seaslog.disting_by_hour = 0
@@ -139,6 +144,9 @@ extension=%{pecl_name}.so
;seaslog.appender = 1
;seaslog.remote_host = '127.0.0.1'
;seaslog.remote_port = 514
+;seaslog.trim_wrap = 0
+;seaslog.throw_exception = 1
+;seaslog.ignore_warning = 1
EOF
@@ -163,7 +171,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -224,12 +231,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{?_licensedir:%license NTS/LICENSE}
@@ -244,6 +246,11 @@ rm -rf %{buildroot}
%changelog
+* Tue Sep 19 2017 Remi Collet <remi@remirepo.net> - 1.7.5-1
+- Update to 1.7.5
+- Update license from Apache License 2.0 to PHP License 3.01
+- open https://github.com/Neeke/SeasLog/issues/152 segfault
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 1.6.9-2
- rebuild for PHP 7.2.0beta1 new API