summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-19 13:16:35 +0200
committerRemi Collet <remi@remirepo.net>2017-09-19 13:16:35 +0200
commit149060296dd0fa4fa2b1ea330eb10d2cdab29768 (patch)
tree2c64bf5226a6294b7a275189088f0b2d5c3c9877
parent824933da5fe84784984fb9e2b9bdf39f9c18a3d5 (diff)
v1.7.6
-rw-r--r--22786c74700c1f0da7747ccea128e6400f0ce289.patch46
-rw-r--r--802d36c6f158e04eace2a816e38f05b8471b4f64.patch38
-rw-r--r--REFLECTION4
-rw-r--r--a782883c301e1f778f0f6c7b4891b66e283ae3bb.patch31
-rw-r--r--php-pecl-seaslog.spec12
5 files changed, 6 insertions, 125 deletions
diff --git a/22786c74700c1f0da7747ccea128e6400f0ce289.patch b/22786c74700c1f0da7747ccea128e6400f0ce289.patch
deleted file mode 100644
index 6043250..0000000
--- a/22786c74700c1f0da7747ccea128e6400f0ce289.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 22786c74700c1f0da7747ccea128e6400f0ce289 Mon Sep 17 00:00:00 2001
-From: neeke <neeke@php.net>
-Date: Tue, 19 Sep 2017 14:27:06 +0800
-Subject: [PATCH] Fixed #152 (Segfault in cli)
-
----
- src/Request.c | 23 +++++++++++++++++------
- 1 file changed, 17 insertions(+), 6 deletions(-)
-
-diff --git a/src/Request.c b/src/Request.c
-index 57f14f0..1817219 100644
---- a/src/Request.c
-+++ b/src/Request.c
-@@ -180,15 +180,26 @@ static int seaslog_init_request_variable(TSRMLS_D)
-
- static void seaslog_clear_request_variable(TSRMLS_D)
- {
-- SEASLOG_ZVAL_PTR_DTOR(SEASLOG_G(request_variable)->request_uri);
--
-- if( SEASLOG_G(request_variable)->request_method )
-+ if(SEASLOG_G(request_variable)->request_uri)
-+ {
-+ SEASLOG_ZVAL_PTR_DTOR(SEASLOG_G(request_variable)->request_uri);
-+ }
-+
-+ if(SEASLOG_G(request_variable)->request_method)
- {
- SEASLOG_ZVAL_PTR_DTOR(SEASLOG_G(request_variable)->request_method);
- }
--
-- efree(SEASLOG_G(request_variable)->domain_port);
-- efree(SEASLOG_G(request_variable)->client_ip);
-+
-+ if(SEASLOG_G(request_variable)->domain_port)
-+ {
-+ efree(SEASLOG_G(request_variable)->domain_port);
-+ }
-+
-+ if(SEASLOG_G(request_variable)->client_ip)
-+ {
-+ efree(SEASLOG_G(request_variable)->client_ip);
-+ }
-+
- efree(SEASLOG_G(request_variable));
- }
-
diff --git a/802d36c6f158e04eace2a816e38f05b8471b4f64.patch b/802d36c6f158e04eace2a816e38f05b8471b4f64.patch
deleted file mode 100644
index 50d2285..0000000
--- a/802d36c6f158e04eace2a816e38f05b8471b4f64.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 79fb94b4cbca994f0f24fb13dbc4796253d21db0 Mon Sep 17 00:00:00 2001
-From: xbruce <xbruce@xbrucedeMacBook-Pro.local>
-Date: Tue, 19 Sep 2017 11:29:03 +0800
-Subject: [PATCH] =?UTF-8?q?=E4=BF=AE=E5=A4=8Dphp7.1=E7=89=88=E6=9C=ACcli?=
- =?UTF-8?q?=E4=B8=8B=E8=BF=90=E8=A1=8C=E4=B8=8D=E6=AD=A3=E5=B8=B8=E7=9A=84?=
- =?UTF-8?q?bug!=20=E5=8E=9F=E5=9B=A0=EF=BC=9A=E8=B6=85=E5=85=A8=E5=B1=80?=
- =?UTF-8?q?=E5=8F=98=E9=87=8F$=5FSERVER=E4=B8=AD=E4=B8=8D=E5=AD=98?=
- =?UTF-8?q?=E5=9C=A8SUDO=5FCOMMAND=E5=AF=BC=E8=87=B4SEASLOG=5FG(request=5F?=
- =?UTF-8?q?variable)->request=5Fmethod=E4=B8=BA=E7=A9=BA=E8=BF=9B=E8=80=8C?=
- =?UTF-8?q?=E5=AF=BC=E8=87=B4seaslog=5Fclear=5Frequest=5Fvariable=E5=87=BD?=
- =?UTF-8?q?=E6=95=B0=E4=B8=ADSEASLOG=5FZVAL=5FPTR=5FDTOR(SEASLOG=5FG(reque?=
- =?UTF-8?q?st=5Fvariable)->request=5Fmethod);=E5=A4=B1=E8=B4=A5?=
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
----
- src/Request.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/src/Request.c b/src/Request.c
-index cc53db1..755ba2c 100644
---- a/src/Request.c
-+++ b/src/Request.c
-@@ -193,7 +193,12 @@ static int seaslog_init_request_variable(TSRMLS_D)
- static void seaslog_clear_request_variable(TSRMLS_D)
- {
- SEASLOG_ZVAL_PTR_DTOR(SEASLOG_G(request_variable)->request_uri);
-- SEASLOG_ZVAL_PTR_DTOR(SEASLOG_G(request_variable)->request_method);
-+
-+ if( SEASLOG_G(request_variable)->request_method )
-+ {
-+ SEASLOG_ZVAL_PTR_DTOR(SEASLOG_G(request_variable)->request_method);
-+ }
-+
- efree(SEASLOG_G(request_variable)->domain_port);
- efree(SEASLOG_G(request_variable)->client_ip);
- efree(SEASLOG_G(request_variable));
diff --git a/REFLECTION b/REFLECTION
index 9d0e3b1..181ff8c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #15 SeasLog version 1.7.5 ] {
+Extension [ <persistent> extension #184 SeasLog version 1.7.6 ] {
- Dependencies {
}
@@ -58,7 +58,7 @@ Extension [ <persistent> extension #15 SeasLog version 1.7.5 ] {
}
- Constants [16] {
- Constant [ string SEASLOG_VERSION ] { 1.7.5 }
+ Constant [ string SEASLOG_VERSION ] { 1.7.6 }
Constant [ string SEASLOG_AUTHOR ] { Chitao.Gao [ neeke@php.net ] }
Constant [ string SEASLOG_ALL ] { ALL }
Constant [ string SEASLOG_DEBUG ] { DEBUG }
diff --git a/a782883c301e1f778f0f6c7b4891b66e283ae3bb.patch b/a782883c301e1f778f0f6c7b4891b66e283ae3bb.patch
deleted file mode 100644
index 9253355..0000000
--- a/a782883c301e1f778f0f6c7b4891b66e283ae3bb.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From a782883c301e1f778f0f6c7b4891b66e283ae3bb Mon Sep 17 00:00:00 2001
-From: neeke <neeke@php.net>
-Date: Tue, 19 Sep 2017 14:24:12 +0800
-Subject: [PATCH] update to #152
-
----
- src/Request.c | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/src/Request.c b/src/Request.c
-index 91eafa4..d34eb5d 100644
---- a/src/Request.c
-+++ b/src/Request.c
-@@ -136,8 +136,7 @@ static int seaslog_init_request_variable(TSRMLS_D)
- if (!strncmp(sapi_module.name, "cli", sizeof("cli") - 1))
- {
- SEASLOG_G(request_variable)->request_uri = seaslog_request_query(SEASLOG_GLOBAL_VARS_SERVER, ZEND_STRL("SCRIPT_NAME") TSRMLS_CC);
--
-- SEASLOG_G(request_variable)->request_method = seaslog_request_query(SEASLOG_GLOBAL_VARS_SERVER, ZEND_STRL("SUDO_COMMAND") TSRMLS_CC);
-+ SEASLOG_G(request_variable)->request_method = seaslog_request_query(SEASLOG_GLOBAL_VARS_SERVER, ZEND_STRL("SHELL") TSRMLS_CC);
-
- SEASLOG_G(request_variable)->domain_port_len = spprintf(&SEASLOG_G(request_variable)->domain_port, 0, "cli");
- SEASLOG_G(request_variable)->client_ip_len = spprintf(&SEASLOG_G(request_variable)->client_ip, 0, "local");
-@@ -149,7 +148,6 @@ static int seaslog_init_request_variable(TSRMLS_D)
- SEASLOG_ZVAL_PTR_DTOR(domain);
-
- SEASLOG_G(request_variable)->request_uri = seaslog_request_query(SEASLOG_GLOBAL_VARS_SERVER, ZEND_STRL("REQUEST_URI") TSRMLS_CC);
--
- SEASLOG_G(request_variable)->request_method = seaslog_request_query(SEASLOG_GLOBAL_VARS_SERVER, ZEND_STRL("REQUEST_METHOD") TSRMLS_CC);
-
- client_ip = seaslog_request_query(SEASLOG_GLOBAL_VARS_SERVER, ZEND_STRL("HTTP_X_REAL_IP") TSRMLS_CC);
diff --git a/php-pecl-seaslog.spec b/php-pecl-seaslog.spec
index 915765a..56a3278 100644
--- a/php-pecl-seaslog.spec
+++ b/php-pecl-seaslog.spec
@@ -25,17 +25,13 @@
Summary: A effective,fast,stable log extension for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.7.5
+Version: 1.7.6
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{proj_name}
Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
-Patch1: 802d36c6f158e04eace2a816e38f05b8471b4f64.patch
-Patch2: a782883c301e1f778f0f6c7b4891b66e283ae3bb.patch
-Patch3: 22786c74700c1f0da7747ccea128e6400f0ce289.patch
-
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -114,9 +110,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch1 -p1 -b .up1
-%patch2 -p1 -b .up2
-%patch3 -p1 -b .up3
: Sanity check, really often broken
extver=$(sed -n '/#define SEASLOG_VERSION /{s/.* "//;s/".*$//;p}' include/SeasLog.h)
@@ -253,6 +246,9 @@ fi
%changelog
+* Tue Sep 19 2017 Remi Collet <remi@remirepo.net> - 1.7.6-1
+- Update to 1.7.6
+
* Tue Sep 19 2017 Remi Collet <remi@remirepo.net> - 1.7.5-1
- Update to 1.7.5
- Update license from Apache License 2.0 to PHP License 3.01