summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION68
-rw-r--r--php-pecl-seasclick.spec223
5 files changed, 309 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..8ae2264
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+SeasClick
+
+SeasClick support => enabled
+Version => 0.1.0
+Author => SeasX Group[email: ahhhh.wang@gmail.com]
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..4c1140a
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,68 @@
+Extension [ <persistent> extension #15 SeasClick version 0.1.0 ] {
+
+ - Functions {
+ Function [ <internal:SeasClick> function SeasClick_version ] {
+ }
+ }
+
+ - Classes [1] {
+ Class [ <internal:SeasClick> class SeasClick ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [6] {
+ Property [ <default> protected $host ]
+ Property [ <default> protected $port ]
+ Property [ <default> protected $database ]
+ Property [ <default> protected $user ]
+ Property [ <default> protected $passwd ]
+ Property [ <default> protected $compression ]
+ }
+
+ - Methods [5] {
+ Method [ <internal:SeasClick, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $connectParames ]
+ }
+ }
+
+ Method [ <internal:SeasClick, dtor> public method __destruct ] {
+ }
+
+ Method [ <internal:SeasClick> public method select ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $sql ]
+ Parameter #1 [ <required> $params ]
+ }
+ }
+
+ Method [ <internal:SeasClick> public method insert ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $table ]
+ Parameter #1 [ <required> $columns ]
+ Parameter #2 [ <required> $values ]
+ }
+ }
+
+ Method [ <internal:SeasClick> public method execute ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $sql ]
+ Parameter #1 [ <required> $params ]
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-seasclick.spec b/php-pecl-seasclick.spec
new file mode 100644
index 0000000..b37acd3
--- /dev/null
+++ b/php-pecl-seasclick.spec
@@ -0,0 +1,223 @@
+# remirepo spec file for php-pecl-seasclick
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-seasclick
+%else
+%global _root_libdir %{_libdir}
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global proj_name SeasClick
+%global pecl_name %{proj_name}
+%global lowername seasclick
+# tests require a server
+%global with_tests 0%{?_with_tests:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: An Yandex ClickHouse client driven extension for PHP
+Name: %{?sub_prefix}php-pecl-%{lowername}
+Version: 0.1.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: ASL 2.0
+URL: http://pecl.php.net/package/%{proj_name}
+Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
+
+%if 0%{?rhel} == 6
+BuildRequires: devtoolset-6-toolchain
+%else
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc-c++
+%endif
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-json%{?_isa}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{lowername} = %{version}
+Provides: %{?scl_prefix}php-%{lowername}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.3"
+Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+PHP client for Yandex ClickHouse,Based on ClickHouse C++ client.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{proj_name}-%{version} NTS
+cp NTS/lib/clickhouse-cpp/LICENSE NTS/LICENSE.clickhouse-cpp
+
+# Don't install tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+
+: Sanity check, really often broken
+extver=$(sed -n '/#define PHP_SEASCLICK_VERSION /{s/.* "//;s/".*$//;p}' php_SeasClick.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%if 0%{?rhel} == 6
+source /opt/rh/devtoolset-6/enable
+%endif
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --enable-SeasClick \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --enable-SeasClick \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%if 0%{?rhel} == 6
+source /opt/rh/devtoolset-6/enable
+%endif
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=json.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep -i %{pecl_name}
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=json.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep -i %{pecl_name}
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{proj_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%doc %{pecl_docdir}/%{pecl_name}
+%{?_licensedir:%license NTS/LICENSE*}
+
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Thu Mar 28 2019 Remi Collet <remi@remirepo.net> - 0.1.0-1
+- initial package, version 0.1.0