summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION31
-rw-r--r--php-pecl-sdl.spec32
2 files changed, 47 insertions, 16 deletions
diff --git a/REFLECTION b/REFLECTION
index 023f727..da7104a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
+Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Constants [738] {
Constant [ int SDL_BLENDMODE_NONE ] { 0 }
@@ -716,11 +716,11 @@ Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
Constant [ int SDL_PREALLOC ] { 1 }
Constant [ int SDL_RLEACCEL ] { 2 }
Constant [ int SDL_DONTFREE ] { 4 }
- Constant [ int SDL_COMPILEDVERSION ] { 2009 }
+ Constant [ int SDL_COMPILEDVERSION ] { 2012 }
Constant [ int SDL_MAJOR_VERSION ] { 2 }
Constant [ int SDL_MINOR_VERSION ] { 0 }
- Constant [ int SDL_PATCHLEVEL ] { 9 }
- Constant [ string SDL_REVISION ] { hg-12373:8feb5da6f2fb }
+ Constant [ int SDL_PATCHLEVEL ] { 12 }
+ Constant [ string SDL_REVISION ] { hg-13609:34cc7d3b69d3 }
Constant [ int SDL_WINDOW_FULLSCREEN ] { 1 }
Constant [ int SDL_WINDOW_OPENGL ] { 2 }
Constant [ int SDL_WINDOW_SHOWN ] { 4 }
@@ -1215,6 +1215,16 @@ Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
Parameter #4 [ <required> $h ]
}
}
+ Function [ <internal:SDL> function SDL_QueryTexture ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $texture ]
+ Parameter #1 [ <required> &$format ]
+ Parameter #2 [ <required> &$access ]
+ Parameter #3 [ <required> &$w ]
+ Parameter #4 [ <required> &$h ]
+ }
+ }
Function [ <internal:SDL> function SDL_SetRenderTarget ] {
- Parameters [2] {
@@ -3118,6 +3128,7 @@ Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
}
- Properties [16] {
+ Property [ <default> public $format ]
Property [ <default> public $BitsPerPixel ]
Property [ <default> public $BytesPerPixel ]
Property [ <default> public $Rmask ]
@@ -3133,7 +3144,6 @@ Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
Property [ <default> public $Bshift ]
Property [ <default> public $Ashift ]
Property [ <default> public $palette ]
- Property [ <default> public $format ]
}
- Methods [8] {
@@ -3216,11 +3226,10 @@ Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [3] {
Property [ <default> public $pitch ]
Property [ <default> public $h ]
Property [ <default> public $count ]
- Property [ <default> public $pixels ]
}
- Methods [9] {
@@ -3303,12 +3312,11 @@ Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
- Static methods [0] {
}
- - Properties [5] {
+ - Properties [4] {
Property [ <default> public $x ]
Property [ <default> public $y ]
Property [ <default> public $w ]
Property [ <default> public $h ]
- Property [ <default> public $clip_rect ]
}
- Methods [8] {
@@ -3684,11 +3692,14 @@ Extension [ <persistent> extension #71 SDL version 2.3.0 ] {
}
}
- - Properties [4] {
+ - Properties [7] {
Property [ <default> public $flags ]
Property [ <default> public $w ]
Property [ <default> public $h ]
Property [ <default> public $pitch ]
+ Property [ <default> public $format ]
+ Property [ <default> public $clip_rect ]
+ Property [ <default> public $pixels ]
}
- Methods [30] {
diff --git a/php-pecl-sdl.spec b/php-pecl-sdl.spec
index 2a9eadc..de47a33 100644
--- a/php-pecl-sdl.spec
+++ b/php-pecl-sdl.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-sdl
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -14,14 +14,14 @@
Summary: Simple DirectMedia Layer for PHP
Name: %{?scl_prefix}php-pecl-sdl
-Version: 2.3.0
+Version: 2.4.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
-URL: http://pecl.php.net/package/sdl
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: https://pecl.php.net/package/sdl
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRequires: %{?scl_prefix}php-devel >= 7.3
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: SDL2-devel
@@ -40,7 +40,7 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
@@ -76,6 +76,17 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%setup -q -c
mv %{pecl_name}-%{version} NTS
+cd NTS
+sed -e 's/2.3.0/%{version}/' -i src/php_sdl.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_SDL_VERSION/{s/.* "//;s/".*$//;p}' src/php_sdl.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
@@ -188,6 +199,15 @@ fi
%changelog
+* Mon Aug 24 2020 Remi Collet <remi@remirepo.net> - 2.4.0-1
+- update to 2.4.0
+- drop patch merged upstream
+- raise dependency on PHP 7.4
+
+* Wed Feb 26 2020 Remi Collet <remi@remirepo.net> - 2.3.0-2
+- add patch for duplicated symbols on GCC 10 from
+ https://github.com/Ponup/php-sdl/pull/39
+
* Sun Sep 8 2019 Remi Collet <remi@remirepo.net> - 2.3.0-1
- update to 2.3.0