summaryrefslogtreecommitdiffstats
path: root/php-pecl-sdl.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-14 13:57:09 +0100
committerRemi Collet <remi@php.net>2022-03-14 13:57:09 +0100
commit5e0c02cc49dd4cc69e977352796edbcc5493a1c5 (patch)
tree4ebfe86b27f45ef7b00ad07288928776f17ed934 /php-pecl-sdl.spec
parentcb1865e48a06ebf3c66d3b8876fd0fe6b0fd3fb6 (diff)
handle all SDL extensions in launcher (for sdl_mixer)
Diffstat (limited to 'php-pecl-sdl.spec')
-rw-r--r--php-pecl-sdl.spec19
1 files changed, 15 insertions, 4 deletions
diff --git a/php-pecl-sdl.spec b/php-pecl-sdl.spec
index fb1137e..c648495 100644
--- a/php-pecl-sdl.spec
+++ b/php-pecl-sdl.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-sdl
#
-# Copyright (c) 2013-2021 Remi Collet
+# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -15,7 +15,7 @@
Summary: Simple DirectMedia Layer for PHP
Name: %{?scl_prefix}php-pecl-sdl
Version: 2.5.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/sdl
@@ -85,13 +85,21 @@ sed -e 's/role="test"/role="src"/' \
cat << 'EOF' | tee phpsdl
#!/bin/sh
-exec %{__php} -d extension=%{pecl_name}.so "$@"
+mod=""
+for i in $(cd %{php_extdir}; LANG=C ls sdl*.so); do
+ mod="$mod -d extension=${i/.so/}"
+done
+exec %{__php} $mod "$@"
EOF
%if %{with_zts}
cat << 'EOF' | tee zts-phpsdl
#!/bin/sh
-exec %{__ztsphp} -d extension=%{pecl_name}.so "$@"
+mod=""
+for i in $(cd %{php_ztsextdir}; LANG=C ls sdl*.so); do
+ mod="$mod -d extension=${i/.so/}"
+done
+exec %{__ztsphp} $mod "$@"
EOF
cp -r NTS ZTS
@@ -190,6 +198,9 @@ fi
%changelog
+* Mon Mar 14 2022 Remi Collet <remi@remirepo.net> - 2.5.0-3
+- handle all SDL extensions in launcher (for sdl_mixer)
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 2.5.0-2
- rebuild for 8.1.0RC1