summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-19 07:25:39 +0200
committerRemi Collet <remi@remirepo.net>2021-06-19 07:25:39 +0200
commitf2a3848349ed7906aada095259bfe2565f2d8f59 (patch)
tree268bbae6d90cce2cd1be339b015155644ae5c5a6
parentda0d27d0caaf40400e0abbedcebe0dc0ba64fcd3 (diff)
update to 2.5.0
raise dependency on PHP 8.0
-rw-r--r--.gitignore9
-rw-r--r--PHPINFO7
-rw-r--r--REFLECTION326
-rw-r--r--php-pecl-sdl.spec37
4 files changed, 195 insertions, 184 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..6160b84
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,7 @@
+
+SDL
+
+SDL support => enabled
+SDL module version => 2.5.0
+SDL2 headers version => 2.0.14
+SDL2 library version => 2.0.14
diff --git a/REFLECTION b/REFLECTION
index da7104a..aeeaaa2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
+Extension [ <persistent> extension #84 SDL version 2.5.0 ] {
- Constants [738] {
Constant [ int SDL_BLENDMODE_NONE ] { 0 }
@@ -716,11 +716,11 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Constant [ int SDL_PREALLOC ] { 1 }
Constant [ int SDL_RLEACCEL ] { 2 }
Constant [ int SDL_DONTFREE ] { 4 }
- Constant [ int SDL_COMPILEDVERSION ] { 2012 }
+ Constant [ int SDL_COMPILEDVERSION ] { 2014 }
Constant [ int SDL_MAJOR_VERSION ] { 2 }
Constant [ int SDL_MINOR_VERSION ] { 0 }
- Constant [ int SDL_PATCHLEVEL ] { 12 }
- Constant [ string SDL_REVISION ] { hg-13609:34cc7d3b69d3 }
+ Constant [ int SDL_PATCHLEVEL ] { 14 }
+ Constant [ string SDL_REVISION ] { hg-14525:e52d96ea04fc }
Constant [ int SDL_WINDOW_FULLSCREEN ] { 1 }
Constant [ int SDL_WINDOW_OPENGL ] { 2 }
Constant [ int SDL_WINDOW_SHOWN ] { 4 }
@@ -745,7 +745,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Function [ <internal:SDL> function SDL_Init ] {
- Parameters [1] {
- Parameter #0 [ <optional> $flags ]
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
Function [ <internal:SDL> function SDL_InitSubSystem ] {
@@ -917,8 +917,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Window $window ]
- Parameter #1 [ <optional> &$x ]
- Parameter #2 [ <optional> &$y ]
+ Parameter #1 [ <optional> &$x = <default> ]
+ Parameter #2 [ <optional> &$y = <default> ]
}
}
Function [ <internal:SDL> function SDL_SetWindowSize ] {
@@ -933,8 +933,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Window $window ]
- Parameter #1 [ <optional> &$x ]
- Parameter #2 [ <optional> &$y ]
+ Parameter #1 [ <optional> &$x = <default> ]
+ Parameter #2 [ <optional> &$y = <default> ]
}
}
Function [ <internal:SDL> function SDL_SetWindowMinimumSize ] {
@@ -949,8 +949,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Window $window ]
- Parameter #1 [ <optional> &$x ]
- Parameter #2 [ <optional> &$y ]
+ Parameter #1 [ <optional> &$x = <default> ]
+ Parameter #2 [ <optional> &$y = <default> ]
}
}
Function [ <internal:SDL> function SDL_SetWindowMaximumSize ] {
@@ -965,8 +965,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Window $window ]
- Parameter #1 [ <optional> &$x ]
- Parameter #2 [ <optional> &$y ]
+ Parameter #1 [ <optional> &$x = <default> ]
+ Parameter #2 [ <optional> &$y = <default> ]
}
}
Function [ <internal:SDL> function SDL_SetWindowBordered ] {
@@ -988,7 +988,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Window $window ]
Parameter #1 [ <required> array $rects ]
- Parameter #2 [ <optional> $numrect ]
+ Parameter #2 [ <optional> $numrect = <default> ]
}
}
Function [ <internal:SDL> function SDL_SetWindowGrab ] {
@@ -1152,8 +1152,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [4] {
Parameter #0 [ <required> $renderer ]
Parameter #1 [ <required> $texture ]
- Parameter #2 [ <required> SDL_Rect or NULL $srcrect ]
- Parameter #3 [ <required> SDL_Rect or NULL $dstrect ]
+ Parameter #2 [ <required> ?SDL_Rect $srcrect ]
+ Parameter #3 [ <required> ?SDL_Rect $dstrect ]
}
}
Function [ <internal:SDL> function SDL_RenderCopyEx ] {
@@ -1161,10 +1161,10 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [7] {
Parameter #0 [ <required> $renderer ]
Parameter #1 [ <required> $texture ]
- Parameter #2 [ <required> SDL_Rect or NULL $srcrect ]
- Parameter #3 [ <required> SDL_Rect or NULL $dstrect ]
+ Parameter #2 [ <required> ?SDL_Rect $srcrect ]
+ Parameter #3 [ <required> ?SDL_Rect $dstrect ]
Parameter #4 [ <required> $angle ]
- Parameter #5 [ <required> SDL_Point or NULL $center ]
+ Parameter #5 [ <required> ?SDL_Point $center ]
Parameter #6 [ <required> $flip ]
}
}
@@ -1189,7 +1189,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Parameter #1 [ <required> $x1 ]
Parameter #2 [ <required> $y1 ]
Parameter #3 [ <required> $x2 ]
- Parameter #4 [ <optional> $y2 ]
+ Parameter #4 [ <optional> $y2 = <default> ]
}
}
Function [ <internal:SDL> function SDL_RenderPresent ] {
@@ -1249,8 +1249,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Parameter #3 [ <required> $depth ]
Parameter #4 [ <required> $Rmask ]
Parameter #5 [ <required> $Gmask ]
- Parameter #6 [ <optional> $Bmask ]
- Parameter #7 [ <optional> $Amask ]
+ Parameter #6 [ <optional> $Bmask = <default> ]
+ Parameter #7 [ <optional> $Amask = <default> ]
}
}
Function [ <internal:SDL> function SDL_FreeSurface ] {
@@ -1311,9 +1311,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [4] {
Parameter #0 [ <required> SDL_Surface $src ]
- Parameter #1 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #1 [ <required> ?SDL_rect $srcrect ]
Parameter #2 [ <required> SDL_Surface $dst ]
- Parameter #3 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #3 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
Function [ <internal:SDL> function SDL_LowerBlit ] {
@@ -1329,9 +1329,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [4] {
Parameter #0 [ <required> SDL_Surface $src ]
- Parameter #1 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #1 [ <required> ?SDL_rect $srcrect ]
Parameter #2 [ <required> SDL_Surface $dst ]
- Parameter #3 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #3 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
Function [ <internal:SDL> function SDL_LowerBlitScaled ] {
@@ -1347,9 +1347,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [4] {
Parameter #0 [ <required> SDL_Surface $src ]
- Parameter #1 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #1 [ <required> ?SDL_rect $srcrect ]
Parameter #2 [ <required> SDL_Surface $dst ]
- Parameter #3 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #3 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
Function [ <internal:SDL> function SDL_SaveBMP_RW ] {
@@ -1357,7 +1357,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Surface $surface ]
Parameter #1 [ <required> SDL_RWops &$rwops ]
- Parameter #2 [ <optional> $freedst ]
+ Parameter #2 [ <optional> $freedst = <default> ]
}
}
Function [ <internal:SDL> function SDL_SaveBMP ] {
@@ -1379,7 +1379,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Surface $surface ]
Parameter #1 [ <required> $flag ]
- Parameter #2 [ <optional> $key ]
+ Parameter #2 [ <optional> $key = <default> ]
}
}
Function [ <internal:SDL> function SDL_GetColorKey ] {
@@ -1454,7 +1454,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Surface $surface ]
Parameter #1 [ <required> SDL_PixelFormat $format ]
- Parameter #2 [ <optional> $flags ]
+ Parameter #2 [ <optional> $flags = <default> ]
}
}
Function [ <internal:SDL> function SDL_ConvertSurfaceFormat ] {
@@ -1462,7 +1462,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> SDL_Surface $surface ]
Parameter #1 [ <required> $format ]
- Parameter #2 [ <optional> $flags ]
+ Parameter #2 [ <optional> $flags = <default> ]
}
}
Function [ <internal:SDL> function SDL_ConvertPixels ] {
@@ -1551,7 +1551,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Parameter #0 [ <required> $flags ]
Parameter #1 [ <required> $title ]
Parameter #2 [ <required> $message ]
- Parameter #3 [ <optional> SDL_Window or NULL $window ]
+ Parameter #3 [ <optional> ?SDL_Window $window = <default> ]
}
}
Function [ <internal:SDL> function SDL_ShowMessageBox ] {
@@ -1605,8 +1605,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [4] {
Parameter #0 [ <required> SDL_Palette $palette ]
Parameter #1 [ <required> array $colors ]
- Parameter #2 [ <optional> $first ]
- Parameter #3 [ <optional> $ncolors ]
+ Parameter #2 [ <optional> $first = <default> ]
+ Parameter #3 [ <optional> $ncolors = <default> ]
}
}
Function [ <internal:SDL> function SDL_AllocFormat ] {
@@ -1723,7 +1723,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> SDL_Window $window ]
- Parameter #1 [ <optional> SDL_GLContext $context ]
+ Parameter #1 [ <optional> SDL_GLContext $context = <default> ]
}
}
Function [ <internal:SDL> function SDL_GL_GetCurrentWindow ] {
@@ -1851,7 +1851,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Function [ <internal:SDL> function SDL_VideoInit ] {
- Parameters [1] {
- Parameter #0 [ <optional> $drivername ]
+ Parameter #0 [ <optional> $drivername = <default> ]
}
}
Function [ <internal:SDL> function SDL_VideoQuit ] {
@@ -1912,7 +1912,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> $displayIndex ]
Parameter #1 [ <required> SDL_DisplayMode $desired ]
- Parameter #2 [ <optional> &$closest ]
+ Parameter #2 [ <optional> &$closest = <default> ]
}
}
Function [ <internal:SDL> function SDL_IsScreenSaverEnabled ] {
@@ -1933,8 +1933,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Function [ <internal:SDL> function SDL_GetPowerInfo ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$secs ]
- Parameter #1 [ <optional> &$pct ]
+ Parameter #0 [ <optional> &$secs = <default> ]
+ Parameter #1 [ <optional> &$pct = <default> ]
}
}
Function [ <internal:SDL> function SDL_GetPlatform ] {
@@ -1950,8 +1950,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Function [ <internal:SDL> function SDL_GetKeyboardState ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$numkeys ]
- Parameter #1 [ <optional> $allkeys ]
+ Parameter #0 [ <optional> &$numkeys = <default> ]
+ Parameter #1 [ <optional> $allkeys = <default> ]
}
}
Function [ <internal:SDL> function SDL_GetModState ] {
@@ -2094,15 +2094,15 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Function [ <internal:SDL> function SDL_GetMouseState ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$x ]
- Parameter #1 [ <optional> &$y ]
+ Parameter #0 [ <optional> &$x = <default> ]
+ Parameter #1 [ <optional> &$y = <default> ]
}
}
Function [ <internal:SDL> function SDL_GetRelativeMouseState ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$x ]
- Parameter #1 [ <optional> &$y ]
+ Parameter #0 [ <optional> &$x = <default> ]
+ Parameter #1 [ <optional> &$y = <default> ]
}
}
Function [ <internal:SDL> function SDL_WarpMouseInWindow ] {
@@ -2316,7 +2316,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $fp ]
- Parameter #1 [ <optional> $autoclose ]
+ Parameter #1 [ <optional> $autoclose = <default> ]
}
}
Function [ <internal:SDL> function SDL_RWFromMem ] {
@@ -2330,7 +2330,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $buf ]
- Parameter #1 [ <optional> $size ]
+ Parameter #1 [ <optional> $size = <default> ]
}
}
Function [ <internal:SDL> function SDL_RWsize ] {
@@ -2359,7 +2359,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Parameter #0 [ <required> SDL_RWops $RWops ]
Parameter #1 [ <required> &$buffer ]
Parameter #2 [ <required> $size ]
- Parameter #3 [ <optional> $number ]
+ Parameter #3 [ <optional> $number = <default> ]
}
}
Function [ <internal:SDL> function SDL_RWwrite ] {
@@ -2367,8 +2367,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [4] {
Parameter #0 [ <required> SDL_RWops $RWops ]
Parameter #1 [ <required> $buffer ]
- Parameter #2 [ <optional> $size ]
- Parameter #3 [ <optional> $number ]
+ Parameter #2 [ <optional> $size = <default> ]
+ Parameter #3 [ <optional> $number = <default> ]
}
}
Function [ <internal:SDL> function SDL_RWclose ] {
@@ -2483,9 +2483,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [3] {
- Property [ <default> public $type ]
- Property [ <default> public $key ]
- Property [ <default> public $motion ]
+ Property [ public $type = NULL ]
+ Property [ public $key = NULL ]
+ Property [ public $motion = NULL ]
}
- Methods [2] {
@@ -2593,9 +2593,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [3] {
- Property [ <default> public $r ]
- Property [ <default> public $g ]
- Property [ <default> public $b ]
+ Property [ public $r = 0 ]
+ Property [ public $g = 0 ]
+ Property [ public $b = 0 ]
}
- Methods [2] {
@@ -2630,9 +2630,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [3] {
- Property [ <default> public $flags ]
- Property [ <default> public $buttonid ]
- Property [ <default> public $text ]
+ Property [ public $flags = 0 ]
+ Property [ public $buttonid = 0 ]
+ Property [ public $text = 0 ]
}
- Methods [2] {
@@ -2668,13 +2668,13 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [7] {
- Property [ <default> public $flags ]
- Property [ <default> public $title ]
- Property [ <default> public $message ]
- Property [ <default> public $window ]
- Property [ <default> public $numbuttons ]
- Property [ <default> public $buttons ]
- Property [ <default> public $colors ]
+ Property [ public $flags = 0 ]
+ Property [ public $title = NULL ]
+ Property [ public $message = NULL ]
+ Property [ public $window = false ]
+ Property [ public $numbuttons = 0 ]
+ Property [ public $buttons = NULL ]
+ Property [ public $colors = NULL ]
}
- Methods [3] {
@@ -2684,9 +2684,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Parameter #0 [ <required> $flags ]
Parameter #1 [ <required> $title ]
Parameter #2 [ <required> $message ]
- Parameter #3 [ <optional> array $buttons ]
- Parameter #4 [ <optional> array $colors ]
- Parameter #5 [ <optional> SDL_Window $parentwindow ]
+ Parameter #3 [ <optional> array $buttons = <default> ]
+ Parameter #4 [ <optional> array $colors = <default> ]
+ Parameter #5 [ <optional> SDL_Window $parentwindow = <default> ]
}
}
@@ -3007,10 +3007,10 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [4] {
- Property [ <default> public $r ]
- Property [ <default> public $g ]
- Property [ <default> public $b ]
- Property [ <default> public $a ]
+ Property [ public $r = 0 ]
+ Property [ public $g = 0 ]
+ Property [ public $b = 0 ]
+ Property [ public $a = 0 ]
}
- Methods [2] {
@@ -3044,10 +3044,10 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [4] {
- Property [ <default> public $ncolors ]
- Property [ <default> public $version ]
- Property [ <default> public $refcount ]
- Property [ <default> public $colors ]
+ Property [ public $ncolors = 0 ]
+ Property [ public $version = 0 ]
+ Property [ public $refcount = 0 ]
+ Property [ public $colors = NULL ]
}
- Methods [9] {
@@ -3109,8 +3109,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> array $colors ]
- Parameter #1 [ <optional> $first ]
- Parameter #2 [ <optional> $ncolors ]
+ Parameter #1 [ <optional> $first = <default> ]
+ Parameter #2 [ <optional> $ncolors = <default> ]
}
}
}
@@ -3128,22 +3128,22 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [16] {
- Property [ <default> public $format ]
- Property [ <default> public $BitsPerPixel ]
- Property [ <default> public $BytesPerPixel ]
- Property [ <default> public $Rmask ]
- Property [ <default> public $Gmask ]
- Property [ <default> public $Bmask ]
- Property [ <default> public $Amask ]
- Property [ <default> public $Rloss ]
- Property [ <default> public $Gloss ]
- Property [ <default> public $Bloss ]
- Property [ <default> public $Aloss ]
- Property [ <default> public $Rshift ]
- Property [ <default> public $Gshift ]
- Property [ <default> public $Bshift ]
- Property [ <default> public $Ashift ]
- Property [ <default> public $palette ]
+ Property [ public $format = 0 ]
+ Property [ public $BitsPerPixel = 0 ]
+ Property [ public $BytesPerPixel = 0 ]
+ Property [ public $Rmask = 0 ]
+ Property [ public $Gmask = 0 ]
+ Property [ public $Bmask = 0 ]
+ Property [ public $Amask = 0 ]
+ Property [ public $Rloss = 0 ]
+ Property [ public $Gloss = 0 ]
+ Property [ public $Bloss = 0 ]
+ Property [ public $Aloss = 0 ]
+ Property [ public $Rshift = 0 ]
+ Property [ public $Gshift = 0 ]
+ Property [ public $Bshift = 0 ]
+ Property [ public $Ashift = 0 ]
+ Property [ public $palette = NULL ]
}
- Methods [8] {
@@ -3227,9 +3227,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [3] {
- Property [ <default> public $pitch ]
- Property [ <default> public $h ]
- Property [ <default> public $count ]
+ Property [ public $pitch = 0 ]
+ Property [ public $h = 0 ]
+ Property [ public $count = 0 ]
}
- Methods [9] {
@@ -3313,20 +3313,20 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [4] {
- Property [ <default> public $x ]
- Property [ <default> public $y ]
- Property [ <default> public $w ]
- Property [ <default> public $h ]
+ Property [ public $x = 0 ]
+ Property [ public $y = 0 ]
+ Property [ public $w = 0 ]
+ Property [ public $h = 0 ]
}
- Methods [8] {
Method [ <internal:SDL, ctor> public method __construct ] {
- Parameters [4] {
- Parameter #0 [ <optional> int $x ]
- Parameter #1 [ <optional> int $y ]
- Parameter #2 [ <optional> int $w ]
- Parameter #3 [ <optional> int $y ]
+ Parameter #0 [ <optional> int $x = <default> ]
+ Parameter #1 [ <optional> int $y = <default> ]
+ Parameter #2 [ <optional> int $w = <default> ]
+ Parameter #3 [ <optional> int $y = <default> ]
}
}
@@ -3396,8 +3396,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [2] {
- Property [ <default> public $x ]
- Property [ <default> public $y ]
+ Property [ public $x = 0 ]
+ Property [ public $y = 0 ]
}
- Methods [2] {
@@ -3444,7 +3444,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $fp ]
- Parameter #1 [ <optional> $autoclose ]
+ Parameter #1 [ <optional> $autoclose = <default> ]
}
}
@@ -3460,13 +3460,13 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $buf ]
- Parameter #1 [ <optional> $size ]
+ Parameter #1 [ <optional> $size = <default> ]
}
}
}
- Properties [1] {
- Property [ <default> public $type ]
+ Property [ public $type = 0 ]
}
- Methods [23] {
@@ -3513,7 +3513,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> &$buffer ]
Parameter #1 [ <required> $size ]
- Parameter #2 [ <optional> $number ]
+ Parameter #2 [ <optional> $number = <default> ]
}
}
@@ -3521,8 +3521,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [3] {
Parameter #0 [ <required> $buffer ]
- Parameter #1 [ <optional> $size ]
- Parameter #2 [ <optional> $number ]
+ Parameter #1 [ <optional> $size = <default> ]
+ Parameter #2 [ <optional> $number = <default> ]
}
}
@@ -3641,9 +3641,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [3] {
- Property [ <default> public $mode ]
- Property [ <default> public $colorKey ]
- Property [ <default> public $binarizationCutoff ]
+ Property [ public $mode = 0 ]
+ Property [ public $colorKey = 0 ]
+ Property [ public $binarizationCutoff = 0 ]
}
- Methods [2] {
@@ -3693,13 +3693,13 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [7] {
- Property [ <default> public $flags ]
- Property [ <default> public $w ]
- Property [ <default> public $h ]
- Property [ <default> public $pitch ]
- Property [ <default> public $format ]
- Property [ <default> public $clip_rect ]
- Property [ <default> public $pixels ]
+ Property [ public $flags = 0 ]
+ Property [ public $w = 0 ]
+ Property [ public $h = 0 ]
+ Property [ public $pitch = 0 ]
+ Property [ public $format = NULL ]
+ Property [ public $clip_rect = NULL ]
+ Property [ public $pixels = NULL ]
}
- Methods [30] {
@@ -3712,8 +3712,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Parameter #3 [ <required> $depth ]
Parameter #4 [ <required> $Rmask ]
Parameter #5 [ <required> $Gmask ]
- Parameter #6 [ <optional> $Bmask ]
- Parameter #7 [ <optional> $Amask ]
+ Parameter #6 [ <optional> $Bmask = <default> ]
+ Parameter #7 [ <optional> $Amask = <default> ]
}
}
@@ -3767,18 +3767,18 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method Blit ] {
- Parameters [3] {
- Parameter #0 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #0 [ <required> ?SDL_rect $srcrect ]
Parameter #1 [ <required> SDL_Surface $dst ]
- Parameter #2 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #2 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
Method [ <internal:SDL> public method UpperBlit ] {
- Parameters [3] {
- Parameter #0 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #0 [ <required> ?SDL_rect $srcrect ]
Parameter #1 [ <required> SDL_Surface $dst ]
- Parameter #2 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #2 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
@@ -3794,18 +3794,18 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method BlitScaled ] {
- Parameters [3] {
- Parameter #0 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #0 [ <required> ?SDL_rect $srcrect ]
Parameter #1 [ <required> SDL_Surface $dst ]
- Parameter #2 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #2 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
Method [ <internal:SDL> public method UpperBlitScaled ] {
- Parameters [3] {
- Parameter #0 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #0 [ <required> ?SDL_rect $srcrect ]
Parameter #1 [ <required> SDL_Surface $dst ]
- Parameter #2 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #2 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
@@ -3821,9 +3821,9 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method SoftStretch ] {
- Parameters [3] {
- Parameter #0 [ <required> SDL_rect or NULL $srcrect ]
+ Parameter #0 [ <required> ?SDL_rect $srcrect ]
Parameter #1 [ <required> SDL_Surface $dst ]
- Parameter #2 [ <optional> SDL_rect or NULL &$dstrect ]
+ Parameter #2 [ <optional> ?SDL_rect &$dstrect = <default> ]
}
}
@@ -3831,7 +3831,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> SDL_RWops &$rwops ]
- Parameter #1 [ <optional> $freedst ]
+ Parameter #1 [ <optional> $freedst = <default> ]
}
}
@@ -3853,7 +3853,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $flag ]
- Parameter #1 [ <optional> $key ]
+ Parameter #1 [ <optional> $key = <default> ]
}
}
@@ -3928,7 +3928,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> SDL_PixelFormat $format ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #1 [ <optional> $flags = <default> ]
}
}
@@ -3936,7 +3936,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $format ]
- Parameter #1 [ <optional> $flags ]
+ Parameter #1 [ <optional> $flags = <default> ]
}
}
}
@@ -3954,10 +3954,10 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [4] {
- Property [ <default> public $format ]
- Property [ <default> public $w ]
- Property [ <default> public $h ]
- Property [ <default> public $refresh_rate ]
+ Property [ public $format = 0 ]
+ Property [ public $w = 0 ]
+ Property [ public $h = 0 ]
+ Property [ public $refresh_rate = 0 ]
}
- Methods [2] {
@@ -4020,13 +4020,13 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
}
- Properties [7] {
- Property [ <default> public $id ]
- Property [ <default> public $flags ]
- Property [ <default> public $x ]
- Property [ <default> public $y ]
- Property [ <default> public $w ]
- Property [ <default> public $h ]
- Property [ <default> public $title ]
+ Property [ public $id = 0 ]
+ Property [ public $flags = 0 ]
+ Property [ public $x = 0 ]
+ Property [ public $y = 0 ]
+ Property [ public $w = 0 ]
+ Property [ public $h = 0 ]
+ Property [ public $title = NULL ]
}
- Methods [44] {
@@ -4171,8 +4171,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method GetPosition ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$x ]
- Parameter #1 [ <optional> &$y ]
+ Parameter #0 [ <optional> &$x = <default> ]
+ Parameter #1 [ <optional> &$y = <default> ]
}
}
@@ -4187,8 +4187,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method GetSize ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$w ]
- Parameter #1 [ <optional> &$h ]
+ Parameter #0 [ <optional> &$w = <default> ]
+ Parameter #1 [ <optional> &$h = <default> ]
}
}
@@ -4203,8 +4203,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method GetMinimumSize ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$x ]
- Parameter #1 [ <optional> &$y ]
+ Parameter #0 [ <optional> &$x = <default> ]
+ Parameter #1 [ <optional> &$y = <default> ]
}
}
@@ -4219,8 +4219,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method GetMaximumSize ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$x ]
- Parameter #1 [ <optional> &$y ]
+ Parameter #0 [ <optional> &$x = <default> ]
+ Parameter #1 [ <optional> &$y = <default> ]
}
}
@@ -4242,7 +4242,7 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
- Parameters [2] {
Parameter #0 [ <required> array $rects ]
- Parameter #1 [ <optional> $numrect ]
+ Parameter #1 [ <optional> $numrect = <default> ]
}
}
@@ -4297,8 +4297,8 @@ Extension [ <persistent> extension #162 SDL version 2.4.0 ] {
Method [ <internal:SDL> public method GL_GetDrawableSize ] {
- Parameters [2] {
- Parameter #0 [ <optional> &$x ]
- Parameter #1 [ <optional> &$y ]
+ Parameter #0 [ <optional> &$x = <default> ]
+ Parameter #1 [ <optional> &$y = <default> ]
}
}
diff --git a/php-pecl-sdl.spec b/php-pecl-sdl.spec
index de47a33..127bff4 100644
--- a/php-pecl-sdl.spec
+++ b/php-pecl-sdl.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-sdl
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -14,14 +14,16 @@
Summary: Simple DirectMedia Layer for PHP
Name: %{?scl_prefix}php-pecl-sdl
-Version: 2.4.0
+Version: 2.5.0
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/sdl
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRequires: %{?scl_prefix}php-devel >= 7.4
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: SDL2-devel
@@ -42,24 +44,13 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# filter private shared
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -77,7 +68,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
cd NTS
-sed -e 's/2.3.0/%{version}/' -i src/php_sdl.h
+#sed -e 's/2.3.0/%{version}/' -i src/php_sdl.h
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SDL_VERSION/{s/.* "//;s/".*$//;p}' src/php_sdl.h)
@@ -155,13 +146,13 @@ done
: Minimal load test for NTS extension
%{__php} -n -q \
-d extension=NTS/modules/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
+ --modules | grep -i '^%{pecl_name}$'
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} -n -q \
-d extension=ZTS/modules/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
+ --modules | grep -i '^%{pecl_name}$'
%endif
@@ -199,6 +190,10 @@ fi
%changelog
+* Sat Jun 19 2021 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+- raise dependency on PHP 8.0
+
* Mon Aug 24 2020 Remi Collet <remi@remirepo.net> - 2.4.0-1
- update to 2.4.0
- drop patch merged upstream