summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-01 15:03:47 +0200
committerRemi Collet <remi@php.net>2023-09-01 15:03:47 +0200
commit97cd54ab667f650fd5acf662be4bdab6191237e0 (patch)
tree9e5d10689f006ff21c4c86cff711cef551739db0
parentc605a7cc6e4fea0cd2eeaa55f5277843f33d0af9 (diff)
build out of sources treeHEADmaster
-rw-r--r--php-pecl-sdl.spec37
1 files changed, 21 insertions, 16 deletions
diff --git a/php-pecl-sdl.spec b/php-pecl-sdl.spec
index b8180f9..7677af5 100644
--- a/php-pecl-sdl.spec
+++ b/php-pecl-sdl.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-sdl
#
-# Copyright (c) 2013-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -11,15 +11,17 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global pecl_name sdl
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Simple DirectMedia Layer for PHP
Name: %{?scl_prefix}php-pecl-sdl
Version: 2.7.0
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP-3.01
Group: Development/Languages
URL: https://pecl.php.net/package/sdl
-Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -33,7 +35,6 @@ Requires: %{__php}
%if %{with_zts}
Requires: %{__ztsphp}
%endif
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -65,9 +66,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
-cd NTS
+cd %{sources}
#sed -e 's/2.3.0/%{version}/' -i src/php_sdl.h
# Sanity check, really often broken
@@ -92,6 +92,7 @@ done
exec %{__php} $mod "$@"
EOF
+mkdir NTS
%if %{with_zts}
cat << 'EOF' | tee zts-phpsdl
#!/bin/sh
@@ -102,7 +103,7 @@ done
exec %{__ztsphp} $mod "$@"
EOF
-cp -r NTS ZTS
+mkdir ZTS
%endif
@@ -114,15 +115,16 @@ peclconf() {
--with-sdl \
--with-php-config=$1
}
-cd NTS
-%{_bindir}/phpize
-peclconf %{_bindir}/php-config
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+peclconf %{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
-peclconf %{_bindir}/zts-php-config
+peclconf %{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -144,7 +146,7 @@ install -Dpm 755 zts-phpsdl %{buildroot}%{_bindir}/zts-phpsdl
%endif
# Documentation
-cd NTS
+cd %{sources}
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -185,7 +187,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{_bindir}/phpsdl
%{php_extdir}/%{pecl_name}.so
@@ -198,6 +200,9 @@ fi
%changelog
+* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 2.7.0-2
+- build out of sources tree
+
* Sat Jul 23 2022 Remi Collet <remi@remirepo.net> - 2.7.0-1
- update to 2.7.0
- drop patch merged upstream