summaryrefslogtreecommitdiffstats
path: root/php-pecl-scrypt.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-17 15:07:12 +0200
committerRemi Collet <remi@php.net>2022-08-17 15:07:12 +0200
commitc2fc70789a513ae0f4905f1d1b2691ffd71f8e53 (patch)
tree0ac2bc381d509a4c51e460f2a109959c07807134 /php-pecl-scrypt.spec
parent6419b68c59964b09973615cddb66c7b8bd107bc9 (diff)
update to 1.4.3
Diffstat (limited to 'php-pecl-scrypt.spec')
-rw-r--r--php-pecl-scrypt.spec43
1 files changed, 14 insertions, 29 deletions
diff --git a/php-pecl-scrypt.spec b/php-pecl-scrypt.spec
index fdc861a..9ee8994 100644
--- a/php-pecl-scrypt.spec
+++ b/php-pecl-scrypt.spec
@@ -7,10 +7,11 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-scrypt
+%scl_package php-pecl-scrypt
%endif
+%bcond_without tests
+
%global pecl_name scrypt
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
@@ -20,20 +21,17 @@
%endif
Summary: Scrypt hashing function
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.4.2
-Release: 10%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.4.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/DomBlack/php-scrypt/pull/56.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/DomBlack/php-scrypt/pull/59.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -45,23 +43,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -80,9 +61,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr
-%patch1 -p1 -b .pr
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SCRYPT_VERSION/{s/.* "//;s/".*$//;p}' php_scrypt.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -175,12 +153,14 @@ cd NTS
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
+%endif
%if %{with_zts}
@@ -190,6 +170,7 @@ cd ../ZTS
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
@@ -197,6 +178,7 @@ NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
%endif
+%endif
%files
@@ -214,6 +196,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Aug 17 2022 Remi Collet <remi@remirepo.net> - 1.4.3-1
+- update to 1.4.3
+
* Thu Aug 4 2022 Remi Collet <remi@remirepo.net> - 1.4.2-10
- add patch for aarch64 from
https://github.com/DomBlack/php-scrypt/pull/59