summaryrefslogtreecommitdiffstats
path: root/php-pecl-scoutapm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-scoutapm.spec')
-rw-r--r--php-pecl-scoutapm.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/php-pecl-scoutapm.spec b/php-pecl-scoutapm.spec
index f3bd25c..3212b1c 100644
--- a/php-pecl-scoutapm.spec
+++ b/php-pecl-scoutapm.spec
@@ -18,11 +18,13 @@
Summary: Native Extension Component for ScoutAPM's PHP Agent
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.2.0
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
+Patch0: https://patch-diff.githubusercontent.com/raw/scoutapp/scout-apm-php-ext/pull/69.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
@@ -77,6 +79,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
+%patch0 -p1
+
: Check version
extver=$(sed -n '/#define PHP_SCOUTAPM_VERSION /{s/.* "//;s/".*$//;p}' zend_scoutapm.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -189,11 +193,7 @@ TEST_PHP_EXECUTABLE=%{__php} \
: Upstream test suite for ZTS extension
cd ../ZTS
TEST_PHP_ARGS="$DEPS -d zend_extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-%if "%{php_version}" > "8.0"
-REPORT_EXIT_STATUS=0 \
-%else
REPORT_EXIT_STATUS=1 \
-%endif
NO_INTERACTION=1 \
TEST_PHP_EXECUTABLE=%{__ztsphp} \
%{__ztsphp} -n run-tests.php --show-diff
@@ -215,6 +215,10 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
%changelog
+* Fri Feb 5 2021 Remi Collet <remi@remirepo.net> - 1.2.0-2
+- add patch for PHP 8 / ZTS from
+ https://github.com/scoutapp/scout-apm-php-ext/pull/69
+
* Thu Feb 4 2021 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0
- open https://github.com/scoutapp/scout-apm-php-ext/issues/67