summaryrefslogtreecommitdiffstats
path: root/php-pecl-scoutapm.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-23 14:58:16 +0100
committerRemi Collet <remi@php.net>2021-12-23 14:58:16 +0100
commit8c2f31f53ec65735658f91e9084ff319cbb664b0 (patch)
treee08952a86cc2ab6bf806a494eabcc277ebed07b3 /php-pecl-scoutapm.spec
parente47a2c4eb5571dd1caa5fb95211ef8d68f6a65af (diff)
update to 1.5.0
add dependency on json extension add patch to allow build with shared json from https://github.com/scoutapp/scout-apm-php-ext/pull/99
Diffstat (limited to 'php-pecl-scoutapm.spec')
-rw-r--r--php-pecl-scoutapm.spec27
1 files changed, 21 insertions, 6 deletions
diff --git a/php-pecl-scoutapm.spec b/php-pecl-scoutapm.spec
index 1808137..e29d041 100644
--- a/php-pecl-scoutapm.spec
+++ b/php-pecl-scoutapm.spec
@@ -17,24 +17,28 @@
Summary: Native Extension Component for ScoutAPM's PHP Agent
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.4.3
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 1.5.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
+Patch0: https://patch-diff.githubusercontent.com/raw/scoutapp/scout-apm-php-ext/pull/99.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
BuildRequires: %{?scl_prefix}php-devel < 8.1
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
# Only for tests
BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-pdo
BuildRequires: %{?scl_prefix}php-pdo_sqlite
BuildRequires: libcurl-devel
-BuildRequires: %{_bindir}/ps
+BuildRequires: /bin/ps
+Requires: %{?scl_prefix}php-json%{?_isa}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -79,6 +83,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
pushd NTS
+%patch0 -p1 -b .pr99
+
: Check version
extver=$(sed -n '/#define PHP_SCOUTAPM_VERSION /{s/.* "//;s/".*$//;p}' zend_scoutapm.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -165,19 +171,22 @@ fi
%check
+DEPS="-n"
+[ -f %{php_extdir}/json.so ] && DEPS="$DEPS -d extension=json.so"
+
# Minimal load test for NTS extension
-%{__php} --no-php-ini \
+%{__php} $DEPS \
--define zend_extension=$PWD/NTS/modules/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%if %{with_zts}
# Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
+%{__ztsphp} $DEPS \
--define zend_extension=$PWD/ZTS/modules/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%endif
-DEPS="-n -d extension=curl.so -d extension=pdo.so -d extension=pdo_sqlite.so"
+DEPS="$DEPS -d extension=curl.so -d extension=pdo.so -d extension=pdo_sqlite.so"
: Upstream test suite for NTS extension
cd NTS
@@ -209,6 +218,12 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Thu Dec 23 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- add dependency on json extension
+- add patch to allow build with shared json from
+ https://github.com/scoutapp/scout-apm-php-ext/pull/99
+
* Fri Nov 5 2021 Remi Collet <remi@remirepo.net> - 1.4.3-2
- EL-9 build