summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-17 14:10:29 +0200
committerRemi Collet <remi@remirepo.net>2019-09-17 14:10:29 +0200
commit0de852a71966008b1204c1dfa736425826243d37 (patch)
treedd750efdd3e93839bb8e6ae914e2e629ad7bc124
New package
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION8
-rw-r--r--build.patch110
-rw-r--r--php-pecl-scoutapm.spec234
6 files changed, 367 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..60740ba
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,4 @@
+
+scoutapm
+
+Version => 0.0.3
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..d2ecd74
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,8 @@
+Extension [ <persistent> extension #201 scoutapm version 0.0.3 ] {
+
+ - Functions {
+ Function [ <internal:scoutapm> function scoutapm_get_calls ] {
+ }
+ }
+}
+
diff --git a/build.patch b/build.patch
new file mode 100644
index 0000000..b24db12
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,110 @@
+From cbadc2e10829d02b45a7f94de3cf21b88e032bfc Mon Sep 17 00:00:00 2001
+From: James Titcumb <james@asgrim.com>
+Date: Tue, 17 Sep 2019 12:25:23 +0100
+Subject: [PATCH 3/3] Use PHP_VERSION_ID to check for existence of zif_handler
+
+---
+ zend_scoutapm.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/zend_scoutapm.h b/zend_scoutapm.h
+index 2d3500b..1c0bc12 100644
+--- a/zend_scoutapm.h
++++ b/zend_scoutapm.h
+@@ -50,7 +50,7 @@ ZEND_END_MODULE_GLOBALS(scoutapm)
+ #endif
+
+ /* zif_handler is not always defined, so define this roughly equivalent */
+-#ifndef zif_handler
++#if PHP_VERSION_ID < 70200
+ typedef void (*zif_handler)(INTERNAL_FUNCTION_PARAMETERS);
+ #endif
+
+
+diff --git a/zend_scoutapm.c b/zend_scoutapm.c
+index 96117c4..e32e2f9 100644
+--- a/zend_scoutapm.c
++++ b/zend_scoutapm.c
+@@ -174,10 +174,12 @@ static PHP_RINIT_FUNCTION(scoutapm)
+ */
+ static PHP_RSHUTDOWN_FUNCTION(scoutapm)
+ {
++ int i, j;
++
+ SCOUTAPM_DEBUG_MESSAGE("Freeing stacks... ");
+
+- for (int i = 0; i < SCOUTAPM_G(observed_stack_frames_count); i++) {
+- for (int j = 0; j < SCOUTAPM_G(observed_stack_frames)[i].argc; j++) {
++ for (i = 0; i < SCOUTAPM_G(observed_stack_frames_count); i++) {
++ for (j = 0; j < SCOUTAPM_G(observed_stack_frames)[i].argc; j++) {
+ zval_ptr_dtor(&(SCOUTAPM_G(observed_stack_frames)[i].argv[j]));
+ }
+ free(SCOUTAPM_G(observed_stack_frames)[i].argv);
+@@ -264,6 +266,8 @@ static double scoutapm_microtime()
+ */
+ static void record_observed_stack_frame(const char *function_name, double microtime_entered, double microtime_exited, int argc, zval *argv)
+ {
++ int i;
++
+ if (argc > 0) {
+ SCOUTAPM_DEBUG_MESSAGE("Adding observed stack frame for %s (%s) ... ", function_name, Z_STRVAL(argv[0]));
+ } else {
+@@ -280,7 +284,7 @@ static void record_observed_stack_frame(const char *function_name, double microt
+ SCOUTAPM_G(observed_stack_frames)[SCOUTAPM_G(observed_stack_frames_count)].argc = argc;
+ SCOUTAPM_G(observed_stack_frames)[SCOUTAPM_G(observed_stack_frames_count)].argv = calloc(argc, sizeof(zval));
+
+- for (int i = 0; i < argc; i++) {
++ for (i = 0; i < argc; i++) {
+ ZVAL_COPY(
+ &(SCOUTAPM_G(observed_stack_frames)[SCOUTAPM_G(observed_stack_frames_count)].argv[i]),
+ &(argv[i])
+@@ -295,6 +299,7 @@ static void record_observed_stack_frame(const char *function_name, double microt
+ Fetch all the recorded function or method calls recorded by the ScoutAPM extension. */
+ PHP_FUNCTION(scoutapm_get_calls)
+ {
++ int i, j;
+ zval item, arg_items, arg_item;
+ ZEND_PARSE_PARAMETERS_NONE();
+
+@@ -302,7 +307,7 @@ PHP_FUNCTION(scoutapm_get_calls)
+
+ array_init(return_value);
+
+- for (int i = 0; i < SCOUTAPM_G(observed_stack_frames_count); i++) {
++ for (i = 0; i < SCOUTAPM_G(observed_stack_frames_count); i++) {
+ array_init(&item);
+
+ add_assoc_str_ex(
+@@ -331,7 +336,7 @@ PHP_FUNCTION(scoutapm_get_calls)
+ );
+
+ array_init(&arg_items);
+- for (int j = 0; j < SCOUTAPM_G(observed_stack_frames)[i].argc; j++) {
++ for (j = 0; j < SCOUTAPM_G(observed_stack_frames)[i].argc; j++) {
+ /* Must copy the argument to a new zval, otherwise it gets freed and we get segfault. */
+ ZVAL_COPY(&arg_item, &(SCOUTAPM_G(observed_stack_frames)[i].argv[j]));
+ add_next_index_zval(&arg_items, &arg_item);
+diff --git a/tests/011-pdo-exec.phpt b/tests/011-pdo-exec.phpt
+index 178e18d..6f48a56 100644
+--- a/tests/011-pdo-exec.phpt
++++ b/tests/011-pdo-exec.phpt
+@@ -7,9 +7,8 @@ Calls to PDO::exec are logged
+ --FILE--
+ <?php
+ $dbh = new PDO('sqlite::memory:');
+-echo $dbh->exec("CREATE TABLE foo (col INT PRIMARY KEY)");
+-echo $dbh->exec("INSERT INTO foo (col) VALUES (1), (2) ");
+-echo "\n";
++$dbh->exec("CREATE TABLE foo (col INT PRIMARY KEY)");
++$dbh->exec("INSERT INTO foo (col) VALUES (1), (2) ");
+
+ $calls = scoutapm_get_calls();
+ var_dump($calls[0]['function']);
+@@ -18,7 +17,6 @@ var_dump($calls[1]['function']);
+ var_dump($calls[1]['argv'][0]);
+ ?>
+ --EXPECTF--
+-02
+ string(9) "PDO->exec"
+ string(38) "CREATE TABLE foo (col INT PRIMARY KEY)"
+ string(9) "PDO->exec"
diff --git a/php-pecl-scoutapm.spec b/php-pecl-scoutapm.spec
new file mode 100644
index 0000000..4d00d9e
--- /dev/null
+++ b/php-pecl-scoutapm.spec
@@ -0,0 +1,234 @@
+# remirepo spec file for php-pecl-scoutapm
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-scoutapm
+%endif
+
+%global pecl_name scoutapm
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 15-%{pecl_name}.ini
+
+Summary: Native Extension Component for ScoutAPM's PHP Agent
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 0.0.3
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+License: PHP
+URL: http://pecl.php.net/package/%{pecl_name}
+
+Patch0: build.patch
+
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 7.1
+BuildRequires: %{?scl_prefix}php-pear
+# Only for tests
+BuildRequires: %{?scl_prefix}php-curl
+BuildRequires: %{?scl_prefix}php-pdo
+BuildRequires: %{?scl_prefix}php-pdo_sqlite
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.3"
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter private shared
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+ScoutAPM's extension for PHP provides additional capabilities to application
+monitoring over just using the base PHP userland library.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+pushd NTS
+%patch0 -p1
+
+: Check version
+extver=$(sed -n '/#define PHP_SCOUTAPM_VERSION /{s/.* "//;s/".*$//;p}' zend_scoutapm.h)
+if test "x${extver}" != "x%{version}%{?prever}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}%{?prever}.
+ exit 1
+fi
+popd
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+zend_extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --enable-scoutapm \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --enable-scoutapm \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+%{!?_licensedir:install -Dpm 644 LICENSE %{buildroot}%{pecl_docdir}/%{pecl_name}/LICENSE}
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+# Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define zend_extension=$PWD/NTS/modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_zts}
+# Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define zend_extension=$PWD/ZTS/modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+%endif
+
+: Upstream test suite for NTS extension
+cd NTS
+TEST_PHP_ARGS="-n -d extension=curl.so -d extension=pdo.so -d extension=pdo_sqlite.so -d zend_extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+NO_INTERACTION=1 \
+TEST_PHP_EXECUTABLE=%{__php} \
+%{__php} -n run-tests.php --show-diff
+
+%if %{with_zts}
+: Upstream test suite for ZTS extension
+cd ../ZTS
+TEST_PHP_ARGS="-n -d extension=curl.so -d extension=pdo.so -d extension=pdo_sqlite.so -d zend_extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+NO_INTERACTION=1 \
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Sep 17 2019 Remi Collet <remi@remirepo.net> - 0.0.3-1
+- update to 0.0.3
+- add build patch from
+ https://github.com/scoutapp/scout-apm-php-ext/pull/32
+ https://github.com/scoutapp/scout-apm-php-ext/pull/34
+
+* Tue Sep 17 2019 Remi Collet <remi@remirepo.net> - 0.0.2-1
+- initial package