summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-16 14:14:48 +0100
committerRemi Collet <remi@remirepo.net>2019-01-16 14:14:48 +0100
commit387e321016e4299b361137bcc5e20c8485d1512b (patch)
tree1b5630a7f94fdeab758147052c99b42cd04821a5
parent599384c73c1869a8e6dee15bc6fc5a96a3d4fd7d (diff)
0.1.1 released
-rw-r--r--REFLECTION68
-rw-r--r--php-pecl-sandbox.spec5
2 files changed, 70 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index dd06604..1b00bd9 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
Extension [ <persistent> extension #141 sandbox version 0.1.1 ] {
- - Classes [1] {
- Class [ <internal:sandbox> class sandbox\Runtime ] {
+ - Classes [2] {
+ Class [ <internal:sandbox> final class sandbox\Runtime ] {
- Constants [0] {
}
@@ -26,6 +26,70 @@ Extension [ <persistent> extension #141 sandbox version 0.1.1 ] {
}
}
}
+
+ Class [ <internal:sandbox> class sandbox\Exception extends ErrorException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $severity ]
+ }
+
+ - Methods [11] {
+ Method [ <internal:Core, inherits ErrorException, ctor> public method __construct ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $severity ]
+ Parameter #3 [ <optional> $filename ]
+ Parameter #4 [ <optional> $lineno ]
+ Parameter #5 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits ErrorException> final public method getSeverity ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
}
}
diff --git a/php-pecl-sandbox.spec b/php-pecl-sandbox.spec
index f713e11..77cc2d5 100644
--- a/php-pecl-sandbox.spec
+++ b/php-pecl-sandbox.spec
@@ -14,7 +14,7 @@
Summary: Isolated environment
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.1.1
-Release: 0%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%%{pecl_name}-%{version}.tgz
@@ -189,6 +189,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Jan 16 2019 Remi Collet <remi@remirepo.Net> - 0.1.1-1
+- update for official release
+
* Thu Jan 10 2019 Remi Collet <remi@remirepo.Net> - 0.1.1-0
- initial package
- test build for upcoming version 0.1.1 (beta)