summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-18 14:28:24 +0200
committerRemi Collet <remi@remirepo.net>2019-09-18 14:28:24 +0200
commit0f11f856d066676d2becf1e88b75ce1e150f019f (patch)
tree28d8e703f32abe0a54f1e5ff28c5358de1411a34
parent0760fb4b704d44965fe213fa33e4a66372b6c460 (diff)
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-sandbox.spec11
-rw-r--r--sandbox-php74.patch23
4 files changed, 7 insertions, 31 deletions
diff --git a/PHPINFO b/PHPINFO
index b2c5759..e86ef0c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
sandbox
sandbox support => enabled
-sandbox version => 0.1.2
+sandbox version => 0.1.3
diff --git a/REFLECTION b/REFLECTION
index c43e671..b138b6f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #145 sandbox version 0.1.2 ] {
+Extension [ <persistent> extension #143 sandbox version 0.1.3 ] {
- Classes [2] {
Class [ <internal:sandbox> final class sandbox\Runtime ] {
diff --git a/php-pecl-sandbox.spec b/php-pecl-sandbox.spec
index 76e6501..dfb9860 100644
--- a/php-pecl-sandbox.spec
+++ b/php-pecl-sandbox.spec
@@ -13,14 +13,12 @@
Summary: Isolated environment
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.1.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.1.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-php74.patch
-
BuildRequires: %{?scl_prefix}php-zts-devel > 7.1
BuildRequires: %{?scl_prefix}php-pear
@@ -102,8 +100,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{pecl_name}-%{version}
-%patch0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/define PHP_SANDBOX_VERSION/{s/.* "//;s/".*$//;p}' php_sandbox.h)
if test "x${extver}" != "x%{version}"; then
@@ -196,6 +192,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Sep 18 2019 Remi Collet <remi@remirepo.net> - 0.1.3-1
+- update to 0.1.3
+
* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 0.1.2-2
- add suptream patch for 7.4.0RC1
diff --git a/sandbox-php74.patch b/sandbox-php74.patch
deleted file mode 100644
index 323381b..0000000
--- a/sandbox-php74.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From c4b8428acca58387d80698d3428a53148ac72a7e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 6 Sep 2019 11:04:22 +0200
-Subject: [PATCH] fix for 7.4
-
----
- src/copy.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/copy.c b/src/copy.c
-index c0af965..e2f959b 100644
---- a/src/copy.c
-+++ b/src/copy.c
-@@ -223,7 +223,9 @@ static inline zend_op* php_sandbox_copy_opcodes(zend_op_array *op_array, zval *l
- case ZEND_JMP:
- case ZEND_FAST_CALL:
- case ZEND_DECLARE_ANON_CLASS:
-+#if PHP_VERSION_ID < 70400
- case ZEND_DECLARE_ANON_INHERITED_CLASS:
-+#endif
- opline->op1.jmp_addr = &copy[opline->op1.jmp_addr - op_array->opcodes];
- break;
-