summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--PHPINFO13
-rw-r--r--REFLECTION170
-rw-r--r--php-pecl-runkit7.spec237
5 files changed, 432 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..3aabf69
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,13 @@
+
+runkit
+
+runkit support => enabled
+version => 2.0.1
+Custom Superglobal support => enabled
+Sandbox Support => disable or unavailable
+Runtime Manipulation => enabled
+spl_object_id alias support => unnecessary in php 7.2+
+
+Directive => Local Value => Master Value
+runkit.superglobal => no value => no value
+runkit.internal_override => Off => Off
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..ca00149
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,170 @@
+Extension [ <persistent> extension #15 runkit version 2.0.1 ] {
+
+ - INI {
+ Entry [ runkit.superglobal <PERDIR,SYSTEM> ]
+ Current = ''
+ }
+ Entry [ runkit.internal_override <SYSTEM> ]
+ Current = '0'
+ }
+ }
+
+ - Constants [17] {
+ Constant [ integer RUNKIT_IMPORT_FUNCTIONS ] { 1 }
+ Constant [ integer RUNKIT_IMPORT_CLASS_METHODS ] { 2 }
+ Constant [ integer RUNKIT_IMPORT_CLASS_CONSTS ] { 4 }
+ Constant [ integer RUNKIT_IMPORT_CLASS_PROPS ] { 8 }
+ Constant [ integer RUNKIT_IMPORT_CLASS_STATIC_PROPS ] { 16 }
+ Constant [ integer RUNKIT_IMPORT_CLASSES ] { 30 }
+ Constant [ integer RUNKIT_IMPORT_OVERRIDE ] { 32 }
+ Constant [ string RUNKIT_VERSION ] { 2.0.1 }
+ Constant [ integer RUNKIT_ACC_RETURN_REFERENCE ] { 67108864 }
+ Constant [ integer RUNKIT_ACC_PUBLIC ] { 256 }
+ Constant [ integer RUNKIT_ACC_PROTECTED ] { 512 }
+ Constant [ integer RUNKIT_ACC_PRIVATE ] { 1024 }
+ Constant [ integer RUNKIT_ACC_STATIC ] { 1 }
+ Constant [ integer RUNKIT_OVERRIDE_OBJECTS ] { 32768 }
+ Constant [ integer RUNKIT_FEATURE_MANIPULATION ] { 1 }
+ Constant [ integer RUNKIT_FEATURE_SUPERGLOBALS ] { 1 }
+ Constant [ integer RUNKIT_FEATURE_SANDBOX ] { 0 }
+ }
+
+ - Functions {
+ Function [ <internal:runkit> function runkit_zval_inspect ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_object_id ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $obj ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_superglobals ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:runkit> function runkit_import ] {
+ }
+ Function [ <internal:runkit> function runkit_function_add ] {
+
+ - Parameters [7] {
+ Parameter #0 [ <required> $funcname ]
+ Parameter #1 [ <required> $arglist_or_closure ]
+ Parameter #2 [ <optional> $code_or_doc_comment ]
+ Parameter #3 [ <optional> $return_by_reference ]
+ Parameter #4 [ <optional> $doc_comment ]
+ Parameter #5 [ <optional> $return_type ]
+ Parameter #6 [ <optional> $is_strict ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_function_remove ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $funcname ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_function_rename ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $funcname ]
+ Parameter #1 [ <required> $newname ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_function_redefine ] {
+
+ - Parameters [7] {
+ Parameter #0 [ <required> $funcname ]
+ Parameter #1 [ <required> $arglist_or_closure ]
+ Parameter #2 [ <required> $code_or_doc_comment ]
+ Parameter #3 [ <optional> $return_by_reference ]
+ Parameter #4 [ <optional> $doc_comment ]
+ Parameter #5 [ <optional> $return_type ]
+ Parameter #6 [ <optional> $is_strict ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_function_copy ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $funcname ]
+ Parameter #1 [ <required> $targetname ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_method_add ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $classname ]
+ Parameter #1 [ <required> $methodname ]
+ Parameter #2 [ <required> $arglist_or_closure ]
+ Parameter #3 [ <optional> $code_or_flags ]
+ Parameter #4 [ <optional> $flags_or_doc_comment ]
+ Parameter #5 [ <optional> $doc_comment ]
+ Parameter #6 [ <optional> $return_type ]
+ Parameter #7 [ <optional> $is_strict ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_method_redefine ] {
+
+ - Parameters [8] {
+ Parameter #0 [ <required> $classname ]
+ Parameter #1 [ <required> $methodname ]
+ Parameter #2 [ <required> $arglist_or_closure ]
+ Parameter #3 [ <optional> $code_or_flags ]
+ Parameter #4 [ <optional> $flags_or_doc_comment ]
+ Parameter #5 [ <optional> $doc_comment ]
+ Parameter #6 [ <optional> $return_type ]
+ Parameter #7 [ <optional> $is_strict ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_method_remove ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $classname ]
+ Parameter #1 [ <required> $methodname ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_method_rename ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $classname ]
+ Parameter #1 [ <required> $methodname ]
+ Parameter #2 [ <required> $newname ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_method_copy ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $dClass ]
+ Parameter #1 [ <required> $dMethod ]
+ Parameter #2 [ <required> $sClass ]
+ Parameter #3 [ <optional> $sMethod ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_constant_redefine ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $constname ]
+ Parameter #1 [ <required> $value ]
+ Parameter #2 [ <optional> $newVisibility ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_constant_remove ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $constname ]
+ }
+ }
+ Function [ <internal:runkit> function runkit_constant_add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $constname ]
+ Parameter #1 [ <required> $value ]
+ Parameter #2 [ <optional> $newVisibility ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-runkit7.spec b/php-pecl-runkit7.spec
new file mode 100644
index 0000000..8311b0d
--- /dev/null
+++ b/php-pecl-runkit7.spec
@@ -0,0 +1,237 @@
+# remirepo spec file for php-pecl-runkit7
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-runkit7
+%else
+%global _root_prefix %{_prefix}
+%endif
+
+# The project is runkit7 but the extension is only runkit
+%global proj_name runkit7
+%global pecl_name runkit
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+%global with_tests 0%{!?_without_tests:1}
+
+%global upstream_version 2.0.1
+#global upstream_prever RC1
+
+Name: %{?sub_prefix}php-pecl-%{proj_name}
+Summary: For all those things you... shouldn't have been doing anyway... but surely do!
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD
+# Temporary
+URL: https://github.com/%{proj_name}/%{proj_name}
+
+# Temporary
+Source0: https://github.com/%{proj_name}/%{proj_name}/releases/download/%{version}/%{proj_name}-%{version}.tgz
+
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+%endif
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php71u-pecl-%{proj_name} <= %{version}
+Obsoletes: php71w-pecl-%{proj_name} <= %{version}
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{proj_name} <= %{version}
+Obsoletes: php72w-pecl-%{proj_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.3"
+Obsoletes: php73u-pecl-%{proj_name} <= %{version}
+Obsoletes: php73w-pecl-%{proj_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%endif
+%{?filter_setup}
+
+
+%description
+Replace, rename, and remove user defined functions, methods, and constants.
+Define customized superglobal variables for general purpose use.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -c -q
+mv %{proj_name}-%{upstream_version}%{?upstream_prever} NTS
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+extver=$(sed -n '/#define PHP_RUNKIT_VERSION/{s/.*\t"//;s/".*$//;p}' runkit.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
+ : Error: Upstream RUNKIT version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
+ : Update the pdover macro and rebuild.
+ exit 1
+fi
+cd ..
+
+cat << 'EOF' | tee %{ini_name}
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+
+; Configuration
+;runkit.superglobal = ''
+:runkit.internal_override = 0
+EOF
+
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+%{?dtsenable}
+
+peclconf() {
+%configure \
+ --enable-runkit \
+ --with-libdir=%{_lib} \
+ --with-php-config=$1
+}
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# Install XML package description
+install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+# install config file
+install -Dpm644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -Dpm644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{proj_name}/$i
+done
+
+
+%check
+export REPORT_EXIT_STATUS=1
+
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+# ignore FPM tests because of systemd monitoring changing output
+rm ?TS/tests/runkit_fpm*
+# segfault on 32-bit see https://github.com/runkit7/runkit7/issues/185
+rm ?TS/tests/runkit_import_class_extend.phpt
+
+: Upstream test suite NTS extension
+cd NTS
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+%{__php} -n run-tests.php -q --show-diff
+%endif
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ $modules \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite ZTS extension
+cd ../ZTS
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n $modules -d extension=$PWD/modules/%{pecl_name}.so" \
+%{__ztsphp} -n run-tests.php -q --show-diff
+%endif
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{proj_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{proj_name}
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+%changelog
+* Thu Apr 4 2019 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- initial package
+- open https://github.com/runkit7/runkit7/issues/185 segfault
+- open https://github.com/runkit7/runkit7/issues/184 bad archive